FTB authlib isn't running properly

Discussion in 'Tech Support' started by Koni, Feb 12, 2016.

  1. Koni

    Koni Guest

    Title:
    FTB authlib isn't running properly
    Launcher Version:
    1.4.11 (according to the console)
    Modpack:
    All of them (Namely FTB Infinity)
    Modpack Version:
    2.3.5 (Recommended)
    Log Link:
    Details of the issue:
    Hey.
    I've been trying to log into an FTB Infinity server for quite some time now, but I can't seem to get past the authentication server or whatever it is.

    To keep it simplistic yet detailed, I'll give you an example of what I'm doing.

    -Opened the FTB Launcher
    -Everything works OK on startup
    -I click a modpack, then I press "Launch"
    -Error message stating "Minecraft authentication servers might be down. Check @ help.mojang.com"

    I checked the auth servers multiple times a day whenever I try getting on, everything is online and okay.
    I assume that it revolves around my PC for some odd reason. I have installed heavy malware protection after supposedly getting a remote access trojan, that may have to do with it. However, I've tried disabling the protection and it still doesn't work.
    I've also tried re-installing the modpack, no luck.
     
  2. Moasseman

    Moasseman New Member

    Options tab -> force update -> try again
     
  3. jikuja

    jikuja Launcher Dev Launcher Developer

    Reinstall java.
     
  4. Koni

    Koni Guest

    Neither of the following worked.

    New error message.
    No usable authlib available. Please check your firewall rules and network connection. Can't start MC without working authlib. Launch button will be disabled.""
     
    Last edited: Feb 12, 2016
  5. Moasseman

    Moasseman New Member

    Check your firewall rules and network connection.
     
  6. Koni

    Koni Guest

    Thank you for such an in-depth answer!

    Two questions.

    What should I enable through the firewall?
    What is "authlib" anyway?
     
  7. RealKC

    RealKC Popular Member

    Java, The FTB Launcher, Minecraft. Also the "authlib" is probably the authentification library
     
  8. Koni

    Koni Guest

    Enabled all the .exe java-related files, the FTB launcher, Minecraft... Still doesn't work.

    I'm not sure , but something is definitely screwing around with my PC's firewall. Probably all the antivirus/ anti-malware stuff I installed recently..
     
  9. TomScheeper

    TomScheeper New Member

    Try disabling all anti-virus related programs and your firewall, then restart your computer and try to launch again.
     
  10. jikuja

    jikuja Launcher Dev Launcher Developer

    Just uninstall all java installations and install newest 64-bit JRE. (Install 32-bit also if required for browser plugin)

    is indicator for broken java installation
     

Share This Page