Solved Friends can't join server

Discussion in 'Server Tech Support' started by TheOnlyMohammed, Feb 15, 2013.

  1. TheOnlyMohammed

    TheOnlyMohammed New Member

    Hey,

    So recently I've been trying to get a FTB server running so that me and a friend can get on to play. but the problem is that my friend can't join the server. when he tries it gives him an error that says something along the lines of "Cannot connect to server: The ip is invalid on local machine or the ip is invalid on remote machine".



    NOTES: I run a normal vanilla minecraft server and that works great. so the port-forwarding and the ip is correct but something about FTB just doesnt work.

    Any ideas?

    Thanks in advance.
     
  2. dc0110

    dc0110 New Member

    Whitelist or modpack version would be the first two places to look.
     
  3. TheOnlyMohammed

    TheOnlyMohammed New Member

    I tried that but that didnt work either.
    Heres a picture of what my friend sees when he trys to join:

    ftb Error.png
     
  4. maxpowa

    maxpowa New Member

    You can connect to the server properly, correct? And he can connect to other servers correctly?
     
  5. TheOnlyMohammed

    TheOnlyMohammed New Member

    yes i can join the server and no my friend cant join any server, even ones from the ftbservers.com list. We have checked his firewall and java is allowed in-bound and out-bound connections.
     
  6. TheOnlyMohammed

    TheOnlyMohammed New Member

    Any ideas ?
     
  7. maxpowa

    maxpowa New Member

    Yep, get him to try the following.

    -Press and hold the windows key, then press the R key, then release (i.e. press Win + R). This causes the Run dialog to appear (bottom left).
    -Copy and paste the following command into the Run dialog:
    setx _JAVA_OPTIONS -Djava.net.preferIPv4Stack=true
    - Press OK. You may see a black screen appear and disappear very quickly.

    Try again
     
  8. TheOnlyMohammed

    TheOnlyMohammed New Member

    YES IT WORKED!!! Thank you so much!!! we should be best friends ;)
     
  9. Austinminiman

    Austinminiman New Member

    i have a similar problem but i get a slightly different error message. i have tried all of the above but none of them have worked. i have connected to my friends server many times before but it just wont work any more :(

    Untitled.png
     
  10. ZorbA

    ZorbA New Member

    I have the same problem as above and I already did everything I can’t solve. Can someone help me
     

Share This Page