1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Mac Fix for launcher on mac (Minecraft crashes immediately)

Discussion in '[Archived] Tech Support' started by portablejim, Nov 11, 2012.

Thread Status:
Not open for further replies.
  1. CryoFear

    CryoFear New Member

    Well the launcher works Ita just it won't update and also when I launch the game it doesn't download the mods so it just give me good ol regular minecraft. And I have java 7 have tried going down to 6 but it didn't do jack for m. What do I do?
     
  2. Ashzification

    Ashzification New Member

    Have you tried force updating in the options tab? If that still doesn't work, follow the trouble shooting steps in my guide (linked in signature)
     
  3. CryoFear

    CryoFear New Member

    Ok I will do that and get back to you as soon as I can try your advise. Thank you
     
  4. CryoFear

    CryoFear New Member

    ok so i tired what you said and the force update doesnt work
     
  5. Jacobmorganian

    Jacobmorganian New Member

    I had a conversation with the admins, they said I can submit a pull request on the GitHub, and what that means is that it could possibly end up on the download page. :D! P.S, I Checked, and it does update successfully. Sadly, no download on the forums. But mabie on the FTB downloads page soon!

    Also I would like to know what problem CryoFear is having. I may be able to help him out sense i have a little experience with java and MC not playing nice.
     
  6. Jacobmorganian

    Jacobmorganian New Member

    Opps i was on page 3 and not page 4, Anyway i think CryoFear is having Network issues. Or mabie his java is wrong. Have you tried to do the steps in the beginning of this thread? It may help your problem. If not try re-downloading the launcher.
     
  7. CryoFear

    CryoFear New Member

    I have tried all of the before but that was before I got your launcher so hen I get the chance ether during or after work today I will try everything from the beginning and try it with your launcher thank you for all of the help thou
     
  8. CryoFear

    CryoFear New Member

    really the only problem right now is that the launcher wont update and when i do launch the game it wont download the mods that is really the only problem i am having with the launcher that you have put up. other then that your launcher is the shit and i love it.
     
  9. Jacobmorganian

    Jacobmorganian New Member

    Are you using my launcher? Did you download it before the admin took it down? Also my launcher does work with updates. If that is was your wondering. Also. You cant just type in the commands that are in the beginning of this thread. You have to change directories into the place where the launcher is. So if you haveit on your desktop. You open terminal, do "ch Desktop" and then do the commands. If you have a a folder on the desktop do "cd Folder name" and it should work.
     
  10. CryoFear

    CryoFear New Member

    it lives!!!!!!! thank you my friend.
     
  11. Jacobmorganian

    Jacobmorganian New Member

    Your Welcome, Here to help! Also the new update with MindCrack pack will NOT work will servers. Be careful.
    EDIT!
    The new Mindcrack pack will not work with servers that are not updated.
     
  12. hunterglory

    hunterglory New Member

    i placed the code in terminal and it launches the launcher but when i press lauch at direwolf20 mod pack it gives me
    Fixed Minecraft Path: Field was private static java.io.File net.minecraft.client.Minecraft.an and then it stays there and nothing happends
     
  13. SaintNicster

    SaintNicster New Member

    You need to give us the full log and exact command you used if you want any attempts at help.
     
    Ashzification likes this.
  14. hunterglory

    hunterglory New Member

    Logging in...
    Login complete.
    Direwolf20
    Modpack is up to date.
    dirs mk'd
    Current: 1.4.6
    Required: 1.4.6
    Setting MinMemory to 256
    Setting MaxMemory to 1024
    Loading jars...
    Loading URL: file:/Volumes/Habets/Minecraft/Direwolf20/instMods/MinecraftForge.zip
    Loading URL: file:/Volumes/Habets/Minecraft/Direwolf20/minecraft/bin/minecraft.jar
    Loading URL: file:/Volumes/Habets/Minecraft/Direwolf20/minecraft/bin/lwjgl.jar
    Loading URL: file:/Volumes/Habets/Minecraft/Direwolf20/minecraft/bin/lwjgl_util.jar
    Loading URL: file:/Volumes/Habets/Minecraft/Direwolf20/minecraft/bin/jinput.jar
    Loading natives...
    Natives loaded...
    Loading minecraft class
    mc = class net.minecraft.client.Minecraft
    field amount: 67
    Fixed Minecraft Path: Field was private static java.io.File net.minecraft.client.Minecraft.an
    after that nothing happends
    and the code i used:
    cd ~/Desktop/Minecraft/
    export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
    java -jar FTB1.2.2.jar
     
  15. Jacobmorganian

    Jacobmorganian New Member

    Do you still have Java 6 installed? Or do you not have Java 7 installed? Looks to me like it just stoped working. The terminal will give our errors and complaints, you cant do a thing about it. But it seems unusual for it to just stop. It set up the Ram, it loaded the proper set up Jars for minecraft. Everything is fine until it loads the minecraft.class. Ive never had this issue, (or mabie i have, i dont pay attemtion to the termial unless something stops working). Also, i say that you went into the "minecraft" directory, is that where your Launcher is? Because the Java fix command only works if the Jar is in the same directory as where you hit the command. Also looks like the Launcher doesn't have the correct permissions to go into the directory where all the minecraft stuff is stored. If you look it sais "Fixed Minecraft Path: Field was private static java.io.file..." Thats a red flag (to me) that something is private to external users and programs that shouldn't be. ALSO, i tried to launch the DireWolf20 pack and it didn't work. (the download didn't finish) but thats because I packaged the FTB launcher to to a .APP Application so i wouldn't have to take those painful steps.
    If you would like to have the Launcher i made that automatically launches FTB, im sorry but i cant post it here. The admins would most likely take this post down or something ugly and i would get into trouble.
     
  16. Cortland

    Cortland New Member

    So I tried doing all this and couldn't find the extension file to rename .icn so i was just messing around and found that opening the app bundler then selecting the ftb launcher .jar file then hit create app it should create a app folder then u just open and it works.
     
  17. Benjaminm97

    Benjaminm97 New Member

    I dont wanna look like a retard here or something, but how do i open the terminal (New Mac user)
     
  18. Seilaerion

    Seilaerion New Member

    A few ways:
    1) Go to Applications>Utilities and run the Terminal app. You could also make a shortcut to it.
    2) Cmd + Space to open Spotlight, type in Terminal(partially or fully) and run it from there. I usually just do this.
    3) Open Launchpad and find it in there.

    Amongst a number of other methods lol.
     
  19. Whovian

    Whovian New Member

    Oh wow, it works. I thought I was using Java 1.6 already, though. Why wasn't it working before?

    EDIT: Yep, according to java -version, I have

    Which is Java 1.6. Doesn't the script specified switch from Java 1.6 to Java 1.6?
     
  20. Van_Tastic

    Van_Tastic New Member

    Hi,

    Even by using the code in the first page I still can't get FTB to work on my macbook. It doesn't quit as it used to do but it gets stuck on "Converting world" whenever I try to create a new world.

    Here's my pastebin log:
    http://pastebin.com/bv6DnGxa
    Ant help would be much appreciated.
     
Thread Status:
Not open for further replies.

Share This Page