Mac Fix for launcher on mac (Minecraft crashes immediately)

Status
Not open for further replies.

portablejim

New Member
Jul 29, 2019
267
0
1
It is known that the mac launcher does not work, minecraft crashes on launch.

To fix it run
Code:
export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
in terminal just before launching the launcher from terminal.

or

You can download an app file <coming> to do this for you
 

portablejim

New Member
Jul 29, 2019
267
0
1
The full process for launching properly is
  1. Save the launcher jar on the Desktop in a folder called ftb
  2. Open terminal and type

    Code:
    cd ~/Desktop/ftb/
    export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
    java -jar FTB_Launcher.jar
  3. The launcher should launch and work properly
 

natchu96

New Member
Jul 29, 2019
52
0
0
IT LIVES!!!!!

Thanks! Now if only there was a way to do this without copy-pasting your post into the terminal every time.

Googled it. came up with Automator workflows saved as application format. Well, that was easy O_0
 

portablejim

New Member
Jul 29, 2019
267
0
1
IT LIVES!!!!!

Thanks! Now if only there was a way to do this without copy-pasting your post into the terminal every time.

Googled it. came up with Automator workflows saved as application format. Well, that was easy O_0
There is a plan (I am fairly sure) to release the launcher in application format for mac that will do this. (Will be linked replacing the crossed out area on the first post). However, good solution.
 

emcginnis

New Member
Jul 29, 2019
3
0
0
Just like with Vanilla server you can make a launch.command file
Heres a one I threw together based on the code above

http://dl.dropbox.com/u/16704552/launch.command.zip

Just unzip and drop it into the same folder you have the FTB.jar in and double click.
If you get an error saying it doesn't have permission, open a new terminal window type in without the quotes "sudo chmod +x (drag launch.command here)" then hit enter.
Make sure you have a space between the "+x" and the file path.
 
  • Like
Reactions: Dravarden

Komoden

New Member
Jul 29, 2019
13
0
0
Have any of you tried simply starting it with this:
Code:
cd ~/Desktop/ftb/
java -jar FTB_Launcher.jar
This has worked for me. I find it weird though that the game cannot run without starting it this way. Especially since it doesn't throw any errors, but simply closes...
Have anyone investigated the cause for the odd behavior when launching the jar by double clicking it, or is it still a mystery why it acts the way it does?
 

portablejim

New Member
Jul 29, 2019
267
0
1
Have any of you tried simply starting it with this:
Code:
cd ~/Desktop/ftb/
java -jar FTB_Launcher.jar
This has worked for me. I find it weird though that the game cannot run without starting it this way. Especially since it doesn't throw any errors, but simply closes...
Have anyone investigated the cause for the odd behavior when launching the jar by double clicking it, or is it still a mystery why it acts the way it does?
If you have java 7 installed it will not work on OS X. If you are interested, read http://lwjgl.org/forum/index.php?topic=4711.0 .
 

Komoden

New Member
Jul 29, 2019
13
0
0
I have Java 7 installed... and it works fine for me.. at least im 98% certain i have Java 7, will have to check when i get back home..
I know of the issues with LWJGL, have been following the development of that thread for a while.. wanna get the new version. The one that ships with Minecraft has a nasty memoryleak when it comes to age-changing in Mystcraft (possibly also Nether/End, but not sure)
 

Dravarden

New Member
Jul 29, 2019
1,693
0
0
Just like with Vanilla server you can make a launch.command file
Heres a one I threw together based on the code above

http://dl.dropbox.com/u/16704552/launch.command.zip

Just unzip and drop it into the same folder you have the FTB.jar in and double click.
If you get an error saying it doesn't have permission, open a new terminal window type in without the quotes "sudo chmod +x (drag launch.command here)" then hit enter.
Make sure you have a space between the "+x" and the file path.
This one works the best, thanks!

Also, you can do an alias and put it anywhere you want, and rename it however you want
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
It is known that the mac launcher does not work, minecraft crashes on launch.

To fix it run
Code:
export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
in terminal just before launching the launcher from terminal.

or

You can download an app file <coming> to do this for you
Do you mind if I include this fix on my CP&S document?
This is what I would put:
# Mac crash errors and Login problems: check out this thread here: the OP
 

ghost20199

New Member
Jul 29, 2019
1
0
0
It is known that the mac launcher does not work, minecraft crashes on launch.

To fix it run
Code:
export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
in terminal just before launching the launcher from terminal.


I had the same problem but how can I start minacraft?? where is the folder java frameworks? the code I have to insert it into the terminal of mac
 

longboarderpbc

New Member
Jul 29, 2019
1
0
0
The full process for launching properly is
  1. Save the launcher jar on the Desktop in a folder called ftb
  2. Open terminal and type

    Code:
    cd ~/Desktop/ftb/
    export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
    java -jar FTB_Launcher.jar
  3. The launcher should launch and work properly
what do you mean by open the terminal
 

portablejim

New Member
Jul 29, 2019
267
0
1
what do you mean by open the terminal
You can open the terminal in two ways:
  • Go to Finder, click on "Applications", scroll down to "Utilities" and double click to open it. Scroll down to "Terminal" and double click on it.
  • Hit Command + Space (to open spotlight) and type "Terminal" (without the quotes).
 

Haidy777

New Member
Jul 29, 2019
4
0
0
The full process for launching properly is
  1. Save the launcher jar on the Desktop in a folder called ftb
  2. Open terminal and type

    Code:
    cd ~/Desktop/ftb/
    export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home
    java -jar FTB_Launcher.jar
  3. The launcher should launch and work properly
Thanks. Its now it's working again.
 
Status
Not open for further replies.