Botania - An innovative natural magic themed tech mod (Not in beta any more!)

Discussion in 'Mod Discussion' started by Vazkii, Feb 23, 2014.

  1. Heathen

    Heathen New Member

    Let me start out with this: Botania, awesome mod. That being said, is there any way to Tweak/Adjust (Modtweaker/Minetweaker/Config) the amount of mana required for the Orechid to function in Garden of Glass? Feels to low for me.
    I added in Cobblestone to the Orechids output dictionary to make it a bit harder to get Ore, but doesn't feel quite right.
     
  2. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    Considering how many ways to produce bulk quantities of mana there are, and the fact that Garden of Glass IS a challenge map, feels about right to me.

    A 5 x 5 field of endoflames with a mana spreader above them should be plenty to keep it going. May need an elvish spreader to keep up with mana throughput. Failing that, cake automation should be fairly trivial by the time you are worried about Orechid speed.
     
  3. Zandorum

    Zandorum Well-Known Member

    Their not saying its too slow, or requires too much mana; their saying it requires too little mana and want to make it harder.
     
  4. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    Ahh, I misunderstood.

    Outside of editing the minetweaker files, I'm not aware of any way to do this. And I'm not sure if it is possible even with Minetweaker because of how Botania does things. I tend to stay away from Minetweaker on general principles.

    Add in chances for Cobble, Dirt, Sand, and Gravel. That ought to make the odds of getting something useful lower. Too bad you can't weight it, or I'd say weight your cobble at 8:1, your dirt at 4:1, and your gravel/sand at 2:1, with your ores at 1:1. So you get one actual ore per, say, 15 iterations.
     
  5. Heathen

    Heathen New Member

    I used Minetweaker to add in weights for Cobblestone, Gravel and such. Minetweaker lets you do a Dump of everything the Orechid makes, and their respective weights; neat way to balance out Ores in your pack or add in new ones.

    Works pretty well, but I will just have to play around with the settings to get the right "feel" or getting Ores. I have Bees and Botania for resource production in a pack I am making, and would like to balance the two options out somewhat.

    I didn't see any option in Minetweaker to actually adjust mana costs of Botania flower operations unfortunately, and I have no intention of editing any of Vazkii's code to do so.
     
  6. Shiphty

    Shiphty Active Member

    I originally liked your mod, it's unique, there are many good ideas incorporated in it. However, the strong-arm approach to the passive mana flowers has turned me off to the mod. I might've stuck with it if their was an option to choose either way. If I have the option to try something or not I usually end up trying it, if I'm not given a choice I tend to dig in my heels. I wish you'd have given the option to turn that aspect off. As it is, it IS your mod and you've every right to do what you like with it. I'll move on and try other mods.
     
  7. TomeWyrm

    TomeWyrm Popular Member

    Try New Dawn, linked somewhere earlier in the thread.
     
  8. NoElement

    NoElement Active Member

    @Vazkii I have an Idea for you. I don't know if it was already added in the newer versions (Mostly playing regrowth atm) or if someone else gave that idea to you or you are already working on it. I posted this on the main minecraft forums a few days ago, but i figured that copy pasting this to here wouldn't hurt anyone.

    Basically, it is about the generating flowers and how to make them more interesting.

    As it stands, you try to make new and interesting ways to generate mana. However, most practical individuals simply use the endoflame a dozen times over with an timed dropper and call it a day.

    Which made me think on how a practical player like me would actually make more then one generating flower. Making other flowers better in mana generation would simply make me get that flower instead, and you probably know that. But, what if there was an benefit in using multiple generating flowers?

    I call my idea Yggdrasil's heart. Just imagine an manaspreader that only has an range of 1 (aka, you need an normal manaspreader (or multiple) nearby to transfer the mana). This "heart" gives an bonus the more different flowers it is connected to.

    Of course, the question is: How great is that bonus? Personally, among all the flowers that the "heart" is connected to, the most complex get's the largest bonus (say 15%, numbers may be balanced later) and every subsequent, less complex flower gets less and less. Obviously, that bonus is only for something like an narslimmus. If the most complex flower is an endoflame, the bonus would be only 5% or so.

    Sadly, it can be abused. Just make multiple hearts with different sets of flowers. My solution to that however is that multiple existing hearts interfer with each other, like the dayblooms of old.

    Taking the idea to it's final step, why not make an full-blown Yggdrasil?! Let the player connect the heart to some special logs, then make the player make an giant tree (aka yggdrasil). The logs need to be connected to the heart, but the greater the area they stretch (x+y+z), the more efficent the heart becomes.

    I hope this is good enough as an idea, Vazkii! And thanks for reading.
     
  9. TomeWyrm

    TomeWyrm Popular Member

    That's actually a neat idea mechanically speaking
     
  10. Stanislav1502

    Stanislav1502 Active Member

    If I setup an automated plant and planter for passive flowers, would that prevent their decay?
     
  11. Nova Sol

    Nova Sol Active Member

    Almost certain they store how long they've been active, so no.
     
  12. rouge_bare

    rouge_bare Well-Known Member

    If you mean constantly breaking and replanting passives, no it won't stop them decaying. You can slow their decay (for dayblooms and nightshades) by not having them planted when they cannot generate mana anyway (for instance during the day for nightshades) by planting them on enchanted soil, which is made by planting an overgrowth seed on dirt. Be aware you cannot reverse this process, and breaking the enchanted soil will return it to normal dirt. In the final 1.7.10 version released also re-added the decay config.
     
  13. Pyure

    Pyure Not Totally Useless

    Does anyone ever use the permanent passives you find in the wild? I can't remember what they're called, but the permanent dayblooms that get world-genned and don't decay.

    I've never actually figured out a decent use-case for these. I'm not going to build my entire base around one, and I don't like the idea of trying to send that mana from 1KM away to my base via a chain of spreaders.

    Is it possible to send mana wirelessly from pool to pool (using tablets or mirrors or something) ?

    Edit: just to be clear, I mean from far away, not via a chain. I'm familiar with sparks.
     
  14. rouge_bare

    rouge_bare Well-Known Member

    The primus flowers? They can be sorta useful if you set up near them. I actually did make use of a set as they were conviently located in a biome i wanted the metamorphic stone from. So i set up a marimorphisis automation there using the mana from the primal lotus.
    '
     
    Pyure likes this.
  15. TomeWyrm

    TomeWyrm Popular Member

    I'd use the mana pump and carts to transfer over THAT kind of distance. The spreaders and required chunk loading would be... laggy.

    That being said, so long as you did pool>spreader>pool>spreader? It would work.

    You might also be able to use the mana quarry trick to do wireless mana transport point-to-point... I honestly can't recall if I tried that.
     
  16. Someone Else 37

    Someone Else 37 Forum Addict

    There's also the possibility of using a clever system to drop mana tablets onto the pools and pick them up again when they're completely filled or emptied, then deposit them in an enderchest for transport to/from the home base... but I agree, transport via minecarts (and, optionally, those EnderIO teleportation tracks) would be much easier and more foolproof.
     
    Lethosos likes this.
  17. Rustoleum09

    Rustoleum09 New Member

    Can't figure out what is going on with Botania... My game crashes if botania is in the mods folder but if i take it out there's no issue...

    ---- Minecraft Crash Report ----

    WARNING: coremods are present:
    LoadingPlugin (RandomThings-MC1.10.2-3.7.6.jar)
    EnderCorePlugin (EnderCore-1.10.2-0.4.1.56-beta.jar)
    FMLPlugin (InventoryTweaks-1.61-58.jar)
    Contact their authors BEFORE contacting forge

    // Who set us up the TNT?

    Time: 10/30/16 4:09 PM
    Description: There was a severe problem during mod loading that has caused the game to fail

    net.minecraftforge.fml.common.LoaderException: java.lang.IllegalAccessError: tried to access field net.minecraft.item.ItemStack.field_77990_d from class cofh.api.energy.ItemEnergyContainer
    at net.minecraftforge.fml.common.LoadController.transition(LoadController.java:186)
    at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:802)
    at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:324)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:520)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:351)
    at net.minecraft.client.main.Main.main(SourceFile:124)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    Caused by: java.lang.IllegalAccessError: tried to access field net.minecraft.item.ItemStack.field_77990_d from class cofh.api.energy.ItemEnergyContainer
    at cofh.api.energy.ItemEnergyContainer.receiveEnergy(ItemEnergyContainer.java:66)
    at refinedstorage.item.ItemWirelessGrid.func_150895_a(ItemWirelessGrid.java:96)
    at vazkii.botania.client.core.handler.CorporeaAutoCompleteHandler.updateItemList(CorporeaAutoCompleteHandler.java:61)
    at vazkii.botania.client.core.proxy.ClientProxy.postInit(ClientProxy.java:236)
    at vazkii.botania.common.Botania.postInit(Botania.java:215)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:600)
    at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
    at com.google.common.eventbus.EventBus.post(EventBus.java:275)
    at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:239)
    at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:217)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
    at com.google.common.eventbus.EventBus.post(EventBus.java:275)
    at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:142)
    at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:800)
    ... 10 more


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.10.2
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 326105072 bytes (310 MB) / 1787297792 bytes (1704 MB) up to 2386558976 bytes (2276 MB)
    JVM Flags: 4 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx2560m -Xms256m -XX:permSize=256m
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP 9.32 Powered by Forge 12.18.2.2116 30 mods loaded, 30 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJ mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJ FML{8.0.99.99} [Forge Mod Loader] (forge-1.10.2-12.18.2.2116.jar)
    UCHIJ Forge{12.18.2.2116} [Minecraft Forge] (forge-1.10.2-12.18.2.2116.jar)
    UCHIJ Baubles{1.3.0} [Baubles] (Baubles-1.10.2-1.3.0.jar)
    UCHIJ BBG{5.0.0} [BetterBedrockGen] (BBG-1.9.4-5.0.0.jar)
    UCHIJ guideapi{@[email protected]} [Guide-API] (Guide-API-1.9.4-2.0.1-44.jar)
    UCHIJ JEI{3.12.8.323} [Just Enough Items] (jei_1.10.2-3.12.8.323.jar)
    UCHIJ BloodMagic{1.9.4-2.1.0-66} [Blood Magic: Alchemical Wizardry] (BloodMagic-1.9.4-2.1.0-66.jar)
    UCHIE Botania{r1.9-334} [Botania] (Botania r1.9-334.jar)
    UCHIJ Chameleon{1.10-2.1.7} [Chameleon] (Chameleon-1.10-2.1.7.jar)
    UCHIJ ElecCore{1.6.328} [ElecCore] (ElecCore-1.10.2-1.6.328.jar)
    UCHIJ deepresonance{1.2.9} [DeepResonance] (deepresonance-1.10-1.2.9.jar)
    UCHIJ endercore{1.10.2-0.4.1.56-beta} [EnderCore] (EnderCore-1.10.2-0.4.1.56-beta.jar)
    UCHIJ Waila{1.7.0} [Waila] (Waila-1.7.0-B3_1.9.4.jar)
    UCHIJ EnderIO{1.10.2-3.0.1.120_beta} [Ender IO] (EnderIO-1.10.2-3.0.1.120_beta.jar)
    UCHIJ inventorytweaks{1.61-58-a1fd884} [Inventory Tweaks] (InventoryTweaks-1.61-58.jar)
    UCHIJ mantle{1.10.2-1.1.1.194} [Mantle] (Mantle-1.10.2-1.1.1.jar)
    UCHIJ mcmultipart{1.2.1} [MCMultiPart] (MCMultiPart-1.2.1-universal.jar)
    UCHIJ notenoughwands{1.3.8} [Not Enough Wands] (notenoughwands-1.10-1.3.8.jar)
    UCHIJ randomthings{3.7.6} [Random Things] (RandomThings-MC1.10.2-3.7.6.jar)
    UCHIJ StorageDrawers{1.10.2-3.3.0} [Storage Drawers] (StorageDrawers-1.10.2-3.3.0.jar)
    UCHIJ refinedstorage{1.1.3} [Refined Storage] (refinedstorage-1.1.3.jar)
    UCHIJ xreliquary{1.10.2-1.3.3.581} [Reliquary] (Reliquary-1.10.2-1.3.3.581.jar)
    UCHIJ rftools{5.57} [RFTools] (rftools-1.10-5.57.jar)
    UCHIJ rftoolscontrol{1.5.1} [RFTools Control] (rftoolsctrl-1.10-1.5.1.jar)
    UCHIJ rftoolsdim{4.43} [RFTools Dimensions] (rftoolsdim-1.10-4.43.jar)
    UCHIJ tconstruct{1.10.2-2.5.6b.jenkins424} [Tinkers' Construct] (TConstruct-1.10.2-2.5.6b.jar)
    UCHIJ VeinMiner{0.34.1_1.9-73be663} [Vein Miner] (VeinMiner-0.34.1-1.9r571+73be663.jar)
    UCHIJ VeinMinerModSupport{0.34.1_1.9-73be663} [Mod Support] (VeinMiner-0.34.1-1.9r571+73be663.jar)
    UCHIJ xprings{1.2.0} [Experience Rings] (xprings-1.2.0.jar)
    Loaded coremods (and transformers):
    LoadingPlugin (RandomThings-MC1.10.2-3.7.6.jar)
    lumien.randomthings.asm.ClassTransformer
    EnderCorePlugin (EnderCore-1.10.2-0.4.1.56-beta.jar)
    com.enderio.core.common.transform.EnderCoreTransformer
    FMLPlugin (InventoryTweaks-1.61-58.jar)
    invtweaks.forge.asm.ContainerTransformer
    GL info: ' Vendor: 'Intel' Version: '4.4.0 - Build 20.19.15.4390' Renderer: 'Intel(R) HD Graphics 520'
    Pulsar/tconstruct loaded Pulses:
    - TinkerCommons (Enabled/Forced)
    - TinkerWorld (Enabled/Not Forced)
    - TinkerTools (Enabled/Not Forced)
    - TinkerHarvestTools (Enabled/Forced)
    - TinkerMeleeWeapons (Enabled/Forced)
    - TinkerRangedWeapons (Enabled/Forced)
    - TinkerModifiers (Enabled/Forced)
    - TinkerSmeltery (Enabled/Not Forced)
    - TinkerGadgets (Enabled/Not Forced)
    - TinkerOredict (Enabled/Forced)
    - TinkerIntegration (Enabled/Forced)
    - TinkerFluids (Enabled/Forced)
    - TinkerMaterials (Enabled/Forced)
    - TinkerModelRegister (Enabled/Forced)
    - WailaIntegration (Enabled/Not Forced)

    EnderIO: Found the following problem(s) with your installation (That does NOT mean that Ender IO caused the crash or was involved in it in any way. We add this information to help finding common problems, not as an invitation to post any crash you encounter to Ender IO's issue tracker. Always check the stack trace above to see which mod is most likely failing.):
    * The RF API that is being used has no API annotation. This may lead to problems.
    This may (look up the meaning of 'may' in the dictionary if you're not sure what it means) have caused the error. Try reproducing the crash WITHOUT this/these mod(s) before reporting it.
    Detailed RF API diagnostics:
    * RF API class 'EnergyStorage' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/EnergyStorage.class
    * RF API class 'IEnergyConnection' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/IEnergyConnection.class
    * RF API class 'IEnergyContainerItem' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/IEnergyContainerItem.class
    * RF API class 'IEnergyHandler' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/IEnergyHandler.class
    * RF API class 'IEnergyProvider' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/IEnergyProvider.class
    * RF API class 'IEnergyReceiver' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/IEnergyReceiver.class
    * RF API class 'IEnergyStorage' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/IEnergyStorage.class
    * RF API class 'ItemEnergyContainer' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/ItemEnergyContainer.class
    * RF API class 'TileEnergyHandler' is loaded from: jar:file:/C:/Users/kylen/Documents/Curse/Minecraft/Instances/Dope%20Shit/mods/extrautilities-1.2.12.jar!/cofh/api/energy/TileEnergyHandler.class
    Detailed Tesla API diagnostics:
    * Tesla API class 'Tesla' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.Tesla)
    * Tesla API class 'TeslaCapabilities' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.capability.TeslaCapabilities)
    * Tesla API class 'ITeslaConsumer' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.ITeslaConsumer)
    * Tesla API class 'ITeslaHolder' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.ITeslaHolder)
    * Tesla API class 'ITeslaProducer' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.ITeslaProducer)
    * Tesla API class 'BaseTeslaContainer' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.implementation.BaseTeslaContainer)
    * Tesla API class 'BaseTeslaContainerProvider' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.implementation.BaseTeslaContainerProvider)
    * Tesla API class 'InfiniteTeslaConsumer' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.implementation.InfiniteTeslaConsumer)
    * Tesla API class 'InfiniteTeslaConsumerProvider' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.implementation.InfiniteTeslaConsumerProvider)
    * Tesla API class 'InfiniteTeslaProducer' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.implementation.InfiniteTeslaProducer)
    * Tesla API class 'InfiniteTeslaProducerProvider' could not be loaded (reason: java.lang.ClassNotFoundException: net.darkhax.tesla.api.implementation.InfiniteTeslaProducerProvider)
     
  18. SatanicSanta

    SatanicSanta Wiki Steam Witch Wiki Staff FTB Mod Dev ModMyMC Editor

    You're using a version of the RF API for 1.7 on 1.10. If you didn't manually install it, I can't really help you further. Though it looks like it might be Refined Storage's fault?
     
  19. ICountFrom0

    ICountFrom0 Popular Member

    There's quite a bit of knockback to the Gaia Guardian attacks sometimes. When combined with the possibility of being in the middle of a sash augmented double jump when hit, it looks like it's quite easy to be removed from the arena and the fight canceled. Could the containing wall be changed to a dome?
     

Share This Page