Unsupported Agrarian Skies: Hardcore Quest Bug Reporting

Status
Not open for further replies.

Regelneef

New Member
Jul 29, 2019
1
0
1
I installed the latest version, went to load Home Sweet Home G for the first time... get ID conflicts on 20518, 20502 and 1056. I closed out, deleted the whole mod's folder and relaunched/redownloaded the mod pack, same issue.
Don't worry about it.... the blocks do not exist yet... just continue and enjoy

Edit: darn ninja'd by Yusu :)
 

Yougirasu

New Member
Jul 29, 2019
4
0
0
Not sure if it may help get to the bottom of things but when I died from an Enderman and lost all my stuff through the bug that occurred (or at least the main assumption is that it's a bug), a Thaumic Slime appeared on the very spot that I died. May be useful, might not. I would provide a log, but when I went to check if my stuff had just vanished and what the slime was there was a loose angry zombie and I lost my only other life :(
 

JimmyJam

New Member
Jul 29, 2019
206
0
0
Not sure if it may help get to the bottom of things but when I died from an Enderman and lost all my stuff through the bug that occurred (or at least the main assumption is that it's a bug), a Thaumic Slime appeared on the very spot that I died. May be useful, might not. I would provide a log, but when I went to check if my stuff had just vanished and what the slime was there was a loose angry zombie and I lost my only other life :(
Same thing happend to me when i died all my stuff was gone we don't know if it a bug or not... I hope it isnt
 

Kinjiru

New Member
Jul 29, 2019
38
0
1
if it warns you about if changes you can just proceed, as the map was made with an older version of the pack, which also means older mod version.
in the meantime mods have updates and have changed certain block/item IDs, thus giving that warning
Thanks, Yusunoha (and thanks Regelneef, too ;)
 

Jadedcat

New Member
Jul 29, 2019
2,615
1
0
I've noticed this bug when I first started playing on my private server after I updated with a brand new download and everything. All of my files are fresh installs. When I make a tool station the first time, it won't register. It wouldn't register until I've made it a 2nd time. I went into an ssp world to test this, and it happens again. The following screenshots are what I have done to recreate this bug.

Making of the first Tool Station:

What the quest log tells me the first time:

What the quest log tells me after I made it a 2nd time. As you can tell by my hotbar, I had to make it twice before it would tell me that I made it.

I don't know if there's other people that's getting this bug, or if it's just me... But I've found it a bit of a waste, tbh.
Its intermittent. I am trying to figure it out to resolve it.[DOUBLEPOST=1396014501][/DOUBLEPOST]
Same thing happend to me when i died all my stuff was gone we don't know if it a bug or not... I hope it isnt
Same thing happened once on my stream. The other time I died everything was there. Its very confusing since there is no gravestone mod or anything. The items should just be there. For now while I track that down I would suggest people use /gamerule keepinventory on.
 

Draigon

New Member
Jul 29, 2019
6
0
0
Its intermittent. I am trying to figure it out to resolve it.
Is this perhaps related to the order in which you craft those items? I've completed this quest in several different worlds, and most of the time I crafted items from left to right. I only got a bug on an established world where I was rushing through the craft list in my head and crafted the tool station first. I noticed the Crafting Station and the Tool Station both require a Crafting
table and the Crafting Station happens to only require a Crafting Table, so if you craft a Tool Station first and place the Crafting Table into the grid first, for a moment the Crafting Station will show in the results.
This at least holds true from my playtime yesterday, I won't have chance to test it out today until later.
 

Lakart

New Member
Jul 29, 2019
51
0
0
Version 1.0.5 & 1.0.6 multiplayer server, spawning in the void and dying until banned. Reinstalled server, still happens.
 
Last edited:

goreae

Ultimate Murderous Fiend
Nov 27, 2012
1,784
2,649
273
Raxacoricofallapatorius
Version 1.0.5 & 1.0.6 multiplayer server, spawning in the void and dying until banned. Reinstalled server, still happens.
If you are on land at any point in time, then do "/jspawn set". This will make the server spawn where you are standing.

Another possibility is you started a new world, in which case this outcome is expected.
 

Uristqwerty

New Member
Jul 29, 2019
48
0
0
It has probably been fixed by now, but on the off chance that this information helps: When I looked up the recipe for the glacial precipitator in 1.0.6, the right copper ingot was showing the ore dictionary entry for CopperIngot, which had zero items associated with it, which would make it uncraftable.
 

Pied_Piper_11

New Member
Jul 29, 2019
52
0
0
Version 1.0.5 & 1.0.6 multiplayer server, spawning in the void and dying until banned. Reinstalled server, still happens.
The same thing happened to me and I had to restart my server. I changed it so it would force me into creative and I could fly over to the starting area and then I set the /jspawn. I then logged out stopped the server changed the gamemode and restartd the game and relogged in and started to play.
 

Pied_Piper_11

New Member
Jul 29, 2019
52
0
0
If you die while setting your spawn like @Pied_Piper_11 suggests, then you can go into creative mode and spawn in full hearts.
However if you die 2 times from falling, you will not be able to log back in due to being "hardcore". That is why I had to restart my server.
 

cannajan

New Member
Jul 29, 2019
172
0
0
couldnt claim quest reward, like picture on page1 - all 100 percent complete - wanted cotton bag, tried a few times, the 'claim reward' is highlighted but didnt do anything I tried other options and it let me have wheat seed :p

Made a jungle barrel - this was accepted even though it says oak, but when I used jungle for the sieve, it wasnt accepted - consistency would be nice but its not really a bug

this quest system almost makes me want to start over, but I'm on my 3rd attempt, and I am not going be tempted into the nether just cos I now have some spare lives, I not, really I'm not, well....
 

JimmyJam

New Member
Jul 29, 2019
206
0
0
Flying with the Thaumostatic Harness is really REALLY slow almost as slow as shift walking,flying up and down is fine just going forward is slow.
 

Jadedcat

New Member
Jul 29, 2019
2,615
1
0
Flying with the Thaumostatic Harness is really REALLY slow almost as slow as shift walking,flying up and down is fine just going forward is slow.
intended. put haste enchant on it.[DOUBLEPOST=1396056121][/DOUBLEPOST]
couldnt claim quest reward, like picture on page1 - all 100 percent complete - wanted cotton bag, tried a few times, the 'claim reward' is highlighted but didnt do anything I tried other options and it let me have wheat seed :p

Made a jungle barrel - this was accepted even though it says oak, but when I used jungle for the sieve, it wasnt accepted - consistency would be nice but its not really a bug

this quest system almost makes me want to start over, but I'm on my 3rd attempt, and I am not going be tempted into the nether just cos I now have some spare lives, I not, really I'm not, well....
I have to add an ore dictionary category for each item with multiple variations. Haven't gotten around to making the other ore dictionary categories.
 
  • Like
Reactions: JimmyJam

goreae

Ultimate Murderous Fiend
Nov 27, 2012
1,784
2,649
273
Raxacoricofallapatorius
So my idea of what is happening with the items not dropping is that the game thinks it's hardcore mode, so it's not dropping items when you die.[DOUBLEPOST=1396069684][/DOUBLEPOST]
I wasn't going to make you do that :(
"Make" is a strong word. I like "let" better. I want to write minetweaker stuff. i'm fine with doing gruntwork. It leaves you available to do cooler things than spending hours writing recipes. Also, I frankly have nothing better to do.
 
Status
Not open for further replies.