World Leaks.

Discussion in 'Server Tech Support' started by Nipinspector, Feb 24, 2013.

  1. Nipinspector

    Nipinspector New Member

    When I start my server I get messages saying
    [Fml] Detected leaking worlds in memory. there are 4 worlds that appear to be persisting. A mod is likely caching the world incorrectly
    The world a7da2b4 (*****) has leaked
    The world 2aa715ae (*****) has leaked
     
  2. theskipman9o5

    theskipman9o5 New Member

    Like you I'm having this problem. Sent in a ticket and the reply I got suggest a forum, spent ages trying to log in only could not remember password. Forgotten password link did not help, so had to start new account. Now can not find original forum.
    Unfortunately from what I read it seem FTB could not careless at present about this leak problem as they said there is not fix yet and no one knows what causing it.
    This could be the second world I have lost due to errors following an update. The first one was duew to tomany old mods following the update. Funny as I though updates should update things including data.
     
  3. nateedubs

    nateedubs New Member

    You, me, and many other people are having this exact same problem.
     
  4. Naolas

    Naolas New Member

    Could try this. Couple spot loaders are a small price to pay for stability.

     
    Eyamaz likes this.
  5. Nipinspector

    Nipinspector New Member

  6. nateedubs

    nateedubs New Member

    Question about step 3....what exactly is a loader and how do you place it? I'm new to hosting FTB, any specifics would be greatly appreciated, thanks!
     
  7. Naolas

    Naolas New Member

    There are a few different ways to force chunks to stay loaded, the smallest one is the Spot Loader from ChickenChunks.

    A chunk loader is an item you place on a chunk that will keep it loaded when you are offline or away.

    You could also give /chunkloaders a try ... that will show you a map with currently loaded chunks and forced chunks.
     
  8. Beleriond01

    Beleriond01 New Member

    I'm getting the same errors yet I'm only plating single-player MC...Will the /chunkloader function even work?
     
  9. b0bst3r

    b0bst3r New Member

    At around about 7 minutes 30 secs into this video



    chickenchunks and cpw start discussing this very issue, it maybe not worth listening to unless you understand what they are talking about but it simply shows you that:

    1) they are aware of the problem
    2) they are seeking to resolve it
    3) it has something to do with different ages (mystcraft etc)
     
    tabs likes this.
  10. theskipman9o5

    theskipman9o5 New Member

    tried the spot loader fix, went to both ages I have plus the Neather and TW Forest and placed spot loaders, however still get one world unloading World 1. When I quit game I unload world 0, -1 8 10 plus one other which I am assuming is the Tw Forest ( may ages are called age 8 and age 10, 0 i assume is the over world (spot loader in this too) and -1 the Neather?. I did have another age open but destroyed the book. I also have problems with chargepads that seem to relate to unused age books that I have created

    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 3/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 4/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 5/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 6/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 7/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 11/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 12/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 13/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 14/inactive (ignoring)
    2013-02-26 19:57:45 [WARNING] [ChargePads] Invalid meta check: 15/inactive (ignoring)

    Sorry can seem to change colour of font. Any Help ?
     
  11. Booker The Geek

    Booker The Geek Well-Known Member

    It might have something to do with Mystcraft, But I solved the problem on my SMP and server by disabling the three "wirelessredstone" mods in the mod pack. See my post here.
     
    Eyamaz likes this.
  12. Naolas

    Naolas New Member

    Sure, just type in the command. (It is /chunkloaders, the plural)

    World 1 should be The End. What you describe is sound. When you quit worlds 0 (overworld), -1 (nether), 8 (age1) 10 (age2), 7 (Twilight Forest) unload. So once you place a loader in The End, there are no more leaking worlds?
     
  13. Beleriond01

    Beleriond01 New Member

    Thanks for the info, will definitely try once I get home today.

    I read your reply to theskipman9o5 as well and that got me thinking. Yesterday I noticed my console spitting out "6 worlds detected leaking". Again, this is Single-player MC. I found the error interesting since I've ONLY discovered/played in the Overworld and The Nether. I've not been to The End or Twilight Forest yet and I've not yet made Mystcraft ages or books (only crafted myself some linking books to more easily get to my Nether base (chunkloaded btw) from my Home base.

    Therefore, I don't fully understand why it should spit out the detected leaking worlds error. FYI, I am currently still able to play modded MC (DW20 pack). Strangely enough, the errors seem not to impact my system's performance...yet (knock on wood!).

    Cheers,
    Bel*.
     
  14. Booker The Geek

    Booker The Geek Well-Known Member

    To fully explain, you'll most likely need to understand JAVA a lot better. As a breakdown, watch the video above, skip to about the ten min mark and listen. Sorta explains what is happening.
    • Basically minecraft loads up the neather & the end while performing terrain generation. (The "Building Terrain" screen) So when this happens those worlds load. Other mods also load worlds, such as Twelite Forest (World #7) and mystcraft. Other mods might, but I don't know from personal experiance.
    • That error is happening because Forge? (Or some mod made by Chicken Bones) is unloading the worlds. Normally this is a good thing because the less worlds you have loaded the faster your game is going to run.
    • The error start to happen because Mods (No, I do not know which ones EXACTLY, but I got a good idea and am going to ask them to fix it, but whom am I except a lonely forum junkie/geek) are coded in such a way as to keep a reference to those worlds. This causes the error to happen and your ram to get full and the client to crash. ( for most people)
    I am testing to see if the chunckloader placing will stop this from happening, I will let you know.

    To stop the errors, and to stop it from crashing your client, (You are SUPER lucky if you are not having any system performance impact.) Follow this post's directions.
     
  15. Naolas

    Naolas New Member

    The log should tell you which worlds unload (and therefore don't have a chunk loader), very shortly before you get the "world leaked" line. Like Booker says, even End/Twilight Forest get loaded briefly and then unload.

    I imagine you would only get problems if you try to do something in a world that has previously not been properly unloaded (leaked), because some mods may refer to the old one, while others will refer to the recently reloaded map.
     
  16. Booker The Geek

    Booker The Geek Well-Known Member

    It should, and it might for other people, but is does not for me.

    Nope. You will get this error on a fresh/clean install Just starting out on a new game standing still.


    ...Yep, Life blows.
     
  17. Naolas

    Naolas New Member

    I know I see it on the server console. You could copy your world to a server to see if that log gives you more information. (Technically these days single player starts its own server, but there might still be differences.) Feel free to post your log to pastebin.

    Yes, you actually explain yourself why. I was merely commenting on why leaked worlds may not be a problem, until the worlds effected are accessed.
     
  18. Booker The Geek

    Booker The Geek Well-Known Member

    lol... I need to learn to read better. You are right, It does show what worlds are not unloading. I for some odd reason was thinking about what mods are actually holding onto those worlds.

    arg.... I need to not post after 3am. Completely my bad and you were right. :D
     
  19. ExEvolution

    ExEvolution New Member

    These world leaks have made client drop to about 2fps when connected to my server after the update, literally unplayable.

    Removing chicken chunks is not an option because then every player on the server will have to do it manually, and we use the chunk loaders anyway.
     
  20. Haruchai

    Haruchai New Member

    We've been getting the "leak" error as well, but fortunately, it hasn't driven lag off the charts like some of you have experienced. I tried the 'chunkloader' trick as mentioned earlier in the thread (thanks!), but it eventually proved ineffective. Here's the tail-end of the log file as the server restarts (~18:12 mark), then as I go collect the chunkloaders the problem appears to worsen (~18:16 mark). I don't know if this helps anyone with a solution or insight into the problem, but I thought I'd toss it your way.

    Mindcrack 8.1.1 (Mystcraft not installed)

    2013-02-27 18:12:04 [INFO] [ForgeModLoader] [Thaumcraft] Removed -609 aura nodes when world 7 unloaded.
    2013-02-27 18:12:06 [INFO] [ForgeModLoader] Unloading dimension 7
    2013-02-27 18:12:14 [SEVERE] [ForgeModLoader] Detected leaking worlds in memory. There are 2 worlds that appear to be persisting. A mod is likely caching the world incorrectly

    2013-02-27 18:12:14 [SEVERE] [ForgeModLoader] The world 33b6180e (xxxx) has leaked.

    2013-02-27 18:16:27 [INFO] [ForgeModLoader] [Thaumcraft] Removed -771 aura nodes when world 1 unloaded.
    2013-02-27 18:16:27 [INFO] [ForgeModLoader] Unloading dimension 1
    2013-02-27 18:16:32 [SEVERE] [ForgeModLoader] Detected leaking worlds in memory. There are 3 worlds that appear to be persisting. A mod is likely caching the world incorrectly

    2013-02-27 18:16:32 [SEVERE] [ForgeModLoader] The world 47dd218b (xxxx) has leaked.


    Tomorrow I think I will re-install 8.1.1 and see if that has any effect.

    Thanks!
     

Share This Page