[WIP 1.10.2 Pack] Sticks and Stones

kev12east

New Member
Jul 29, 2019
546
0
1
Sticks-and-Stones (4).png

"Sticks and Stones," sounds like it's going to break your bones, right? Well, it might, if you're not careful.
Gather together some flint to cobble together an axe. Chop whole trees. Cut logs into planks.
Combat the elements, your thirst, and your hunger. Create your mighty civilization from the humblest of beginnings. Will it stand the test of time?
Industrialize quickly, or enjoy as your little shack is demolished for a highway.

3rd Party pack code: sns
Also available on Curse!

KVCbQql.png

This is a pack designed to be challenging, but fun. Its inspired by Terrafirmacraft and my previous pack, Technofirma.
This is my third mod pack, and I hope it turns out well. I plan to put much more forethought into this, and to make it feature complete by version 1. Please post any suggestions, bug reports, etc. down below, I'd love to hear your feed back!

Have questions, or just want to chat? Check out the Discord! https://discord.gg/pX4avwj

 
Last edited:

kev12east

New Member
Jul 29, 2019
546
0
1
For a better formatted mod list copy it directly off the FTB Launcher.

I might do that, but I don't actually have the FTB launcher installed...


Update 0.9.1 [Should be out in the near-ish future]
  • Fixed Main Menu logo
  • Fixed inability to launch pack
  • Fixed crash on startup due to vein miner
  • Added Immersive craft
 

RyokuHasu

New Member
Jul 29, 2019
255
0
0
 

kev12east

New Member
Jul 29, 2019
546
0
1

Just a weee bit of copy-paste and the list is updated, thanks!
 

cannajan

New Member
Jul 29, 2019
172
0
0
A pretty pack, I liked the tooltips telling what to do, but there was plenty I didnt know, a few tips on the tough as nails mod would have kept me alive, I would have kept going but dying repeatedly to tiredness was annoying.
 

kev12east

New Member
Jul 29, 2019
546
0
1
A pretty pack, I liked the tooltips telling what to do, but there was plenty I didnt know, a few tips on the tough as nails mod would have kept me alive, I would have kept going but dying repeatedly to tiredness was annoying.

I'll be working on the tips and tweaking sleeping. Forgot to put in the OP, but this is still WIP [only at version 0.9.1]
 
R

RepliK

Guest
I really like playing on modpacks like this. A bit of realism, not as easy as vanilla and taking your time for planning or just doing things to eventually progress very far... and bam! immersion happen.
All that just to say i've got a good feeling about this one.

Besides that i'm kinda stuck in my world actually xD the fact is that, for some reason, i can't put tool-part patterns in the part builder, the slot won't accept it, but it does for blank patterns, which is quite useless o.0
I don't think this is a tinker's construct side bug because i'm using this mod in others packs and it never happened. That's why i haven't even googled it (maybe i should have).
Or i'm doing something wrong, in that case, pardon my noobness o.o

That say, keep up the good work, i would like to see this pack going far =P
 

kev12east

New Member
Jul 29, 2019
546
0
1
I really like playing on modpacks like this. A bit of realism, not as easy as vanilla and taking your time for planning or just doing things to eventually progress very far... and bam! immersion happen.
All that just to say i've got a good feeling about this one.

Besides that i'm kinda stuck in my world actually xD the fact is that, for some reason, i can't put tool-part patterns in the part builder, the slot won't accept it, but it does for blank patterns, which is quite useless o.0
I don't think this is a tinker's construct side bug because i'm using this mod in others packs and it never happened. That's why i haven't even googled it (maybe i should have).
Or i'm doing something wrong, in that case, pardon my noobness o.o

That say, keep up the good work, i would like to see this pack going far =P

Glad you like it! The TC part builder is an issue I'm aware of [no idea what's causing it, as of right now]. A workaround for this issue is to use the pattern chest, and to put the stencils in that way.
 
R

RepliK

Guest
A workaround for this issue is to use the pattern chest, and to put the stencils in that way.

I don't get it. The pattern chest only allows to have all the crafted tool-parts patterns in the part-builder UI. But my problem is that i can't insert them in the left slot of the part-builder, shift-clicking doesn't work either.
 

kev12east

New Member
Jul 29, 2019
546
0
1
I don't get it. The pattern chest only allows to have all the crafted tool-parts patterns in the part-builder UI. But my problem is that i can't insert them in the left slot of the part-builder, shift-clicking doesn't work either.

Well, the person who found it said that it was most likely a fluke. What version are you playing on? In my most recent dev [0.11], this is no longer an issue. I am uncertain if this was fixed in 0.10, or just now.
 
R

RepliK

Guest
I was playing on 0.91 but even 0.10 hasn't fixed it (i've just checked to be sure). 0.11 is not on ftb launcher yet, gonna try when it's up.
 

kev12east

New Member
Jul 29, 2019
546
0
1
I was playing on 0.91 but even 0.10 hasn't fixed it (i've just checked to be sure). 0.11 is not on ftb launcher yet, gonna try when it's up.

OK, so it look like the recent TC update fixed it. I haven't pushed 0.11 to FTB yet at all (why I said in dev). I'll being pushing it either later today or tomorrow, I still have some things to fix with it.
 

kev12east

New Member
Jul 29, 2019
546
0
1
I was playing on 0.91 but even 0.10 hasn't fixed it (i've just checked to be sure). 0.11 is not on ftb launcher yet, gonna try when it's up.

Ok, I've found the issue, it was a config error on my part. If you set reuseStencils to true in the tconstruct.cfg, then you will be able to use the part builder again. Don't know why this is the case, but it is. This is fixed in 0.11, which is basically ready to be sent to FTB. Just waiting on one more permission, then I can send it in.

A short version of the changelog:
Version 0.11.0
Updated various mods
Fixed inability to use part builder
Cleaned up and updated configs
Changed the default font
Increased mag_limit to 6, from 5
Updated main menu backgrounds
now show pictures from S&S instead of Technofirma
Fixed some scripts not loading

As always, you can see the full changelog in game by going escape>changelog [one of the 3 buttons on the side, where you can also view tips, and report bugs]

This update should also be adding icon and splash images for the pack, as well as having the pack on Curse [hopefully], which is why the OP has a new picture :p
 

ZephyrWindSpirit

New Member
Jul 29, 2019
280
0
1
Your pack sounded interesting; so I downloaded it. Unfortunately, my computer has major issues with any packs over 1.7.10. Specifically it chokes on baking models most of the way through with 100% memory and cpu usage.

I would like to suggest that next to [wip pack] you add it is for 1.10.2 so others with little memory on their laptops don't fall in the same trap I did. Much as I want to play, this computer does not support 1.10 in any way, shape or form.
 

kev12east

New Member
Jul 29, 2019
546
0
1
Your pack sounded interesting; so I downloaded it. Unfortunately, my computer has major issues with any packs over 1.7.10. Specifically it chokes on baking models most of the way through with 100% memory and cpu usage.

I would like to suggest that next to [wip pack] you add it is for 1.10.2 so others with little memory on their laptops don't fall in the same trap I did. Much as I want to play, this computer does not support 1.10 in any way, shape or form.

I've gone ahead and updated the thread title.

What are your PC specs? To not be able to play on 1.10 seems weird.
 
R

RepliK

Guest
I've got huge fps drop only when tree foliage are quickly disappearing, from 130fps to 2 or 3 freeze during a second. Not unplayable, the "fps-meter" hasn't even got the time to show me how many i have when it happen.
Also i can't sleep during nights anymore, the bed says that there are monsters nearby when there aren't, even on peaceful.
And doors "sprits" doesn't have texture in belt or in hands (or when thrown on the ground).
 

kev12east

New Member
Jul 29, 2019
546
0
1
I've got huge fps drop only when tree foliage are quickly disappearing, from 130fps to 2 or 3 freeze during a second. Not unplayable, the "fps-meter" hasn't even got the time to show me how many i have when it happen.
Also i can't sleep during nights anymore, the bed says that there are monsters nearby when there aren't, even on peaceful.
And doors "sprits" doesn't have texture in belt or in hands (or when thrown on the ground).

I've slowed down leaf decay for the next update.
I'll look into the sleeping issue, I have an idea as to what's causing it, but I need to make sure. If I figure it out, it'll be fixed for next update.
Which doors are you talking about? Can you provide some pictures? Are you using Optifine of a texture pack?
 
R

RepliK

Guest
Which doors are you talking about? Can you provide some pictures? Are you using Optifine of a texture pack?

Not using neither texture packs nor things like otpifine, not needed with my specs and i'm not using shader packs so..

The doors without textures that you can see on the screenshot are the vanilla doors only (Oak, Iron, Spruce, Birch, Jungle, Acacia and Dark Oak) I've checked.
I've put some doors on the ground and in the belt just so you can see.