Which MC version should new mod developers target?

Discussion in 'Mod Development' started by Nivix, Sep 27, 2016.

  1. Nivix

    Nivix New Member

    Hi guys, I'd like your opinion on something. As a new mod developer just starting out, which Minecraft version should I target?

    Minecraft 1.7 seems to be the most popular, but I doubt any "new" development is being done in that version. Probably mostly maintenance. Minecraft 1.9 hasn't gained much popularity -- meanwhile 1.10 and 1.11 are a thing. Any ideas / opinions?
     
  2. LordPINE

    LordPINE Well-Known Member

    You should probably go for 1.10, there is still a lack of good mods for that version. I would definitely not go for 1.7, because everyone is moving away from that anyway. Generally, I would try to mod the newest version when you're making a new mod, because otherwise you will need to update it a lot afterwards.
     
  3. Nivix

    Nivix New Member

    Thanks @LordPINE for your response. Aroma1997 also recommended 1.10 on Direwolf20's IRC. I had reservations because the popular mods targeting 1.10 seem unstable and very new, but I guess any mod I make would be in the same boat. :)
     
  4. SatanicSanta

    SatanicSanta New Member

    Definitely 1.10.
     
  5. Viesis

    Viesis Guest

    I would say 1.10.x. For the most part, code you write for 1.10.2 would be easily back ported for 1.10 and 1.9.4.
     
  6. Shadow Codex

    Shadow Codex Guest

    I just started writing some mods myself, and I am targeting 1.10...

    It makes sense just as a developer to go with the latest.
     

Share This Page