Solved UUID change after upgrading from Revelation 2.2.0 to Revelation 2.7.0

Discussion in 'Tech Support' started by Dragonator, Jun 22, 2019.

  1. Dragonator

    Dragonator Active Member

    Hello,

    So, I've upgraded my local server instance of FTB Revelation from 2.2.0 to 2.7.0. Specifically I installed the 2.7.0 server in another folder, fixed some issues with custom mods, including upgrading forge to the latest beta version, and moved my world folder from the old server to this new one.

    When I finally connected all my gear was gone. I found that my UUID was changed, so I simply renamed the playerdata files to the new UUID, but it seems Botania relics are linked to the players UUID. That means that when I logged in wearing my relics I got punished for using them and got killed.

    Anyone have any idea why the UUID may have changed, or how to change it back?

    Thanks.

    EDIT: I think I solved it. The firewall was blocking access and the server wouldn't run in online mode. When I changed it to false it changed my uuid. When I fixed the firewall settings and changed the setting back to true it gave me back the proper UUID. Now I just have to see why the server runs so poorly.
     
    Last edited: Jun 22, 2019
  2. grandrolf

    grandrolf Popular Member Trusted User

    This might be part of your problem:

    All mods in a pack is depending on the version of the other mods + depending on the version of forge. Changing one might force you to update another, and then a third breaks, and then forge needs to...

    I would suggest that your run your server with the version of forge and versions of the mods in the pack "as-is".
     

Share This Page