Problem updating server, [severe] world leak, bukkit plugins stopped working?

Discussion in 'Server Tech Support' started by Adolph Hipster, Feb 19, 2013.

  1. Sn0bb

    Sn0bb New Member

    I also have this leaked worlds issue besides few other SEVERE reports in forgemodloader log. The server runs though, although i haven't tried to keep it up for long.
    Here is the whole log:
    Pastebin
     
  2. Slovic

    Slovic New Member

    Getting the same issue with DW20 server. Any idea which mods are causing the problem?
     
  3. Adolph Hipster

    Adolph Hipster New Member

    I've been troubleshooting for a few hours, and when one error seems gone, another is created :mad:
     
  4. DZCreeper

    DZCreeper New Member

    I just finished nuking these problems from orbit. Let me explain my progression into darkness and not so far out of it.

    MindCrack V8 server. A few custom mod updates and its becoming quite popular, but still small enough that all updates are handled via dropbox. We switch hosts, no big deal, the old host didn't live up to our needs. I learn about MCPC+, which I of course start using build 291. 1 random night I notice some pretty big bugs have been changed in some mods, along with new content, which the users are always happy to see. I update these, and MCPC+ to build 199. I get up the next morning and press start in mcmyadmin, doesn't work, and console is showing errors.

    Some googlefu, I find later that any build after 192 and before 201 had this. I upgrade to 202. Then chicken chunks loses its shit entirely, my server starts leaking memory like a sieve. I narrow it down to CC. After downloading the entire server which totaled at 1.5 gigs, I got it working again after much pain & RAM usage to keep the server open long enough to delete the loaders so I could remove CC without another crash, that would break the world.

    I upload everything back to the dedicated box and I start it and log on. I died mentally. My entire base, along with my WIP progress base in a MystCraft age where gone. This is not replaceable stuff. I had hundreds of solars and plenty of auto sorting and gregtech stuff, not to mention my entire base took days to make, consisting of 2 volcanos worth of basalt.

    I now resolve that nothing short of a earthquake in France combined with 1 in minecraft would make me move hosts or update mods.
     
  5. Naolas

    Naolas New Member

    Sorry for repeating myself.

    You can fix this by making sure the worlds never unload.
    1. Start server
    2. Go to dimension (nether, end, twilight forest, ..)
    3. Place loader (make sure with /chunkloaders that it is properly doing its job)
    4. Stop server
    5. Start server (there shouldn't be any more world leakage)
    My guess is that when a world unloads some mod does not properly do so and keeps a reference to the old world. Then, after loading the world again, there are two versions. Placing items (only really seen it with chunk loading blocks) crashes the client and freaks the server out, which results in regenerated chunks. Again, all my speculation, based on the post by Nallar I quoted above.
     
    Geometry likes this.
  6. sorcereo

    sorcereo New Member

    This sounds about right. While I was trying to trouble shoot what was going on with my server: while I and my friends were entering and exiting dimensions I would notice that the leaking worlds would sometimes jump up in numbers exponentially.
     
  7. DZCreeper

    DZCreeper New Member

    New versions of Chicken Bones mods. Wireless Redstone, EnderChests, Chicken Chunks, and NEI.
     
  8. Sn0bb

    Sn0bb New Member

    Is there a new version of chicken chunks that fixes the problem? Or is there nothing that can be done about it that fixes the problem currently.
     
  9. delicateglow

    delicateglow New Member

    It still leaked for me. :/
     
  10. Greytusks

    Greytusks New Member

    The leaks occur even if chicken chunks isn't installed *is eyeing Forge suspiciously*
     
  11. Adolph Hipster

    Adolph Hipster New Member

    I downloaded the MindCrack server file again, extracted in a new folder by itself. added nogui to the bat file. and I can connect via local host although I still got the "world leak" errors. Walked around for a few minutes, and it seems to work okay. Going to try to add in my world now and retest.
    Edit: Imported my world, still get world leak. No other known issues.

    note: I don't know exactly what "world leak" means, but it seems it could be worked around IMO?

    Has anyone been getting other issues/glitches from the world leak?
     
  12. Sn0bb

    Sn0bb New Member

    I don't even dare to continue. Some have reported worlds getting worse by time and servers crashing. And I don't want to place chunk loaders that hog the power of server just due leaking worlds.
    Wouldn't want to waste time on world that gets corrupted more due the bugs in current version.

    Also sad that there is no official word on this case whether it is looked upon or not.
     
  13. Klonken321

    Klonken321 New Member

    no update yet how to fix this?
     
  14. DR. DOOMADORE

    DR. DOOMADORE New Member

    We are getting this problem too. Server is up but a single arcane bore + Chunk loader is making everything lag badly. The golems are taking ten to twenty seconds to take a step.
     
  15. Fred Nerks

    Fred Nerks New Member

    This "the world has leaked" error is talked about in the latest direwolf 20 smp(season 4) episode(26) at around the 9.40 mark. Hopefully someone can explain what they're saying.
     
  16. enki

    enki New Member

    This is bothersome, watching the video to see what I can make of it. I got this error after unzipping the latest mindcrack server zip and launching the server. I have made no changes, it generated a map and then gave me the errors. I have not even launched my client yet.
     
  17. Booker The Geek

    Booker The Geek Well-Known Member

    A Temp Fix for your leaking worlds. Full post Here

    1. Fresh install of modpack.
    2. Start the game, DO NOT create a new save, just get to the starting screen.
    3. Exit minecraft.
    4. Restart FTB and disable all of the "wireless redstone" mods.
    5. Launch minecraft and enjoy.
     
  18. Frosthawk87

    Frosthawk87 New Member

    That may work so single player, but what about those of us running servers?
     
  19. Booker The Geek

    Booker The Geek Well-Known Member

    Remove those mods from the server?
     

Share This Page