"the server requires mods that are absent or out of date on your client"

Discussion in 'Server Tech Support' started by Yamipirogoeth, Jun 2, 2013.

  1. Yamipirogoeth

    Yamipirogoeth New Member

    Just yesterday when I tried to login to my server I keep getting the error in the subject line "the server requires mods that are absent or out of date on your client" and all I can do is disconnect from the server. Here is a screenshot of what I'm seeing: http://prntscr.com/17tl2d

    I have tried changing the launcher to use FTB Ultimate 1.1.1 for the modpack but with no change

    I have not added any mods or deleted any mods from anything.

    As far as I'm aware my server is FTB Ultimate 1.1.2 (I'm not sure how to check the version to be 100% sure)

    My launcher is v1.2.4 and is using FTB Ultimate 1.1.2 modpack

    Here is the server log: http://pastebin.com/mk4Egex2

    I'm also seeing logs with the following names: ForgeModLoader-server-0.log, ForgeModLoader-server-1.log, ForgeModLoader-server-2.log
    Each of these are over 500Kb so if you need to see them please let me know so I can find something other than pastebin to upload the information to.

    Machine spec for both launcher and server:
    Windows 7 Home Premium 64bit
    AMD A6-3620 running @ 2.2GHz
    6GB RAM (2GB selected for the launcher) DDR3-1333

    I am not using a Minecraft hosting provider, I'm using a LogMeIn Hamachi client in order for people to connect to the server. The Hamachi client is up to date.

    Please let me know if anything else is needed to figure out what's happening.
     
  2. Alchemist

    Alchemist Member

    It seems like you have different versions of the following mods:

    -MineFactory Reloaded
    -BiblioCraft
    -Wireless Redstone CBE (Core, RedPower module, and the addons)
    -EnderStorage
    -Machinemuse's Modular Powersuits
    -GregTech
    -GraviSuite
    -ChickenChunks
    - Factorization
    - AppliedEnergistics
    - StevesCarts
    - Mystcraft

    Solution 1 :
    If your server is just a place for having fun and not serious building, you can just delete the entire server folder and grab a new one from the FTB Launcher.

    Solution 2 :
    The solution for this would be :
    Open up your server directory and copy the following files from the SERVER to the CLIENT while matching folders:
    root = server directory (The folder that contains your server files)
    You'll find those inside your "root/mods" folder:

    Capture.PNG

    Now grab one single file from your "root/coremods":

    Capture1.PNG
    It's a dependancy for ChickenChunks and might be different for both sides.

    When copying the files from the server to the client, you have to delete the old files from the client first (Note the ChickenChunks version)
     
  3. Yamipirogoeth

    Yamipirogoeth New Member

    It's definitely for fun however I certainly don't want to lose all the hard work I've put into everything so far so I'm going to try solution 2

    My immediate question is, where do I find the files for the client? I know there's the .minecraft folder in the %APPDATA% folder on my computer but I don't see anything containing those mods that need to be replaced
     
  4. Alchemist

    Alchemist Member

    Alright, open up the appdata folder, look for ftblauncher folder, then open up the file ftblaunch.cfg, find the line installPath=[some directory here] and it will tell you where your modpacks are located, now you open up that folder (that you just got from the config) and then the Ultimate folder (assuming you have ultimate modpack), from there you can open the minecraft folder and then replace the files.
     
  5. Yamipirogoeth

    Yamipirogoeth New Member

    So I made the proper copying and pasting to get everything the same, but now FTB won't even launch...FML comes up saying it needs to prepare things and sits at 0% even after almost 30 minutes.

    So I'm a little stumped as to what's going on there
     
  6. Alchemist

    Alchemist Member

    Grab the latest forge for 1.4.7 and hope for the best > Forge.
    Place that in "xxx\Ultimate\instMods" (xxx is your modspacks folder)
    And delete the old one from there, if that doesn't work, then can you pastebin the FTB launcher log?
     
  7. Yamipirogoeth

    Yamipirogoeth New Member

  8. Yamipirogoeth

    Yamipirogoeth New Member

    Update and a question

    I had someone else try accessing my server, they had no issues in accessing it, so the server doesn't seem to be the issue

    This brings me to my question, is there a way to remove the current client (saving my personal world stuff first) and then re-installing the client launcher after downloading the newest one off the site?
     
  9. Alchemist

    Alchemist Member

    Your "personal world stuff" can be found inside your "xxx\Ultimate\minecraft\saves" you can just back that up (by placing it in the desktop maybe) and then delete the Ultimate folder.
     
  10. Yamipirogoeth

    Yamipirogoeth New Member

    So it seems the client is launching now that I deleted the Ultimate folder. And to try and figure out what caused the client to stop loading I compared the deleted folder to the newly created folder and they are identical to each other so the only thing I can think of is when the client updated from 1.1.1 to 1.1.2 that one of the mods installed corrupted or something. Can that happen?
     

Share This Page