Server Quests not completing

Discussion in 'FTB Pyramid Reborn' started by CycnusJones, Mar 15, 2018.

  1. CycnusJones

    CycnusJones New Member

    If I run the server locally everything works perfect, however once I upload it to my online server I am unable to complete any quests and receive rewards. I place the item, in this case the Basic Drawer from Storage Drawers, into the iron chest on any of the islands and it never gets pulled out of the chest therefore not completing the quest and netting zero rewards. I tried pressing the computer reset button in the pyramid but it didn't fix the issue. The only thing I can think of is that online servers don't allow you to upload .bat or .sh files so those are the only difference between my local server and my online one. Could the opencomputer setup require something that one of these files runs to work? Any help would be greatly appreciated. Also, singleplayer works great and I am really enjoying the pack so far, just trying to get this up to my server for friends to play as well.
     
  2. Henry Link

    Henry Link Popular Member

    The .bat and .sh files are the best way to start up a modded minecraft server. But not the only way. Each hosting company can be a little different. But make sure you are running the FTB server jar file not the minecraft one. Also, make sure you can give it enough memory using whatever control panel they are using for the server. But your best bet if you still have questions is to ask your hosting provider. It is their system and control panel. They would be the best ones to talk to about configuring it for launching a modded minecraft server.
     
  3. slowpoke

    slowpoke Administrator FTB Founder

    Without more details aboutfow the server provider it is going to be effectively impossible to troubleshoot this. As far as I am aware there is no specific requirements that must be met for OC to work. However having said that, something obviously is not right.

    As Henry Link mentions, your best bet right now would be to contact youyrserver provider. As this may be an issue that affects other people if they manage to give you any answers, I would love to know them to see if there is anything that can be done our end to help this problem.
     
  4. djfluffy_vs_joe

    djfluffy_vs_joe New Member

    Hello, i am having the same issue as cycnusjones

    but i am running it on a dedicated Centos Server with 16G of 6g assigned to the minecraft server.

    To manage my minecraft servers i am using a licensed version of the multicraft server manage software.

    Every FTB server pack that i download will be run twice on my windows machine before i upload it so that it can download the minecraftserver.jar and some additional libraries
    The first run is to dowload the server jar and the eula.
    The second run to check if the server runs on my windows machine with a eula.txt set to true.

    Until this pack i have never had any issues with modpacks running on the Dedicated Server.

    i tried a lot to fix this problem but i still have the same issue.

    Here are some of the things that i tried.
    Please note that In every update step i tried the current version of the map and a brand new generated version of the map.

    first i updated Centos and OpenJDK wich was the program that executes the Jar files to the latest versions

    this didn't change anything.

    Then i removed OpenJDK and installed latest Java version from the Oracle site.

    This made no difference.

    Then i looked at the startup parameters that startserver.sh uses to start the actual serverjar file and amended those to the multicraft startup profile.

    And the server started a bit faster but it still made no change.

    So yeah im a bit at a stand still here.
    I am willing to Troubleshoot and try things out.
    I own the server and have full control so i can try out stuff and hope that others may benefit from the solution.

    As a side note, i also want to note that all the screens with the Induction Furnace don't render the induction furnace image and text, its just a black square
     
    Last edited: Apr 2, 2018
  5. Henry Link

    Henry Link Popular Member

    So have you tried to just run the ServerStart.sh file directly from the command line in a terminal window (either ssh or telnet)? Also, do you have any crash reports?
     
  6. djfluffy_vs_joe

    djfluffy_vs_joe New Member

    When i wrote my reply, i didn't do that.

    but i tried that this morning.

    I made a new user in Centos and and downloaded a fresh zip from this pack and i got a server running with the ServerStart.sh

    Then i copied all the files to a new created server in multi craft and the server runs. it doesn't crash and you can do whatever you want in minecraft.
    The only thing that is not working is the quest computer system

    So there are no crash report because the server doesn't crash
     

Share This Page