1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Redpower Crash

Discussion in '[Archived] Tech Support' started by Greeniegriz, Feb 20, 2013.

Thread Status:
Not open for further replies.
  1. Greeniegriz

    Greeniegriz New Member

    Server with Direwolf20 5.1.1

    Started getting this error/crash after setting up Magma crucible and loading it with redstone...

    Code:
    ---- Minecraft Crash Report ----
    Time: 2/20/13 9:59 AM
    Description: Unexpected error
     
    java.lang.IndexOutOfBoundsException
        at com.eloraam.redpower.core.ItemExtended.d(ItemExtended.java:33)
        at up.i(Item.java:458)
        at up.l(Item.java:598)
        at ur.r(SourceFile:334)
        at atr.a(GuiIngame.java:406)
        at ban.b(EntityRenderer.java:982)
        at net.minecraft.client.Minecraft.J(Minecraft.java:882)
        at net.minecraft.client.Minecraft.run(Minecraft.java:771)
        at java.lang.Thread.run(Unknown Source)
     
     
    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
     
    -- Head --
    Stacktrace:
        at com.eloraam.redpower.core.ItemExtended.d(ItemExtended.java:33)
        at up.i(Item.java:458)
        at up.l(Item.java:598)
        at ur.r(SourceFile:334)
        at atr.a(GuiIngame.java:406)
     
    -- Affected level --
    Details:
        Level name: MpServer
        All players: 2 total; [ays['Greeniegriz'/9414, l='MpServer', x=-255.88, y=106.62, z=442.38], bah['PTDragon'/132, l='MpServer', x=-261.31, y=118.00, z=432.59]]
        Chunk stats: MultiplayerChunkCache: 250
        Level seed: 0
        Level generator: ID 00 - default, ver 1. Features enabled: false
        Level generator options:
        Level spawn location: World: (-24,64,252), Chunk: (at 8,4,12 in -2,15; contains blocks -32,0,240 to -17,255,255), Region: (-1,0; contains chunks -32,0 to -1,31, blocks -512,0,0 to -1,255,511)
        Level time: 2409287 game time, 2476387 day time
        Level dimension: 0
        Level storage version: 0x00000 - Unknown?
        Level weather: Rain time: 0 (now: false), thunder time: 0 (now: false)
        Level game mode: Game mode: survival (ID 0). Hardcore: false. Cheats: false
    
    Going to reinstall client just to be sure. Server has a fresh install of Dire.

    Thoughts?

    Cheers,

    GG
     
  2. Wyvern67

    Wyvern67 Active Member

    I'm having the exact same bug.
    I can't connect to my own server since yesterday. I tried everything.
    • I deleted my player.dat, nothing
    • We tried to destroy everything I built yesterday (not sure if everything is gone though), nope, nothing
    • I completly reinstalled feed the beast, no changes either
    I was building in a mystcraft world, in creative mode, a little obsidian generator which was surprisingly very buggy.
    I used dispensers and for some reason they kept being activated for no reason when a block update was made around them.
    I used pistons, wireless transmitters/receivers, state cells, repeaters, redstone dust and warded stone blocks.

    I can play in singleplayer or with another account, which is weird because I deleted my player.dat.
    I think there's a block linked to my character that's not working, like a chunk loader or something.

    Please help.

    EDIT: It was the wireless receiver.
    I deleted my player.dat but it was still in my hand, I don't know why !
    I had to delete it 4 times or so, now it's fixed.
     
  3. L3PR3CHAUN

    L3PR3CHAUN New Member

    You can use NBT editor to change which item slot you have selected. I use this when i get this error and it works. Just don't hold any invisible, buggy items in your hand.
     
  4. cannonfodder1

    cannonfodder1 New Member

    i am getting the same error, its in Ultimate pack with the redstone wireless receivers. however deleting my playername.dat file doesnt work, even when i try it four times. can someone please help?!

    the crash report is uploaded with this post.
     

    Attached Files:

  5. Francis Baster

    Francis Baster Active Member

    Thanks for pointing out that it was Wireless Redstone, I managed to get this error by middle clicking a wireless transmitter in creative. Hopefully deleting the playerfile will fix.
     
  6. newera4

    newera4 New Member

    THANK YOU SO MUCH! THIS SAVED ME!
     
Thread Status:
Not open for further replies.

Share This Page