Really stupid things that people have said about Modded MC(Off topicness makes moderators tired)

  • The FTB Forum is now read-only, and is here as an archive. To participate in our community discussions, please join our Discord! https://ftb.team/discord

Is this a good idea?

  • Yes

    Votes: 66 18.2%
  • No

    Votes: 18 5.0%
  • if people don't get out of control

    Votes: 68 18.8%
  • POTATOES

    Votes: 210 58.0%

  • Total voters
    362
Status
Not open for further replies.

CptSpike

New Member
Jul 29, 2019
398
0
0
I have one. "You shouldn't use these mods, because they don't capitalize their code right".
http://www.reddit.com/r/feedthebeas..._are_there_so_many_badly_written_but_popular/

I haven't read your code, but his point on package names is convention. All lower case. Var names like Block b are fine as I imagine they're local? And classes can't follow a logical structure because that's not the way MC works. That guy should try coding a block with GUI *shudders*


Sent from my iPhone using Tapatalk
 

xbony2

WikiWorker
Wiki Staff
FTB Mod Dev
Jul 3, 2013
914
1,353
201
America
ftb.gamepedia.com
I have one. "You shouldn't use these mods, because they don't capitalize their code right".
http://www.reddit.com/r/feedthebeas..._are_there_so_many_badly_written_but_popular/
Or the way she uses {} brackets on the same line as the function and if statements. I know it's contentious, but that makes it nearly unreadable IMO.
if(post.getUsername.equals("blockachella"){
post.getUsername.hitWithTruck();
}

Strangely, when I google "Reika" I get naked anime girls. Might be why some people think you're female :p
 

RavynousHunter

New Member
Jul 29, 2019
2,784
-3
1
if(post.getUsername.equals("blockachella"){
post.getUsername.hitWithTruck();
}

To be fair, I cringe when I see code written that way, too. Let me fix that for ya...

Code:
if ( post.GetUsername() == "blockachella" )
{
  Users.FindUserByName( post.GetUsername() ).HitWithTruck();
}

(I know, but its the Microsoft standard for all their classes and methods in the .Net Framework, and I hate it when my code looks inconsistently formatted.)

Strangely, when I google "Reika" I get naked anime girls. Might be why some people think you're female :p

3savd8.jpg
 

PODonnell

New Member
Jul 29, 2019
876
0
0
actually, I just googled reika..... and I now see why someone may have been confused...... particularly if their native language was Japaneese.....

That said, best to avoid pronouns until you've done your due dilligence.
 

CptSpike

New Member
Jul 29, 2019
398
0
0
Code:
if ( post.GetUsername() == "blockachella" )
{
  Users.FindUserByName( post.GetUsername() ).HitWithTruck();
}

My eyes just threw up :)

Code:
String user = post.getUsername();
if(user.equals("blockachella")){
    Users.findUserByName(user).hitWithTruck();
}

Or, if its not part of a larger series of if statements:
Code:
String user = post.getUsername();
if(user.equals("blockachella")){Users.findUserByName(user).hitWithTruck();}

All this, of course, IMO™
 

RavynousHunter

New Member
Jul 29, 2019
2,784
-3
1
My eyes just threw up :)

Code:
String user = post.getUsername();
if(user.equals("blockachella")){
    Users.findUserByName(user).hitWithTruck();
}

I can understand storing the user's name in its own variable, from a readability standpoint. However, if memory serves, it may not be the most efficient method of going about hitting a user with a truck, especially if its something that needs to be done often. Also, why the ".equals()" in both examples? That's...what the equality operator is here to do.

Or, if its not part of a larger series of if statements:
Code:
String user = post.getUsername();
if(user.equals("blockachella")){Users.findUserByName(user).hitWithTruck();}

All this, of course, IMO™

AAH! NO! Never never never! One thing I hate more than when people don't properly scope their single-line if blocks is when they try to cram it all into one line! Its so...ugly. *shudders*
 

CptSpike

New Member
Jul 29, 2019
398
0
0
I can understand storing the user's name in its own variable, from a readability standpoint. However, if memory serves, it may not be the most efficient method of going about hitting a user with a truck, especially if its something that needs to be done often. Also, why the ".equals()" in both examples? That's...what the equality operator is here to do.



AAH! NO! Never never never! One thing I hate more than when people don't properly scope their single-line if blocks is when they try to cram it all into one line! Its so...ugly. *shudders*

I find Java sometimes equates == to be false, when the strings ARE the same. Especially if the string is created from say reading a text file. So I always use equals, or .matches(), as force of habit. I don't normally single line my ifs, just if they're inconsequential to the rest of the methods operation. And now you hate me :(
 

Reika

RotaryCraft Dev
FTB Mod Dev
Sep 3, 2013
5,079
5,331
550
Toronto, Canada
sites.google.com
Strangely, when I google "Reika" I get naked anime girls. Might be why some people think you're female :p
My reactions: o_O:eek::confused::oops:


I find Java sometimes equates == to be false, when the strings ARE the same. Especially if the string is created from say reading a text file. So I always use equals, or .matches(), as force of habit. I don't normally single line my ifs, just if they're inconsequential to the rest of the methods operation. And now you hate me :(
"==" tests reference equality. String s1 = "Potato"; String s2 = "Potato". Those are two separate memory objects. ".equals()" tests for actual logical equality, and defaults to "==" unless classes implement it otherwise.

I haven't read your code, but his point on package names is convention.
Agreed. That does not mean I care unless there is a tangible penalty (performance, stability, or otherwise) for not doing so.
 

midi_sec

New Member
Jul 29, 2019
1,053
0
0
actually, I just googled reika..... and I now see why someone may have been confused...... particularly if their native language was Japaneese.....

That said, best to avoid pronouns until you've done your due dilligence.
That's kind of asking a lot on an internet forum.

People just kind of go with what they know, with what they can associate things. If I googled every person I reply to on this forum, just to make sure I'm addressing them properly, I would be doing more googling than typing. :p
 

CptSpike

New Member
Jul 29, 2019
398
0
0
My reactions: o_O:eek::confused::oops:



"==" tests reference equality. String s1 = "Potato"; String s2 = "Potato". Those are two separate memory objects. ".equals()" tests for actual logical equality, and defaults to "==" unless classes implement it otherwise.


Agreed. That does not mean I care unless there is a tangible penalty (performance, stability, or otherwise) for not doing so.

Hmm well I've had == be false whereas .equals() and .matches() be true so :/ anyways whatever gets the bloody thing working eh :)


Sent from my iPhone using Tapatalk
 

RavynousHunter

New Member
Jul 29, 2019
2,784
-3
1
"==" tests reference equality. String s1 = "Potato"; String s2 = "Potato". Those are two separate memory objects. ".equals()" tests for actual logical equality, and defaults to "==" unless classes implement it otherwise.

Not to offend anyone here who's keen on Java, but...were the developers in charge of this language over at Sun Microsystems effing drunk when they made that decision?

Agreed. That does not mean I care unless there is a tangible penalty (performance, stability, or otherwise) for not doing so.

Damn right! Other than being slower than molasses, that's one of my biggest gripes with Eclipse: it constantly pisses and moans when I use ThisStyle for naming packages...and everything else. I dunno if there's a way to turn it off, but it really bugs the crap outta me.
 

PODonnell

New Member
Jul 29, 2019
876
0
0
That's kind of asking a lot on an internet forum.

People just kind of go with what they know, with what they can associate things. If I googled every person I reply to on this forum, just to make sure I'm addressing them properly, I would be doing more googling than typing. :p
By due diligence here, all I mean is taking a look at their account profile....... and I'd argue that is only necessary if you find the need to use pronouns..... If like me you generally avoid them on internet forums it simplifies things greatly.

I only googled reika after I noticed the earlier post, but apparently his handle is a fairly common female given name in japan. And from the list of "famous" characters it looks like there are many manga/anime, and video game characters who may have spread the recognition well outside native speakers of the language.
 

midi_sec

New Member
Jul 29, 2019
1,053
0
0
By due diligence here, all I mean is taking a look at their account profile....... and I'd argue that is only necessary if you find the need to use pronouns..... If like me you generally avoid them on internet forums it simplifies things greatly.

I only googled reika after I noticed the earlier post, but apparently his handle is a fairly common female given name in japan. And from the list of "famous" characters it looks like there are many manga/anime, and video game characters who may have spread the recognition well outside native speakers of the language.

iirc when I first ran into Reika, there was no indication one way or another. This was on MCF, and last year, so I can't be certain. But I too thought Reika was female at one time. No harm, he wasn't offended, just corrected me once.

If somebody has an ambiguous name, I'm sorry but...yeahh... Mistakes will be made.
 

Reika

RotaryCraft Dev
FTB Mod Dev
Sep 3, 2013
5,079
5,331
550
Toronto, Canada
sites.google.com
iirc when I first ran into Reika, there was no indication one way or another. This was on MCF, and last year, so I can't be certain. But I too thought Reika was female at one time. No harm, he wasn't offended, just corrected me once.

If somebody has an ambiguous name, I'm sorry but...yeahh... Mistakes will be made.
This coming from a bike tire. :p
 

NJM1564

New Member
Jul 29, 2019
2,348
-1
0
Agreed. That does not mean I care unless there is a tangible penalty (performance, stability, or otherwise) for not doing so.

Well there would be a 5% drop in complaints from those who know what the heck you are talking about and care. So what 3 guys.
That most be worth the effort of completely re-writing your mod. :D
 

midi_sec

New Member
Jul 29, 2019
1,053
0
0
This coming from a bike tire. :p
haha, well... fair enough.

but it's hard to fault somebody for mistakenly calling you a "she" when Reika is a common'ish name for a girl in japan, that's why I thought you were :p pardon my yellow fever.
 
Status
Not open for further replies.