People can't join my server anymore

Discussion in 'Server Tech Support' started by Zlade, Feb 13, 2013.

  1. Zlade

    Zlade New Member

    Hello

    I am having some problems with my FTB Dire Wolf20 server. I recently changed the computer which is hosting the server and it works fine, however I would like to add more ram to the server (since it comes with this message when I start the server: "[WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"."

    I read that it is most common to use a .bat file instead, if you would like to increase the ram and so I did (java -Xms1024M -Xmx2G -jar ftbserver.jar basicly). It starts running "almost" perfectly but people are unable to connect to it. (They can still join if I run the normal ftbserver.jar version).

    Anyone? :)
     
  2. Shadowmander

    Shadowmander New Member

    I am having the exact same problem. I allocated more ram to my server (java -Xms1G -Xmx4G -jar ftbserver.jar) and started it using the .bat file. I can join, but my friends can't. On their server list, it shows my server being offline. I told them to try joining anyway, but it didn't work. This only happens when running with a .bat file.

    Did you find a solution to this problem? And if so, can you tell me?
     
  3. Nessiroj

    Nessiroj New Member

    That's rather odd, cause what the .bat basicly does is starting the .jar with some extra information (ea extra ram). So if the .jar works the .bat has to work (unless you make a strange typo in the .bat).

    What i expect that is happening is that your "server" has gotten a new IP-adress and this aint portforwarded in your router, that way you can join bu other people from outside your network can't.
     
  4. Shadowmander

    Shadowmander New Member

    the .bat file reads exactly as i have it on my first post, so I don't think i have made a typo.

    If the server has a new IP-address, how do I go about finding/fixing this problem? I was able to log in using the same IP-address as before, so it seems unlikely. Nothing in the server properties file seemed to have changed. Also, when I play with my friends, they are on the same network as me. They are over at my house when we play, connected to our wifi. (I should mention that I do have hamachi. Does this effect anything?)
     
  5. Eyamaz

    Eyamaz New Member

    Starring from a jar and making java start the jar through an argument sometimes confuses AV and firewalls. Try temporarily disabling them.
     
  6. Shadowmander

    Shadowmander New Member

    I will try that later tonight, and see if it works
     
  7. Shadowmander

    Shadowmander New Member

    I disabled them, but it still did not work.
     
  8. Eyamaz

    Eyamaz New Member

    Ok, let me see if I remember my checklist (in at work)

    Is this a server host, or are you hosting your own?

    If your hosting your own:
    Are you playing from the same computer you are hosting from?

    Are your friends connecting via LAN or internet?

    If connecting from the internet:

    Is the port for the server forwarded to the proper computer?

    Are your friends trying to connect to your internet ip and not the local ip? (local is anything 192.x.x.x, this is lan only)

    About the server:
    Are your friends connection attempts showing up in the console?

    Is your server whitelisted? (i've seen ppl accidentally do this)

    I think that was all. At least a good start point anyway.
     
  9. Shadowmander

    Shadowmander New Member

    I am hosting my own server.

    I am playing from the same computer that I am hosting off of.

    Via Internet.

    I'm not sure about this part. We use hamachi to connect.

    The IP does not start with (192.xxx) So I assume it's internet.

    They are not.

    The server is not whitelisted.
     
  10. Eyamaz

    Eyamaz New Member

    Go into your router and manually forward the server port to your computer. This is slightly different per router so if you don't know how, you will need to look it up online.

    Have them connect through the minecraft multiplayer interface using your ip and the port instead of hamachi. For some reason, hamachi just doesn't like servers started with a batch file.
     
  11. Shadowmander

    Shadowmander New Member

    Do you think you could link to a good guide on how to do that? I looked at that when I started, but I couldn't wrap my head around it.
     
  12. Eyamaz

    Eyamaz New Member

    I don't have one right off hand. Google "port forwarding"
     

Share This Page