Open Pack crashes before even starting

Discussion in 'FTB Presents HermitPack 1.10.2' started by nuclearfarts, Dec 29, 2016.

  1. nuclearfarts

    nuclearfarts Guest

    Summary of the problem Pack crashes before even starting

    Pack Version
    Recommended


    What is the bug?
    When I click launch, the Minecraft window doesn't even open.

    Mod & Version
    No specific mod.


    Link to log file
    Minecraft doesn't even start when I click launch, so no log is generated. The launcher console says:
    SEVERE: Unhandled error launching minecraft
    java.lang.ClassNotFoundException: net.minecraft.client.Minecraft
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at net.ftb.legacylaunch.Launch.main(Launch.java:85)

    Is it repeatable?
    Yes, I just click launch and it repeats.

    Known Fix
    None.
     
  2. Henry Link

    Henry Link Popular Member

    So we need more to go on. This sounds like the legacy launcher have you tried the Curse launcher yet? Also, what are your system specs (physical RAM, CPU, etc)? How much memory did you allocate to play this pack? Do you have this problem with other packs?
     
  3. nuclearfarts

    nuclearfarts Guest

    I'm using the legacy launcher, and I absolutely refuse to use the Curse launcher unless it's curse launcher-exclusive because that thing is annoying as hell (stop trying to be two things at once - I don't want a damn voice client, I just want to install a modpack!) I have 8GB ram, 4ghz 8 core AMD processor, GTX 970, so I don't think that's the problem. Both DW20 1.10 and Infinity Lite 1.10 cause the same error, 1.7.10 packs are fine. I've allocated 4GB of RAM, so that's probably not the problem.
     
  4. UniZero

    UniZero Popular Member

    I have never had an issue installing or playing a modpack with curse yet. The old launcher will eventually be going away soon so I suggest switching to curse.
     
  5. nuclearfarts

    nuclearfarts Guest

    My issue with Curse isn't how the modpack installs work (that's actually designed pretty well), it's how it's also trying to be a voice client, when I have no need or want for one. And I just automatically hate any program where the red x minimizes it instead of closing it.
     
  6. Henry Link

    Henry Link Popular Member

    Don't get me wrong here. But I would like for you to at least try to use curse if only to test and see if the pack launches. Also, I've seen an awful lot of 8GB systems choke on 1.10.2 packs. Most of which require 5 GB just to run the pack only 3 GB for the OS. Which in most cases isn't enough to go around unless you shutdown almost every running program except the game. But, at present from what little info you have given for a log, try to launch it via Curse just to see if it works. Let us know what happens. If it loads, it sounds like you might need to delete the pack out and re-install it.

    Also, there is an option in the Curse setting to "Exit Curse" when the "X" is clicked. I know I have mine set that way. But I really don't want to de-rail your support thread with Curse vs. legacy launcher discussion.
     
  7. jikuja

    jikuja Launcher Dev Launcher Developer Global Moderator

    Are you using 1.4.3 version of legacy launcher or some cracked version? full log?
     
  8. nuclearfarts

    nuclearfarts Guest

    1.4.3 launcher, no idea where the full log is (Minecraft doesn't even start, so the Forge log isn't there.) If it was a ram problem, that it would at least make some progress launching then crash with an OutOfMemoryError. I also just tried Curse, it won't launch Minecraft because I have a space in my Windows username. *slowclap*
     
  9. Henry Link

    Henry Link Popular Member

    Huh? Your user name in windows has NOTHING to do with curse. Also, Curse supports spaces in path names and files. Something not right here and you aren't providing information or logs. We can't help if you don't give us details.
     
  10. nuclearfarts

    nuclearfarts Guest

    I'd give a full log if I knew where it was. Just tried Curse again, it worked this time. No idea why.
     
  11. Henry Link

    Henry Link Popular Member

    So now we know it is a problem with the legacy FTB launcher and not some other system issue. So completely remove and uninstall the legacy launcher then download a fresh copy from FTB's main page. You will find the links for the legacy launcher just under the big orange download now button. Don't forget to delete the .ftb from %appdata% as well before you reinstall it.
     
  12. nuclearfarts

    nuclearfarts Guest

    That worked! I guess not running the launcher for a year or so made it so out of date that it couldn't update. Thanks!
     
  13. Quetzi

    Quetzi Jack of All Trades Team Member Director of IT FTB Mod Dev

    The auto updater broke on one of the updates, yes
     

Share This Page