MPS Support Thread

Discussion in 'Mod Discussion' started by MachineMuse, May 9, 2013.

  1. RansomDemands

    RansomDemands New Member

    Last night I adjusted the appearance of my powersuit, then during the night my game had some cataclysmic crash that killed my level.dat.
    I restored my character, cheated in some armour to replace the set I had.
    Now when I adjust the appearance of my armour it looks all clunky and ugly.

    Is there a fix to keep the nice rendered texture when adjusting the colour of my suit?
     
  2. RedGrass

    RedGrass New Member

    If you're talking about the helmet then make the first part disabled by setting it on the first option. Any part of the suit you can make invisible by doing that. That should solve your clunkyness problem.
     
    kaovalin likes this.
  3. kaovalin

    kaovalin New Member

    Have you tried a newer version of MPS? I had to manually update the one that was in DW20 before because ICBM potion effects caused a crash when I was wearing them. It was related to radiation effects IIRC.


    Do you have TE recipes enabled in the config without TE being part of your modpack? Looks like it isnt finding recipes for TE stuff from the crash logs, but im by no means an expert.
     
  4. NoPain9

    NoPain9 New Member

    I'm currently having an issue which some the icons being all weird. I have a screenshot of it.

    Now first I'll say this: I'm using the Resonat Rise pack on the ATLauncher, I've tried the forums but not really much help came so I thought I'd tried it here.

    So from what I can see in the screenshot it seems to be some sort of conflict between mods, but here's the issue. I can't find any ID's of the items that are acting weird.

    Screenshot: http://gyazo.com/bf16c11006fa6bc169a1557c60d4e977

    On the left I have the Modular Powersuits mod open and I have highlighted the from the looks of it a ProjectRed chipset. On the right I have hovered over this particular chipset and I can see the name is 'Wiring'.

    Now again it seems to be a conflict. But from both mods I cannot find all the ID's. ProjectRed.cfg doesn't have a list of ID's for there chipsets, and the powersuits.cfg doesn't have the ID's for Solenoid for example (which is the one to the right of the 'Wiring').

    Now I can still make the parts and use them, that's not the issue. But I'd like to play with the original icons as it were. Saves me alot of confusion if you will :). Any idea's ?
     
  5. kaovalin

    kaovalin New Member

    Try searching for "conflict" in your luancher log. It will probably say some stuff about IDs with items conflicting. In this case, project red's ID are probably loading first and MPS tries to use the same IDs and gets denied. Since the recipes are just looking for the IDs it thinks it has MC says its the project red stuff. Had this happen the other day. Just have to be more thurough looking through the logs because its there. Might not be listed as the name you think it is, so use the # of the ID thats conflicting.

    Note: I think item IDs in game are 256 higher than what the configs are. Not sure of the exact value but you can easily figure that out looking at the configs. You could probably find that info online somewhere too.
     
  6. NoPain9

    NoPain9 New Member

    Tried this. Although I did find some Conflicts, they were only Ars Magica & Den Pipes. Nothing from Project Red or Modular Powersuits.
     
  7. MoosyDoosy

    MoosyDoosy New Member

    I doubt it's an ID conflict, just the items using the pictures of other items for some reason. Not really the biggest deal in the world if you specifically search for each item in NEI.
     
  8. NoPain9

    NoPain9 New Member

    Well that's the thing. Modular Powersuits picture's are all wrong or are recplaced with Project Red ones. Now I can still make them but it can be a bit confusing :p.
     
  9. MachineMuse

    MachineMuse New Member

    How can you be 100% sure if you don't even know how the heat system is supposed to work?

    Let me guess: you installed a kinetic generator and ran around a bunch. Well, guess what. The kinetic generator produces heat. That's what the big bar full of lava on the right hand side of the screen is for. Don't let that go over the top or you'll overheat. Simple.[DOUBLEPOST=1394655133][/DOUBLEPOST]As for the icon issue, it's fixed in an experimental build. I'll make it recommended soon.
     
    MoosyDoosy likes this.
  10. NoPain9

    NoPain9 New Member

    Ah cool. Like I said it isn't that big of an issue I can still craft things. I was just really confused at the start, love the mod though :)!
     
  11. Dodge34

    Dodge34 New Member

    I don't have any Kinetic Generators, I know they produce heat so I avoided them at all cost, I use the solar upgrade on the helmet instead and the most strange problem is before I had MPS addons installed, I had no overheat problems at all.
     
  12. Albin_Xavier

    Albin_Xavier New Member

    Don't the solar panels produce heat?
     
  13. Dodge34

    Dodge34 New Member

    Yes, but I have the cooling system, it should be able to cope with it, at the moment I don't have any problems, but my brother was forced to ditch all of his suit again yesterday, not sure what's happening but whenever he got any piece of his suit on the armor gui or in the hotbar and the selector was on it, he burned nearly instantly, and even underwater.
     
  14. MacAisling

    MacAisling Popular Member

    Suddenly overheating to the point where it kills you before you can take the suit off does seem to be a little too easy to achieve. I think my problem this last time was that I filled up the redstone energy cell in my inventory & the thermal generator could no longer convert the heat built up by the kinetic & solar generators...Just when you think you've got it all tweaked so it will no longer kill you...

    This is my 1st time using MPS, much to learn & some differences in flight to get used to, but I'm satisfied with it overall.
     
  15. Dodge34

    Dodge34 New Member

    So the fact that I carry some Tinkers Construct tools with a flux capacitor on them and the latest tier of redstone flux capacitor on me at all time to keep my tools charged could cause problems with my suit overheating, what kind of interaction could cause this, I noticed that when I have many tools that have a flux capacitor, the total charge of my suit is higher than when my tools are in my backpack, not sure why its like that.
     
  16. MacAisling

    MacAisling Popular Member

    The suit can draw power from & send power to the energy storage devices in your inventory & also power the tools in your hot bar. If you use the thermal generator to help cool the suit, you need some place for that power to go. I'm using a redstone (now resonant) energy cell instead of any of the internal power suit batteries & I'm producing more power than I'm using. This power sharing scheme is not unique to MPS, the nano armor does the same thing with IC2 compatible power tools, but it only acts like a battery & not a generator or I'm sure IC2 would find a reason to have its armor explode, too.
     
  17. SonarMB

    SonarMB New Member

    Just moved this from a standalone post into here as this is probably the more correct place to place it.

    Having a little issue. The powerfist vanishes on first use.I have the MV cap, Lux gen,pick, axe and shovel installed and as soon as I used the lux gen it (the Power Fist) vanished game remained on.
    All other MPS parts work fine, just the Fist! Anyone else having a problem. It has done it in the last few updates to DW's packs. Any hints?
     
  18. MoosyDoosy

    MoosyDoosy New Member

    Try cheating one in from creative.
     
  19. SonarMB

    SonarMB New Member

    That worked...odd how the one I made vanished still. I wonder if it was because it wasant fully charged when I used it?
     
  20. Stoo42

    Stoo42 New Member

    I'm on v1.0.18 of Direwolf20 pack, and I get this issue.

    Its been fine for ages, but today for some reason I instantly overheat - even if I only have the powerglove on my hotbar only, and the rest of the armour is in my bag! It goes to over 400 heat instantly, and I am instantly killed. Its happened in multiple biomes. Its happened while I'm just gliding along (using the modular glider), or if I'm just standing on the ground. The last time it happened I was standing on the ground for like 2 mins just fine (was alt-tabbed away), then I came back, was looking in NEI, and just instantly died from overheating.

    Definitely has to be a bug, I've used this armour for a while all over the place, and its never given an issue before, except for one of the other guys on the server having the same issue a while back.

    Looks like its back to quantum armour for me for a while... Three rapid deaths in succession has seen me lose nearly all my tinkers tools, plus a whole backpack full of extra tools...
     

Share This Page