Modular Powersuit Energy twitch?

Discussion in 'Mod Discussion' started by Flea, May 22, 2013.

  1. Flea

    Flea New Member

    I am having this problem with my power armor in a Tekkit server where something about the suit causes my devices to "twitch". By twitch, I mean that I try to mine some ore with my power tool and it just tried to break it endlessly, taking many tries to mine it before it actually breaks. Sometimes its so bad, that it wont let me use the power tool to mine simple cobblestone. I can remove pieces or armor and get it to work fine, mining at full speed with no twitch, so that must mean it has something to do with the way it interacts with the rest of my power suit. However, I can't figure out what I'm doing wrong.

    I've tried lowering the battery and turning off multiple devices, turning off the heat sinks, removing armor, and so on. Still, even when it comes with something as simple as nightvision, it causes my power tool to have this twitch problem. The same is true of my plasma canon. I try to fire or charge it and it "resets" the charging multiple times. I can't tell you how many times I've been killed trying to fire it, having a full 800k in energy for the darn thing, only to have the canon "misfire" and get my ass blown to hell by creepers.

    I also cant figure out what the IC2 tier slider is supposed to represent on the batteries. I've tried googling this for a few days and I guess I suck at googling because I can't find the answer. I know someone must explain this somewhere. I've tried looking at all the tutorial videos, but not only are they for the voltz version and don't seem to do a good job explaining my problem or the IC2 thing. The only thing I could figure out is that it has something to do with Industrial Craft 2, but thats about it.

    I don't know if they're related, but any help figuring out this "twitchy" problem would be most appreciated.
  2. Exasperation

    Exasperation Member

    I can't help with the rest of it, but I know the answer to this one: IC2 tools are assigned to technology tiers, and can't be recharged by a batpack of a lower tier than they are; that's why the mining laser can't be recharged from the lithium batpack. In older versions of the mod, the MPS batteries always counted as tier 1, and couldn't recharge higher tier IC2 tools (such as the aforementioned mining laser). This slider addresses that issue.
  3. Flea

    Flea New Member

    Thank you so much for this! That is one mystery solved. I'll play around with the sliders more purposefully to see if I can't derive some kind of relationship. Sadly, my server is down so I cannot test it on the offending armor, but If someone knows about the rest of my issues (like my jumpy plasma canon that tries to charge and resets a million times) I would appreciate further help.

    Thank you again!
  4. Dravarden

    Dravarden Well-Known Member

    I can confirm that also happens to me, can't even mine some cobble, but I have no idea what causes it/how to fix it.
  5. Peppe

    Peppe Well-Known Member

    Does the version in tekkit have the heat system?

    I believe the twitch you describe is your heat level preventing mining.

    No sure if it is intentional, but you can't mine if you have any heat.

Share This Page