MINECRAFT CORRUPT WORLD HELP

Discussion in 'Mod Discussion' started by dcf007, Mar 6, 2014.

  1. dcf007

    dcf007 New Member

    I was playing minecraft with mods installed (168 mods I think) suddenly my minecraft crashed , I restarted minecraft but now the world is missing, it is still in the saves folder but not in minecraft anymore, I tried to make a new world and replace the level.dat, level.dat_mcr, level.dat_old and session.lock like shown in a tutorial to recover corrupt worlds, but it didn't work as the world was still not showing up in minecraft. I can still open my world in mcedit, but how can I fix this problem? Please help.
    crash report:
    http://pastebin.com/9VcPymjT
     
  2. shockwave95

    shockwave95 New Member

  3. dcf007

    dcf007 New Member

  4. ThatOneSlowking

    ThatOneSlowking New Member

    Should have made back-ups
     
  5. dcf007

    dcf007 New Member

    I realize that now...
     
  6. b0bst3r

    b0bst3r New Member

    Tried removing Hats and Hatstand mods and loading your world?
     
  7. dcf007

    dcf007 New Member

    my world still doesn't show up in the singleplayer worlds, it isn't there, but in the saves folder it is
     
  8. dcf007

    dcf007 New Member

    I think I somehow fixed it, apparently I had a backup of my world from when I first created it, I noticed that in my corrupt world the file 'level.dat_old' was missing but in the backup, this file was there, so I copied the file to the corrupt world, opened minecraft and the world was there, everything works now.
    Thanks for your help though :D
     
  9. Dodge34

    Dodge34 New Member

    May I suggest you install Cobian Backup, its an easy freeware that can backup your save or world folder at your choice of intervals, it did save my life a few time, and it backup my server world every 2hrs to a different disk drive and every 10hrs to a cloud service (I use copy.com they offer 15GB of free space on the cloud and you can throttle the download and upload speed of their client so you can still enjoy playing the game while the backup is running...
     
  10. IsVictor

    IsVictor Guest

    I went to:
    http://minecraft.gamepedia.com/Tutorials/Recover_corrupted_saved_world_data
    I followed the instructions, but all I got was an extra button/link to go to the world I copied the (level.dat, level.dat_old, session.lock) package from.
    Basically, I only got an extra link to "BlankWorld" as it is called on the wiki page. I have no mods installed. I can see a lot of people are having this problem.
    Some help would be much appreciated, and if someone finds a solution I really think that the wiki page needs to be updated.
    I'm gonna go back to experimenting.
     
  11. Dodge34

    Dodge34 New Member

    Reviving a very very old dead topic here, don't think anyone will see this, you'd be better creating a new topic in the appropriate section, I got an email notification because I forgot to unsubscribe from this thread. I would help you if I could, but I can't really help you out on this one.
     
    ThatOneSlowking likes this.

Share This Page