1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Problem Mekanism Thermoelectric Boiler Problem

Discussion in 'General FTB chat' started by Reddis, Oct 3, 2018.

  1. Reddis

    Reddis Well-Known Member

    I built a thermoelectric boiler to provide steam to my mekanism turbine and I cannot get the boiler to make enough steam to (meaningfully) turn the turbine. The boiler is 5x5x7 and the turbine is 7x7x9. I connected 3 mekanism electric pumps to water source blocks and have 8 fuelwood heaters.

    I'm guessing that I am not pumping enough water into the boiler, but aside from adding 50x more electric pumps, I'm not sure what to do and would appreciate suggestions.

    The modpack is Enigmatica 2 normal. Thanks in advance.
     
  2. GamerwithnoGame

    GamerwithnoGame Forum Addict

    This is probably going to sound daft, but have you fully upgraded your mekanism pumps with speed (and ideally energy) upgrades?
     
    LordPINE and Reddis like this.
  3. Reddis

    Reddis Well-Known Member

    Oh good lord no lol. It never occurred to me to put speed upgrades in a pump! Thanks Gamer!
     
    LordPINE and GamerwithnoGame like this.
  4. GamerwithnoGame

    GamerwithnoGame Forum Addict

    No problem! This is where I hope I've remembered correctly and that they CAN go into pumps (I'm fairly sure they can).

    They definitely should work :) If they aren't too expensive I'd definitely add at least an energy upgrade per speed upgrade you put in. Also, make sure that fluid throughput isn't limited by your pipes (I've been caught out by that before!)
     
    LordPINE and Reddis like this.
  5. Reddis

    Reddis Well-Known Member

    As a side note, if you (anyone reading this) has never used a Mekanism turbine... wow! The tiniest bit of steam generated hundreds of millions of RF for me. I honestly have no idea what to do with it all lol.
     
    LordPINE and GamerwithnoGame like this.

Share This Page