low fps on really good pc

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here
T

TheCowanplayzz

Guest
specs

i7 7700HQ
16GB RAM
GTX 1060 6GB

im getting about 40 fps any way that can be higher?
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
Need way more info :)

What's your view distance?
What modpack?
Are you using shaders?
How much RAM is allocated?
Are you using a custom texture pack?
Do you have any java arguments in your launcher?
What launcher are you using?

Hell, that's not even enough info, but it might help.

I can tell you that I've had the most luck with Optifine, which is usually not included in modpacks. The mod itself tends to help with stability for me, but the real deal is that it opens up a bunch of options for really tweaking performance, and (I'm not 100% sure of this, take it with a grain of salt) I believe it moves some of the workload to the graphics card, freeing up some processor real estate. I can go from a 40ish frame rate to a stable 90+ on a relatively fresh world just by tweaking the right things.

Anything else, we'd need more info.
 
T

TheCowanplayzz

Guest
view distance is 16
my mudpack is ftb relevation
no shaders
8 gb ram allocated
no custom texture packs
I don't know how to check and what to do if there is one
im using the twitch launcher
I have optifine installed
 

Cptqrk

Popular Member
Aug 24, 2013
1,362
635
138
May be over allocating ram, cut that down to 6gigs max for the pack

Optifine can make things look nicer, but it has some issues with some mods.. could be part of your issue as well.
 

Hambeau

Over-Achiever
Jul 24, 2013
2,602
1,533
213
My system is:
Ryzen 5 1600 3.2Ghz (Self-boosted to 3.75Ghz)
16GB DDR4-3000Mhz
GTX 1060/6GB

Pretty much the same as yours.

The lowest fps I've ever seen with the packs I play is 98, for a moment.

The only differences I see between our setups are:

I allocate just under 7GB... I don't see your allocation being much of a problem for a 1.12 pack.

My packs are Direwolf20, Enigmatica 2, both Normal and Expert mode, both for MC version 1.12.x

I do NOT have Optifine. Try disabling that from running and see what happens, as an experiment.
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
view distance is 16
my mudpack is ftb relevation
no shaders
8 gb ram allocated
no custom texture packs
I don't know how to check and what to do if there is one
im using the twitch launcher
I have optifine installed
That should be running at like 100 FPS. At this point, I'd run a virus scan. I'm really not sure what's going on here.

They're not wrong in suggesting the possibility of allocating too much RAM, but in my experience all that does is cause some stuttering later on. It shouldn't hurt your frame rates. 16 view distance is not pushing it in any way, either.

My only other recommendations is to go through all of the video settings that optifine adds. Specifically go through each one that has an option of "fast" "fancy" or default and set them all first to fancy, then to fast to see if there's a difference, but anything but default. Disable aniscopic filtering. Then go to the performance tab and check off things like fast math, try messing with chunk updates (I have always liked 3, but experiment), set dynamic chunk loading to on. And from the main menu, look for something like multi-core for chunk loading. Under the animation tab, the biggest culprit there is terrain animation, try shutting that one off.

If I had it up in front of me, I could be more detailed, but these are the things I have to set every time I start a new world.

BTW, recommend the faithful 32x pack. It has support for a lot of mods and seems to be entirely lag free. Looks just like normal minecraft, just a liiiitle sharper.
 

adamich

New Member
Jul 29, 2019
697
0
0
Do U have any bitcoin miner turned on? On Ur specs U must have a lot FPS.
1. Virus/troyan
2. Miner: webminer on some site U watch or miner started by virus.
3. Video drivers:
a. Download latest.
b. Download not latest, up to 2-4 version downgrade.
4. Install latest version of GTX buster. May be Ur videocard work in some kind Silent mode or Low energy mode.
5. Install latest version of Java.
 
T

TheCowanplayzz

Guest
I'm using v sync with my monitor since its at 60hz also when I lower my ram to 6gb, the memory limit reaches 80% and fps drops for some reason

and im trying to play ftb relevation
 

LoGaL

Well-Known Member
Aug 4, 2013
173
36
54
same processor, same amount of ram but with a gtx1050, not 1060ti, and i am facing the same issue
I would consider acceptable a lower fps in a world full of machines but not in a fresh one
Funny thing is that my old laptop, which had a less powerful processor/GPU and less ram, used to run 1.7.10 packs with better fps
 

Hambeau

Over-Achiever
Jul 24, 2013
2,602
1,533
213
same processor, same amount of ram but with a gtx1050, not 1060ti, and i am facing the same issue
I would consider acceptable a lower fps in a world full of machines but not in a fresh one
Funny thing is that my old laptop, which had a less powerful processor/GPU and less ram, used to run 1.7.10 packs with better fps
Like @zemeric said above, if your system has Intel Integrated Graphics on the motherboard and you haven't disabled it then chances are about 98% that Minecraft is ignoring the GPU and using the built in graphics. Go into your BIOS and see if you have a setting to switch the default video basically anything but "Integrated" should work. If you are using the Integrated Graphics you also are losing up to half a GB of your system ram because the system uses that for video memory.
 

LoGaL

Well-Known Member
Aug 4, 2013
173
36
54
Actually i don't think so, the nvidia driver says the dedicated gpu is being used when minecraft is on. I manually added java to the list of programs that should use the dedicated gpu
But i will try nontheless
 

Hambeau

Over-Achiever
Jul 24, 2013
2,602
1,533
213
Actually i don't think so, the nvidia driver says the dedicated gpu is being used when minecraft is on. I manually added java to the list of programs that should use the dedicated gpu
But i will try nontheless
The "dedicated gpu" is exactly what you DON'T want to enable... Dedicated, in that sense, means built-in.
 

LoGaL

Well-Known Member
Aug 4, 2013
173
36
54
nono dedicated means dedicated memory (it's own one)---> it's not the integrated one ( i know how to tell the pc which GPU to use, it's not the first time i do it).
Seems, however, that you are right
i checked with the task manager and minecraft keeps using the integrated GPU instead of the dedicated one.( and the nvidia driver says that the gtx is being used! that's weird) With other games such as dota it tells that the other one is running.
Anyone else has a workaround for it? i wouldn't like to use the dedicated GPU as a default changing bios settings, as this is a laptop and it alrdy chews through the battery fast enough
 

LoGaL

Well-Known Member
Aug 4, 2013
173
36
54
Update: for those looking for it
(N.B. my desktop is in italian, so i am translating the names) go to NVIDIA control panel---> on the left, "manage 3D settings" ---> in the middle of the screen "program settings" ---> add
!!!!!here is the thing: specify the nvidia control panel to use the dedicated gpu FOR THE ENTIRE JAVA FOLDER !!!!!!!
Edit: more weird stuff happens, as it seems to revert to the intel gpu after some time
Editedit: i jump from 120 fps to 30 when i maximize the minecraft window and the task managers says i start using the integrated gpu
EditEdit: no way to force minecraft resolution? my issue could be due to my 4k monitor o_O ( i know optifine does it)

(Maybe you don't even care but i will write my progress here)
 
Last edited:

Hambeau

Over-Achiever
Jul 24, 2013
2,602
1,533
213
nono dedicated means dedicated memory (it's own one)---> it's not the integrated one ( i know how to tell the pc which GPU to use, it's not the first time i do it).
Seems, however, that you are right
i checked with the task manager and minecraft keeps using the integrated GPU instead of the dedicated one.( and the nvidia driver says that the gtx is being used! that's weird) With other games such as dota it tells that the other one is running.
Anyone else has a workaround for it? i wouldn't like to use the dedicated GPU as a default changing bios settings, as this is a laptop and it alrdy chews through the battery fast enough
Ok, I misunderstood. To me, "dedicated" refers to being unable to physically remove. I call the plug-in board a GPU to distinguish the two. A GPU could, if needed, be removed and put into another system then moved back when the need is over.

For me your issue isn't a problem, since I have no Integrated Graphics on my motherboard.

[Edit] I seem to recall that there is a setting in Java to force the use of the better graphics option, but I'm not sure. I ran into this with a laptop I bought several years ago. If you're interested, the newer laptops that use APUs don't have this problem except you'll need to verify you have enough ram. I have an HP with the new AMD Ryzen chip that includes VEGA graphics... The Drawback is the better graphics need more ram. I have 8GB in the laptop and the video takes between 2 and 4GB of that away, depending on game settings. If I upgrade to 16GB then that number goes up to 8GB, but that's the maximum amount.

Intel is moving away from Integrated graphics as well... They're making their own APU version now that also uses VEGA video until they get their Graphics program up and producing chips.
 
T

TheCowanplayzz

Guest
I think I found the reason, when I press f3 on my Minecraft and it shows your pc info, it shows my memory usage and I play fine until it hits up to 80% and goes back down and the fps drops. I have 6gb of memory allocated to Minecraft.
 

adamich

New Member
Jul 29, 2019
697
0
0
1. Do U play 1.10+ modpack? If U play 1.7.10 do not dedicate more 4 GB.
2. "Java GC is broken?" - Try uninstall java, reboot, use CCleaner, install java.