Problem Lag Spikes


New Member
Jul 29, 2019
I recently changed server company and simultaneously made a few changes that have unfortunately lead to lag spikes fairly regularly on my unleashed server. Unfortunately I can't figure out for the life of me what is causing them as the server is significantly better than the previous one (mainly processor wise - Xeon e3 1245v2 to Xeon e5 1650) though simultaneously I have gone back to a regular HDD as opposed to SSD. - despite this change however I am certain the lack of an SSD is not the issue as that should only affect world loading speed, and is not necessary on a server reaching peaks of 45 players.

Anyway moving on, we run MCPC+ with around 25 plugins, nothing has changed since before the move so i don't believe it is that, though we are running on the 1.1.3 version of unleashed which I believe is a bit temperamental in several ways.

We are running on the latest tick threading patch which was installed before the change - again no issues previously.

I use the start command: java -Xms32G -Xmx32G -Xmn8G -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=31 -XX:+UseG1GC -XX:MaxGCPauseMillis=40 -XX:GCPauseIntervalMillis=400 -XX:+AggressiveOpts -XX:permSize=1024m -XX:+TieredCompilation -XX:ReservedCodeCacheSize=2048m -XX:+UseCodeCacheFlushing -XX:CompileThreshold=1000 -jar server.jar nogui

Which was changed the same day as the switch, but I have tried on my previous command and still get lag.

The new server is with OVH hosting meaning it was a completely clean server. I installed Java, and now think that maybe I installed the wrong one:

Now using: java version "1.7.0_25"OpenJDK Runtime Environment (IcedTea 2.3.10) (7u25-2.3.10-1ubuntu0.12.04.2)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

I was using: java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

Could that be an issue or have I not installed a piece of software perhaps for FTB server hosting?


New Member
Jul 29, 2019
check wish version of java you are using for the server as the default may be pointing to a 32bit (if i remember correctly adding -d64 will force 64 bit mode) As for your arguments are you really using 32GBs of ram? If not move the amount of ram you allocate lower especially the Xms.