Bug io.netty.handler.timeout.ReadTimeoutException: null issue

Kissune

New Member
Dec 20, 2019
1
0
2
I run a FTB Revelations server, using a hosting provider, with only a couple of extra mods added (galacticraft and ProjectE specifically)

One of the players I play with has an issue where if he connects to the server, he can play for about 10 seconds, before getting timed out. When he does, his model stays in the game for a little while, before eventually disconnecting itself. When it does, this is the error it throws in the console. He can connect just fine, but he gets booted after a few moments.

[00:27:27] [Netty Epoll Server IO #5/ERROR] [FML]: NetworkDispatcher exception
io.netty.handler.timeout.ReadTimeoutException: null
[00:27:27] [Server thread/INFO] [minecraft/NetHandlerPlayServer]: PLAYERNAME lost connection: Disconnected

I think it's a problem with him specifically, and not the provider, because everyone else on the server (10 people in total) can connect just fine, with no problems. That's why I'm not going to the hosting provider for support.

Things we have tried:

Resetting his router.
Restarting game.
Reinstalling the launcher and modpack.
Resetting winsock
Reinstalling Java
Deleting his player.dat
Restarting server
Connecting to a different server on a different version (Worked fine?)
Running the world on a hamachi connection (Worked fine, he could connect)

We know the problem has to be that either he has issues with connecting to specifically that server, or that server has problems allowing him specifically to connect. This has been a nightmare to troubleshoot, and I still don't know what the fuck the problem is. I don't know why he can connect, move around and interact with things for a few seconds, before getting timed out.