Solved Gear and Plate recipes don't work - 2.0.0

Discussion in 'FTB Revelation' started by AWZool, Jun 13, 2018.

  1. AWZool

    AWZool New Member

    Summary of the problem Gear and Plate recipes don't work

    Pack Version 2.0.0

    What is the bug? Copper Gear and any plate recipe don't work. JEI shows the recipe but it can not be crafted on a workbench (IE hammer and IC2 forge hammer)

    Metal former, casting, metal press and (probably) other mechanized ways of creating plates and gears work.

    The problem is, to create a plate by machinery, you need to create some plates by hammers first, so it's pretty game breaking.

    Mod & Version

    Link to log file

    Is it repeatable? yes

    Known Fix probably some change in the 01_unification.zs
     
  2. GamerwithnoGame

    GamerwithnoGame Forum Addict

    I've seen some else post about this and they got no reply :( Are you using a new hammer to try the craft?
     
  3. AWZool

    AWZool New Member

    Tried every type of hammer/wrentch, full health (since I couldn't craft any plates, there were no durability loss).
     
  4. GamerwithnoGame

    GamerwithnoGame Forum Addict

    Damn. Sounds like you’ve already covered the things I would have suggested, sorry :(
     
  5. AWZool

    AWZool New Member

    NP :)

    I have a few ideas, first and foremost fiddling with the 01_unification.zs script. In 1.8.0 these things worked, and the unification file "fixed" exactly these things, so... But I can't run a MC atm because my workplace workstation have a potato vga card :-/

    namely: these lines were added:
    Code:
    #fix tin recipes
    recipes.remove(<thermalfoundation:material:257>);
    recipes.addShaped(<thermalfoundation:material:257>, [[null, <ore:ingotTin>, null], [<ore:ingotTin>, <ore:ingotIron>, <ore:ingotTin>], [null, <ore:ingotTin>, null]]);
    
    #Plate Fixs
    recipes.remove(<thermalfoundation:material:325>);
    recipes.remove(<thermalfoundation:material:324>);
    recipes.remove(<thermalfoundation:material:352>);
    recipes.remove(<thermalfoundation:material:33>);
    recipes.remove(<thermalfoundation:material:321>);
    recipes.remove(<thermalfoundation:material:320>);
    recipes.remove(<thermalfoundation:material:32>);
    recipes.remove(<thermalfoundation:material:323>);
    recipes.remove(<thermalfoundation:material:353>);
    recipes.remove(<thermalfoundation:material:327>);
    recipes.remove(<thermalfoundation:material:356>);
    recipes.remove(<thermalfoundation:material:358>);
    recipes.remove(<thermalfoundation:material:359>);
    recipes.remove(<thermalfoundation:material:354>);
    recipes.remove(<thermalfoundation:material:357>);
    recipes.remove(<thermalfoundation:material:328>);
    recipes.remove(<thermalfoundation:material:326>);
    interestingly enough, tin gear works fine.
     
  6. GamerwithnoGame

    GamerwithnoGame Forum Addict

    Huh... weird. And there's no lines adding in recipes for those things? I guess if you know the item names, you can copy the format and add gear recipes. Looks like that's designed to, at a guess, remove the crafting of TF versions of the plates full stop.

    You can't cast plates in a smeltery can you? I don't know much about the pack, so I don't know if that's a dumb suggestion - especially if you'd need a plate to create the plate cast in the first place.
     
  7. AWZool

    AWZool New Member

    There are lines after it adding (seemingly) the recipes for the plates, this is just the diff to the 1.8 version of the 01_unification.zs.
    My suspicion is that the new recipes that are added never worked, but the 1.8 version didn't remove the original recipes, so it worked after all.

    I only tried the metal former, which worked. My suspicion is that all the machined recipes work, since they weren't removed(?)

    I'll try out 2 alternatives to the script at home, and post the results. I attached the file if you want to experiment in the mean time (the commented out lines are my second idea for the IE hammer)
     

    Attached Files:

    GamerwithnoGame likes this.
  8. AWZool

    AWZool New Member

    I found the problem: I removed 2 addons (embers and rustic), and apparently MineTweaker shits itself if one script contains invalid recipes and doesn't execute the rest (and doesn't log out anything but a NPE -.-)

    case closed: PEBKAC XD
     
    GamerwithnoGame likes this.

Share This Page