FTB MotM Botania (July) Quest Bugs

Discussion in 'Modpack Bugs' started by Bashful Giant, Jul 2, 2015.

  1. Bashful Giant

    Bashful Giant New Member

    Please post any bugs relating to quests in here. This is NOT a discussion thread, and "I don't like X or Y" posts will probably be ignored. I'll try to provide support as much as possible, and fix any bugs as and when they arise.
     
    Last edited: Jul 6, 2015
  2. electrifeye

    electrifeye New Member

    I'll just quote my posts from the other thread, easier than typing them out again
     
    MULTIK and Bashful Giant like this.
  3. Hydrattler

    Hydrattler New Member

    I personally don't know any bugs but Vazkii has a few mentioned in some of her earlier tweets iirc
     
  4. Bashful Giant

    Bashful Giant New Member

    Most of those were simply NYI quests, hidden to users not in edit mode. The quest locking them had a description stating this, but TBH should probably have been completely removed rather than hidden. I was borderline on that, and from the looks of it, chose the wrong side of the border to fall on.
     
  5. randomshananzer

    randomshananzer New Member

    Hey so i was playing the MOTM and when i collected the bane of arthropods wooden sword it didnt register in the book. i pressed manual detect and it still didnt register. This also happened to me with the Rod of the Skies. I tried using NEI to get one from cheat mode and it still didnt register. (just to specify, i made the rod of the skies and it didnt work and THEN i cheated another one in to see if it would fix it and it didnt.)
     
  6. Sarah Swiftwind

    Sarah Swiftwind New Member

    In addition to the enchanted wooden sword quest I found some other quests that don't appear to work properly
    Beyond the Basics -> FOCUS! (Craft a Mana Lens): doesn't detect the mana lens when crafted or using manual detect
    Flowers -> Exoflame: doesn't seem to have the flower registered in the detection task

    Some quest text is wrong/misspelled as well.
    Basics -> Terrasteel: Instructs to use Livingwood but you need to use Livingrock.
    Basics -> Brews: "Brewing Stang" should be Brewing Stand, and it's a Rune of Mana not a Rune of Fire that's used in the recipe
     
  7. Akan0

    Akan0 New Member

    Mystical Items --> Rod Of The Skies: doesn't detect the Rod Of The Skies when crafted or using manual detect.
     
  8. Bashful Giant

    Bashful Giant New Member

    Yeah- I found myself constantly typing livingwood rather than livingrock. I'm not surprised it slipped through uncorrecred at least once! Will see about pushing a patched HQM file soon to fix the bugs and typos you're all reporting. Thanks for all the reports!
     
    PhoenicsThePhoenix likes this.
  9. SifrNihilum

    SifrNihilum New Member

    Here's what I've found so far...
    Elven Trade will not detect my alfheim lexicana, no matter what.
    More Enchanting won't detect the sword either...
    I had some issues with other quests, but for the most part dropping the item and then picking it back up fixed it.
    I love this idea though. Mod of the month. Fantastic.
     
    PhoenicsThePhoenix and clockgen like this.
  10. Andy Dufresne

    Andy Dufresne New Member

    The quest for the Tainted Blood Pendant dont seem to detect it no matter what i do.
     
  11. cbenneck

    cbenneck New Member

    After update to 2.0.1 following bugs remaining:

    - quest "more enchanting" didn't detect the sword
    - (idk if it is a bug) flower "munchdew" is not stackable
     
    PhoenicsThePhoenix likes this.
  12. Bashful Giant

    Bashful Giant New Member

    Hmm. I thought I'd fixed that quest. Tested it and everything. Considering that was a rework of a previously impossible quest, may have to pull it.

    Just make sure you're enchanting a wooden sword with the Bane of Arthropods 1 book rewarded from the previous quest. If that fails, I'm well and truly stumped as to why it's broken.


    Sent from somewhere.
     
  13. cbenneck

    cbenneck New Member


    I've tested also a new entchanted sword with the book from the quest before...also does not work.
    My other 2 books are protection and projetile protection and do not work on wooden swords
     
  14. Mysticalmaid

    Mysticalmaid New Member

    Spark Network in Basic Quests doesn't update properly, it's green and says completed, but there is no button to submit and the red "unlocks 1 quest elsewhere" is still there.
     
  15. Mysticalmaid

    Mysticalmaid New Member

    Had a minor issue updating the "Mana Lens: Efficiency" quest, dropping the lens and picking it back up fixed it though.
     
    MC.SUNNISHINE likes this.
  16. PhoenicsThePhoenix

    PhoenicsThePhoenix New Member

    Yeah, same thing for me with the efficiency lens. Works after dropping it and picking it back up.

    Also getting the same problem as everyone else with the more enchanting quest. I thought it was my fault because i accidentally lost the original book, and made a new one. Confirmed not working when I used a new world and the NEI to save bring another one hot out of the quest book to my original world.

    Also, kinda moot but there are noticeably many spelling errors. Forgivable, because the modpack is actually pretty damn good, but it does detract from the quests a bit.
     
  17. Bashful Giant

    Bashful Giant New Member

    I typed directly into the book, which unfortunately doesn't have a spellchecker. Apparently, my spelling... sucks. to say the least. I'll run it through a spellchecker first next time :p
     
    PhoenicsThePhoenix likes this.
  18. The lens quests are all "broken".. dropping them and picking them up works, but has there been a fix released? (yes, I totally realize I'm almost a year behind the times LOL)
     
    Bashful Giant likes this.
  19. Bashful Giant

    Bashful Giant New Member

    Unfortunately, it was a bug with hqm itself. I couldn't fully fix it :/ glad people are still playing the lack!
     
  20. Adam1991

    Adam1991 Guest

    Hey. I've only just got into minecraft and started on this pack. Is there anyway arround the wooden sword issue cos that's what's limiting me ATM.
     

Share This Page