1. This section of the forums is now closed. You can post and answer support requests on the new support site here

FTB Launcher Crash

Discussion in '[Archived] Tech Support' started by Jared K, Dec 15, 2013.

  1. Jared K

    Jared K New Member

    My launcher keeps crashing and I don't know why. It starting happening right after I updated to the new version that came out today. I can show you what the console says, but other than that, I don't know what happened.

    FTBLaunch starting up (version 1.3.0)
    AnalyticsBackgroundThread started
    Java version: 1.7.0_21
    Java vendor: Oracle Corporation
    Java home: C:\Program Files\Java\jre7
    Java specification: Java Virtual Machine Specification version: 1.7 by Oracle Corporation
    Java vm: Java HotSpot(TM) 64-Bit Server VM version: 23.21-b01 by Oracle Corporation
    OS: amd64 Windows 7 6.1
    [i18n] Checking for updates ...
    [i18n] enUS English language file loaded!
    [i18n] remoteVer = 10
    [i18n] localVer = 10
    [i18n] Files are up to date
    [i18n] Fallback enUS loaded
    The FTB Launcher has found the following Java versions installed:
    From Console: Exception in thread "AWT-EventQueue-0"
    From Console: java.lang.ArrayIndexOutOfBoundsException: 3
    From Console: at net.ftb.util.winreg.JavaInfo.<init>(JavaInfo.java:61)
    From Console: at net.ftb.util.winreg.JavaFinder.findJavas(JavaFinder.java:95)
    From Console: at net.ftb.util.winreg.JavaFinder.parseWinJavaVersion(JavaFinder.java:131)
    From Console: at net.ftb.gui.panes.OptionsPane.<init>(OptionsPane.java:128)
    From Console: at net.ftb.gui.LaunchFrame.<init>(LaunchFrame.java:504)
    From Console: at net.ftb.gui.LaunchFrame$1.run(LaunchFrame.java:274)
    From Console: at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    From Console: at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    From Console: at java.awt.EventQueue.access$200(Unknown Source)
    From Console: at java.awt.EventQueue$3.run(Unknown Source)
    From Console: at java.awt.EventQueue$3.run(Unknown Source)
    From Console: at java.security.AccessController.doPrivileged(Native Method)
    From Console: at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
    From Console: at java.awt.EventQueue.dispatchEvent(Unknown Source)
    From Console: at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    From Console: at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    From Console: at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    From Console: at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    From Console: at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    From Console: at java.awt.EventDispatchThread.run(Unknown Source)

    That's where it stops. Please help me.
     
  2. VLinden

    VLinden New Member

    I'm having the same problem, a solution would be really appreciated.

    edit: The only difference is: my java version is 1.7.0_25
     
  3. 50_Ind1g0

    50_Ind1g0 New Member

  4. Jeff Something

    Jeff Something New Member

  5. Themistocles

    Themistocles New Member

  6. Toxic_Runts

    Toxic_Runts New Member

    Ive seen no replys from any one on how to fix it... funny thing is that none of the mods comment on it
     
  7. Dorkstinn425

    Dorkstinn425 New Member

    I am having the same issue, hope there is a fix soon.
     
  8. Voorhees3388

    Voorhees3388 New Member

  9. 50_Ind1g0

    50_Ind1g0 New Member

    This is still fairly new, if anything they're either A: trying to replicate it, B: sleeping/chilling with family or stuff (it is sunday in europe) C: re-syncing the launcher to the DL servers or D: already realize what the problem is and are trying to fix it. give it time. besides, it isn't too big of a deal yet.
     
  10. grand_mind1

    grand_mind1 New Member

  11. mellamokb

    mellamokb New Member

    The problem seems to be the logic that tries to find all Java installs (JavaInfo.java). It makes the assumption that every version of java has 4 parts - major, minor, revision, and build. However, this is not the case. Some installs of Java don't have a build number. For example, these are the installs present on my system (in c:\program files\java):
    jdk1.6.0_24
    jdk1.6.0_30
    jdk1.6.0_33
    jdk1.7.0
    jdk1.7.0_25

    Note that jdk1.7.0 has no build number. So the code attempts to split into 4 parts and read all 4 parts... hence the ArrayIndexOutOfBoundsException with value 3, because this version doesn't have a 4th part (index 3).

    The solution for me was to uninstall jdk1.7.0, since it's an older version of Java and I don't need it.
     
    Last edited: Dec 15, 2013
    techbrew and Jeff Something like this.
  12. Tapar11

    Tapar11 New Member

    Thanks so much! That was exactly the fix I needed. I had 1.7.0 installed.
     
    Toxic_Runts likes this.
  13. Themistocles

    Themistocles New Member

    It worked! Thank you so much!
     
  14. Jason Sanchez

    Jason Sanchez New Member

    I've submitted a patch to the FTB github, you can find it here if you're interested. Thanks to mellamokb on the diagnosis, made the patch easy to make.
     
    Jeff Something likes this.
  15. Jared K

    Jared K New Member

    Thanks guys!
     
  16. Voorhees3388

    Voorhees3388 New Member

    Confirmed removing 1.7.0 worked! I spent many hours before reading this trying to get it to work, gave up and had a friend zip me his files. Thanks a lot!
     
  17. joedgreat

    joedgreat New Member

    how do i delete "jdk1.7.0" i don't know how to get to the file?
     
  18. Jeff Something

    Jeff Something New Member

    Assuming you're using windows, you can uninstall it from the control panel. The fix seems to have been implemented in the next launcher version, so as soon as that is released, the problem should be solved in any case.
     
  19. joedgreat

    joedgreat New Member

    I am using windows but i do not know where to look in the control panel for the "jdk" i know it will probably be fixed soon but i want to play ftb again soon thanks
     
  20. xxmelle

    xxmelle New Member

    i have the same problème but don't have multiple java i have delete old folder delete java do all it said everywhere but still don't work no change exept the update of the launcher

    http://pastebin.com/THzmyfWr
     

Share This Page