Problem FTB Direwolf 20 1.6.4 Server Lag

Francis Baster

New Member
Jul 29, 2019
295
0
0
so i play only whit a friend of my so we are whit 2 people. and it gives lag spikes.. some times only when running.. so its just randering to mutch ?? or do i need to get more ram for the surver?? useing serverstart.bat whit
java -Xms2048m -Xmx2048m -XX:permSize=128m -jar FTBServer-1.6.4-965.jar noggin
pause
Your serverstart.bat looks good, and 2GB should be plenty of RAM for a small server.

Can you be more specific than lag? Your problem could be low frame rate spikes on your client (screen freezes), low tick rate spikes on your server (commonly known as block lag, blocks can reappear or take a long time to drop as items when you break them) or you could have network bandwidth lag (the map is slow to load after joining the server or teleporting around, server doesn't respond until map is finished loading). Which of these sounds the most like your problem? If this is not related to tick rate lag spikes on a 1.6 DW20 server, then you may be best to start your own forum thread.
 

Luminus

New Member
Jul 29, 2019
18
0
0
For those of you trying to set Peaceful mode to see if it's able to be fixed that way, it doesn't help. Even in Peaceful, for a fraction of a second, mobs will still try to spawn. Set it to Peaceful to clear the mobs, do "/gamerule doMobSpawning false", and then see if anything changes.

For Direwolf20 pack (dunno about MCPC, don't use it), I would advise no less than 3GB of RAM dedicated for ~4-5 players, including yourself (my own server runs 2.5GB, and sits around 60% usage on startup, another 10% if I (and only I) connect and start playing).
 

Protous

New Member
Jul 29, 2019
1
0
0
I was having the same issues with lag death -- and some crashes, found a thread that suggest adding this to the start (I run a duel Xeon 2.0ghz Server - Windows 2k8 r2 sp1, 8 gigs of ram. Changed my bat file to the following now the server runs like a scalded ape!

Code:
java -Xms2048m -Xmx4096m -XX:PermSize=256m -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:MaxGCPauseMillis=10 -XX:GCPauseIntervalMillis=50 -XX:MaxGCMinorPauseMillis=7 -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc -jar FTBServer-1.6.4-965.jar
pause
edit [typ 0 in server os]
 
  • Like
Reactions: Francis Baster

Sisrace

New Member
Jul 29, 2019
19
0
0
I was having the same issues with lag death -- and some crashes, found a thread that suggest adding this to the start (I run a duel Xeon 2.0ghz Server - Windows 2k8 r2 sp1, 8 gigs of ram. Changed my bat file to the following now the server runs like a scalded ape!

Code:
java -Xms2048m -Xmx4096m -XX:PermSize=256m -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:MaxGCPauseMillis=10 -XX:GCPauseIntervalMillis=50 -XX:MaxGCMinorPauseMillis=7 -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc -jar FTBServer-1.6.4-965.jar
pause
edit [typ 0 in server os]
I had the same problem but my server is running linux.
It said that something was wrong with the start code so i tried to make the .jar file more accessable but it didnt work ( /home/server/Desktop/FTB/ServerStart.sh )
Then i added nogui after the FTBserver.jar and it started, Did you happen to do a misstake when publishing the startcode or will it just not run in linux without nogui but it works without on windows?