FTB Beyond Immersive Engineering - Can't Make Metal Press?

Discussion in 'Tech Support' started by AtlantisRising, Jun 27, 2017.

  1. Title FTB Beyond Immersive Engineering - Can't Make Metal Press?

    Launcher Type Server

    Modpack FTB Beyond

    Modpack version 1.10.2

    Have you modified the pack? No

    Link to log file

    Details of the issue No error log attached as there is no error actually generated on server or client, other than the expected result not occurring. For Immersive Engineering, there is a multiblock structure called a Metal Press you make using 2 steel scaffolding, 2 conveyor belts, a heavy engineering block, a redstone engineering block, and a piston. The mod's in-game manual (and the FTB wiki) show the same instructions for building it which I've done, with one rather significant issue.

    To turn the blocks into the Metal Press once placed, you right-click the piston (which must be facing downward) with the Engineer's Hammer to turn it into the Metal Press multiblock structure. In Single Player, this works just fine, and it's created as expected. However when I tried this in Multiplayer (using a standalone FTB Beyond 1.10.2 server I was running for friends), the piston changes orientation instead, and no multi-block is created. I've tried breaking it, rebuilding it, doing it in a new location, and every time the result is the same.


    I'm unfortunately unsure if this is a bug within Immersive Engineering or if it's a weird conflict with another mod, but it does appear to be something with servers specifically, since it doesn't appear to affect single player at all. Beyond that, I'm not sure what else to try. I can try to post pictures if needed, but given that the exact same setup works in single player consistently but not in multi-player, it sounds like something is definitely broken.

    And for the sake of clarity, I did make sure multiple times that both conveyor belts were pointed the same way (which is required for it to build), and that it was a heavy engineering block and not a light one.
     
    Last edited by a moderator: Jun 28, 2017
  2. Solved thanks to mod maker, did not know there were belts that are set as "ignore redstone control," and that was the belt I was trying to use (which is why it didn't work at all).

    Can close whenever someone sees this, no actual bug.
     
    GamerwithnoGame likes this.
  3. GamerwithnoGame

    GamerwithnoGame Forum Addict

    That's a very useful point to know though, as the redstone non-control conveyors look identical to the controllable ones, so that's definitely handy to be aware of!
     
  4. Still irritates me to no end that I -thought- I tried everything and never noticed there were 2 conveyor belts in JEI to pick between. Ah well, live and learn, and then learn how to automate the metal press :)
     
    GamerwithnoGame likes this.

Share This Page