1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Fatally Missing Blocks and Items

Discussion in 'General FTB chat' started by Manou_54, Jan 25, 2015.

  1. Manou_54

    Manou_54 New Member

    Hello guys Manou_54 here

    I was having problems whit connecting to the servers . When try to log in into a server ( In every single mod pack ) it kicks me out because of Fatally Missing Blocks and Items Error . I tried to redownload
    mod packs (latest version) same , Enabled the required mods ... same , Redownloaded Java ... same , extended the ram size ... same , Reseted FTB launcher ... same

    AND I'M SICK OF IT (I wasted 7 Hours)

    So if you guys help me about this issue i will be so glad .

    Things that could be useful from you guys :

    1-Your Javas Version

    2-Some knowledge

    3-FML support

    4-And ideas that could fix this problem

    Manou_54
     
    Last edited: Jan 25, 2015
  2. b0bst3r

    b0bst3r New Member

    Fatally missing blocks is mods which are included on the server which you have not or mods which are a different version to the ones you are using.

    What you need to do is find out what DW20 version the server(s) are on and match it.
     
  3. dogan cem gurel

    dogan cem gurel New Member

    i cant stand when i see people answering who never experienced the same situation and assume they do know the issue.
    Manou_54 is probably highly and likely using FTB launcher to download the packages so telling him that mod versions conflict just a silly advice at the best.

    Manou_54 your problem is causing because of your windows language is Non utf-8 or something.

    try with an English Windows OS and you'll be able to join it. I've wasted soooo many times on this. Just don't wanna see people wasting any more time.

    Again : its just OS language problem. ( at least it was for me , i am Turkish :)) )

    I had opened a thread in here somewhere i can't really find it atm.

    edit : i've found it , it was in support.
    http://support.feed-the-beast.com/t/os-language-bug/10596

    and i also tried changing system locale to english. still no luck. ftb launcher doesnt seem to like non-english OS'es
     
    Last edited: Feb 25, 2015
  4. Manou_54

    Manou_54 New Member

    Thank you i solved my problem my turkish brother :D
    Thank you my brother ... by the way we are from the same nation you solved my problem im soo greatfull

    OUR FLAG İS MOON AND STAR ON OUR SOLDİERS BLOOD WHO DİED WHİLE SAWİNG OUR NATİON !!! şçı
     
  5. Ra'Zim

    Ra'Zim New Member

    I know this post is rather dead, but I wanted to post that I had this same experience and discovered that it could potentially be due to a config mismatch between the client and the server. It seems to be only particular mods and if you disable an integral part of a mod. In my circumstance the culprit was actually OpenBlocks, I had tried to re-enable the gravestones on the server (after disabling them prior) and suddenly none of my players could connect, none of the posts I found suggested this as the problem, instead they said to just reset the pack.

    So I figured for posterity's sake, I'd come back through to these older posts that I tried to get help from with a quick Google search and post my findings about the "Fatally missing blocks and items" error. Sorry for any inconvenience!
     
    Houstonruss likes this.
  6. napstrike

    napstrike New Member

    Hey, I am also Turkish, and I believe only Turkish people experience this problem because of the "I" "i" problem which is unique to the Turkish language.
    YOU DON'T NEED TO install an English OS. What you need is a simple launch parameter: "-Duser.language=en". This makes java to operate in English for minecraft.
    Go to advanced settings on your FTB launcher, and add that launch parameter without the quotation marks, and voila. It should solve the problem.
    If you are also hosting a server, add the same parameter into the server launch.bat file.
     
    Namelesswon, mattp_12 and Padfoote like this.
  7. rasamalai

    rasamalai New Member

    How do I do that? I already have a parameter set for java in advanced options, I included this one next after it and the game wouldn't launch. Should it have a "," between parameters?
     
  8. mattp_12

    mattp_12 New Member

    A comma is not required in between parameters, just one space.
     
  9. rasamalai

    rasamalai New Member

    Thanks! That wouldn't let my game load so I removed it and it seemed to fix itself somehow since I could play later.
     
  10. Kisbee

    Kisbee New Member

    I am not Turkish and I am having this problem! Help
     
  11. oliveanimone907

    oliveanimone907 New Member

    I just uploaded my clients config files and the error vanished
     
  12. Namelesswon

    Namelesswon Guest

    Where do i add the same parameter into the server launch.bat file? Where should i type it exactly? I have attached a file.
    please reply asap!
     

    Attached Files:

  13. MarcNemesis

    MarcNemesis New Member

    I have the same issue which i had somehow fixed but my FTB crashed 2 days ago and now i have that same shity problem once again. In my case, AE2 state I am missing 16 block & items. However, i'm the server admin and i downloaded fresh copy of the server config & mod folder to replace my client folder and still, i'm having the same error.

    Edit: I've finally managed to fix the damn problem as follow:
    - Deleted the config & mod folder
    - Downloaded the config & mod folder from the server.
    - This time arround, when Filezilla asked to overwhrite some files, i did not do so.
    - Managed to log in to the server.
     
    Last edited: Nov 16, 2018

Share This Page