Closed Crash on Startup (Solved)

Discussion in 'FTB Presents SkyFactory 3 1.10' started by Meshey, Jan 1, 2017.

  1. Meshey

    Meshey New Member

    Summary of the problem Crash on Startup

    Pack Version 3.0.0

    What is the bug? upon clicking "launch" in the FTB launcher minecraft begins to load all the mods. near the end (step 6/7) it crashes and i get a message from windows saying im using too muchr am.
    when i got to the resource monitor it uses all 8 gigs of my ram when loading up.

    Mod & Version Sky Factory 3
    V 3.0.1

    Link to log file http://paste.feed-the-beast.com/view/6b77edc4

    Is it repeatable? Yes, startup Sky factory 3

    Known Fix
     
  2. Darkosto

    Darkosto Well-Known Member

    Your computer has 8gb of RAM and you dedicated all 8gb?
     
  3. Meshey

    Meshey New Member

    at first i dedicated 4 gigs to MC but once i got the crashes i tried bringing it up to 8 gigs. all to no avail :(
     
  4. Darkosto

    Darkosto Well-Known Member

    You should never dedicate all of your RAM, that's a bad idea. 4gb is more than enough to run the pack. It's been tested by many people to use 4 and loadup just fine.
     
  5. Meshey

    Meshey New Member

    Ok so i'm not entirely sure what the problem is then. here is the crash report when i try running it on 4gb http://paste.feed-the-beast.com/view/6fa9b190. a friend of mine is also getting the same problem and crashes at the same point.
     
  6. Darkosto

    Darkosto Well-Known Member

    The crash reports say: # There is insufficient memory for the Java Runtime Environment to continue.

    Meaning you're running out of memory. If you have 8gb, don't dedicate more than 6 AT THE MOST. Also, it looks like you only dedicated 131mb total.
     
  7. dazsim

    dazsim Active Member

    Java is still trying to allocate 8gb
     
  8. Meshey

    Meshey New Member

    How do i go about dedicating more memory? the only thing i can find is the RAM Maximum (MB) setting and thats set to 4GB currently.
     
  9. totalhamman

    totalhamman Active Member

    Check if you have custom arguments set. The crash log shows these arguments being set.

    JVM Flags: 3 total; -Xms256M -Xmx8174M -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump


    Sent from my iPhone using Tapatalk
     
  10. Garpu

    Garpu New Member

    Dark, what did the people with 8GB of RAM use for a minimum amount? I'm getting a crash upon loading a world. (Linux, 64, bit, most recent version of Java 8, 4GB allocated.) Log: https://www.dropbox.com/s/0lynjeiepwhamw3/latest.log?dl=0

    Is something screwed up in my setup with RAM, or is this a new issue? (Also, I'm using MultiMC. I should be using
    12.18.3.2185, correct?)
     
  11. Darkosto

    Darkosto Well-Known Member

    I would use 4gb as a minimum. I spent hours trying to get it to use less but that's the absolute lowest I could go.
     
  12. TheDCPlaya

    TheDCPlaya New Member

    i run it on 4gb no issues, i only have 8 in my pc
     
  13. Garpu

    Garpu New Member

    Got 4GB allocated. Crashes when loading islands both using the FTB launcher and MultiMC. No difference whether I'm using MultiMC or FTB's launcher. Log in #10 is standard.
     
  14. UniZero

    UniZero Popular Member

    Try the curse launcher. Also use pastebin or ftb paste for your logs.
     
  15. Garpu

    Garpu New Member

    No curse launcher for Linux.
     
  16. 33333333mbhabe

    33333333mbhabe New Member

    For me its trying to dedicate more than i dedicate i would dedicate 3 gigs and it would use 5 which is very weird
     
  17. Garpu

    Garpu New Member

  18. Devor

    Devor New Member

    4gb was not working for me, with 8 gb of system memory. Usage went well above 4 gb during startup, particularly. I noticed a jump of about ~2 gb usage at the moment Reliquia was being loaded. Disabling Reliquia lets me start game and play normally with 4 gb maximum allocated.
     
  19. Garpu

    Garpu New Member

    Dumping Reliquia did the trick for me. Nothing else changed. After I got it to load successfully, I also upgraded to the most recent version of foamfix, which sped things up considerably.

    Looks like Reliquia eating all system RAM is a known issue, from comments on the curseforge page. Shame, because I dig bookshelves.
     
  20. Meshey

    Meshey New Member

    Disabling Reliquia has fixed my problem. to disable Reliquia go to the modpack section of the FTB launcher. then select sky factory 3 and click "edit mod pack". Scroll down to Reliquia and click disable. it should start working for you now! :)
     

Share This Page