Solved Common Server problems, and sollutions.

Discussion in 'Server Tech Support' started by Greedseed, Nov 13, 2012.

  1. Greedseed

    Greedseed New Member

    Since we see a lot of issues coming back over and over, I am going to make this topic.
    In here I will try to put in most common issues so they can be solved without you needing to wait for a reply on your topic.

    If you have any fixes post a topic and I will link it here or send me the info in a PM and I will put it in the main post. Also I will try to see what i can get out of already fixed issues.

    Check the Mojang server status before posting "I cannot connect to servers"

    List.
    1. Mystcraft Dymension 0
    2. Unable to craft some IC2 or BC items with the NEI recipies.
    3. Running a server on a local network. Behind a router.
    4. Removing mods from your server.
    5. Forestry Error after removing extra bee's

    1. Mystcraft Dymension 0
    Code:
    Time: 11/12/12 5:23 PM
    Description: Exception in server tick loop
     
    java.lang.IllegalArgumentException: Failed to register dimension for id 0, One is already registered
    at net.minecraftforge.common.DimensionManager.registerDimension(DimensionManager.java:66)
    at xcompwiz.mystcraft.MystcraftEventHandler.registerDimensions(MystcraftEventHandler.java:50)
    at xcompwiz.mystcraft.MystcraftEventHandler.handleWorldLoadEvent(MystcraftEventHandler.java:37)
    at net.minecraftforge.event.ASMEventHandler_58_MystcraftEventHandler_handleWorldLoadEvent_Load.invoke(.dynamic)
    at net.minecraftforge.event.ASMEventHandler.invoke(ASMEventHandler.java:35)
    at net.minecraftforge.event.EventBus.post(EventBus.java:103)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:278)
    at hg.c(DedicatedServer.java:153)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:454)
    at fp.run(SourceFile:818)
     
    Relevant Details:
    - Minecraft Version: 1.4.2
    - Operating System: Windows Server 2008 R2 (amd64) version 6.1
    - Java Version: 1.7.0_05, Oracle Corporation
    - Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    - Memory: 2043993464 bytes (1949 MB) / 2102788096 bytes (2005 MB) up to 3817799680 bytes (3640 MB)
    - JVM Flags: 2 total; -Xms1G -Xmx4G
    - AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    - FML: ~ERROR~ NullPointerException: null
    - Is Modded: Definitely; 'forge,fml'
    - Profiler Position: N/A (disabled)
    - Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    - Player Count: 0 / 20; []
    - World world Entities: 0 total; []
    - World world Players: 0 total; []
    - World world Chunk Stats: ServerChunkCache: 0 Drop: 0
    - Type: Dedicated Server
    Fix Thanks to Katherine1
    Code:
    Cannot Load World: Log States There Is Already a Provider for DIM 0
     
    This is a known bug related to spawned Descriptive Books. Deleting SAVE/data/agedata0.dat will fix this error.
    2. Unable to craft some IC2 or BC items with the NEI recipies.
    If you seem unable to craft some items like they are stated in NEI, and you are using GregTech. This might be due to the fact that in the first couple of days of FTB releasing there was a little hiccup.

    The Gregtech configs on the server and client did not match correctly. The client has the correct config but the server has a custom version. This will make it so recipes are different then your NEI thinks.

    Fix
    You can solve this problem by taking you client GregTech config, and putting it in place of the server GregTech config. This will make the recipes match NEI again.

    3. Running a server on a local network. Behind a router.
    If you are running a server on the same network as you play on. You need to use the local IP to connect to that server yourself.
    • If the server is running on the same computer, then use 127.0.0.1.
    • If you are playing on the same network but a different machine, use a Local IP like 192.168.1.5
      • Windows LocalIP: Start-> Run-> CMD-> ipconfig -> IPv4 address
      • Lunix LocalIP: type ifconfig in the console.
    Also if you want other to play on your server from outside your router.
    1. you will need to find your external IP. You can do that with a website like this.
    2. Once you have your external IP, you need to open your ports for Minecraft in your router. Most routers in general home setups have the address: 192.168.1.1
    3. Once in there forward the port your minecraft server is running on. Standard port is 25565.
    4. Also check if your router or computer firewall is NOT blocking the java or port.
    4. Removing mods from your server.
    So this is how you can remove mods from your server so they cant be used by anyone.
    1. Shutdown your server.
    2. Go to your "server folder" in there to the folder "Mods"
    3. Then find the mod you want to get rid of, in this case we will use "Enderstrorage"
    4. Select the "EnderStorage" .jar file and Delete it.
    5. Start your server up again.
    5. Forestry Error after removing extra bee's

    Some of you are having the error you see here
    This is due to removing extra bee's from a work that was generated with extra bee's installed.
    There are still EB items in the world and chests.
    Code:
    Description: Exception in server tick loop
     
    java.lang.NullPointerException
    at forestry.core.genetics.Chromosome.writeToNBT(Chromosome.java:50)
    at forestry.core.genetics.Genome.writeToNBT(Genome.java:57)
    at forestry.apiculture.genetics.Bee.writeToNBT(Bee.java:115)
    at forestry.apiculture.BeekeepingLogic.tickBreed(BeekeepingLogic.java:220)
    at forestry.apiculture.BeekeepingLogic.update(BeekeepingLogic.java:127)
    at forestry.apiculture.gadgets.MachineApiary.updateServerSide(MachineApiary.java:159)
    at forestry.core.gadgets.TileMachine.g(TileMachine.java:175)
    at xe.h(World.java:2020)
    at ie.h(WorldServer.java:463)
    at net.minecraft.server.MinecraftServer.r(MinecraftServer.java:649)
    at hg.r(DedicatedServer.java:241)
    at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:585)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:492)
    at fp.run(SourceFile:818)
    Fix
    Code:
    go into the Forestry config file, base.conf. Near the middle, there should be a setting called "genetics.invalid.chromosome.clearing." Set that option to "true" and try again after you restart your game.
    Thanks to redit
     
    QueWhat, Crezetique, Vauthil and 2 others like this.
  2. Ashzification

    Ashzification New Member

    Greedseed, do you have anything for server troubleshooting that I can add to the CP&S in my signature?
     
  3. Greedseed

    Greedseed New Member

    you can :) no problem.
     
  4. kooljac702

    kooljac702 New Member

    fihgu's mod can be usas a temporary alternative to protections and perms
     
  5. Stellastronza

    Stellastronza New Member

    3.

    Twilight portals and centrifuge extractors stacked in the same chunk are known to cause relevant lag. If possible, try to diversify their location.
     
  6. Greedseed

    Greedseed New Member

  7. kooljac702

    kooljac702 New Member

  8. Greedseed

    Greedseed New Member

    Added a small and Router and local IP guide.
     
  9. Angl476

    Angl476 New Member

    What should I do if I load up FTB and the console says

    "15:18:44 [INFO] net.ftb.gui.LauncherConsole$OutputOverride.write:65 From Console: Loading jars...
    15:18:44 [INFO] net.ftb.gui.LauncherConsole$OutputOverride.write:65 From Console: Loading URL: file:/C:/Users/Saber/Downloads/FTBBETAA/instMods/MinecraftForge.zip
    15:18:44 [INFO] net.ftb.gui.LauncherConsole$OutputOverride.write:65 From Console: Loading URL: file:/C:/Users/Saber/Downloads/FTBBETAA/minecraft/bin/minecraft.jar
    15:18:44 [INFO] net.ftb.gui.LauncherConsole$OutputOverride.write:65 From Console: Loading URL: file:/C:/Users/Saber/Downloads/FTBBETAA/minecraft/bin/lwjgl.jar
    15:18:44 [INFO] net.ftb.gui.LauncherConsole$OutputOverride.write:65 From Console: Loading URL: file:/C:/Users/Saber/Downloads/FTBBETAA/minecraft/bin/lwjgl_util.jar
    15:18:44 [INFO] net.ftb.gui.LauncherConsole$OutputOverride.write:65 From Console: Loading URL: file:/C:/Users/Saber/Downloads/FTBBETAA/minecraft/bin/jinput.jar
    15:18:44 [INFO] net.ftb.gui.LauncherConsole$OutputOverride.write:65 From Console: Loading natives..."

    What should I do, or what did I do wrong?
     
  10. Ashzification

    Ashzification New Member

    That looks okay to me. Someone else may know more than me though.
     
  11. Greedseed

    Greedseed New Member

    its just loading the jar file's. Nothing wrong with that.
     
  12. GangsterHippie

    GangsterHippie New Member

    Well, i have the server open in a java window. Here's what it says, as it says i cannot reach server. I'm guessing that the server is UP but theres a problem.
    Here's what my server console says.

    [INFO] Starting minecraft server version 1.4.2
    [WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    [INFO] Loading properties
    [WARNING] server.properties does not exist
    [INFO] Generating new properties file
    [INFO] Default game type: SURVIVAL
    [INFO] Generating keypair
    [INFO] Starting Minecraft server on *:25565
    [WARNING] Failed to load operators list: java.io.FileNotFoundException: .\ops.txt (The system cannot find the file specified)
    [WARNING] Failed to load white-list: java.io.FileNotFoundException: .\white-list.txt (The system cannot find the file specified)
    [INFO] Preparing level "world"
    [INFO] Preparing start region for level 0
    [INFO] Preparing spawn area: 13%
    [INFO] Preparing spawn area: 25%
    [INFO] Preparing spawn area: 37%
    [INFO] Preparing spawn area: 48%
    [INFO] Preparing spawn area: 60%
    [INFO] Preparing spawn area: 69%
    [INFO] Preparing spawn area: 78%
    [INFO] Preparing spawn area: 86%
    [INFO] Preparing spawn area: 95%
    [INFO] Done (12.161s)! For help, type "help" or "?"

    Oh and i put my IP as something other than that number in the parenthesis. Is that my problem?
     
  13. krizmac

    krizmac New Member

    Try making two files, one named ops.txt, and one named white-list.txt, and throw them both in the same folder as your server.

    These *should* be created when you run the server for the first time, looks like they weren't.

    When you say "that number in the parenthesis" to what do you refer?
     
  14. GangsterHippie

    GangsterHippie New Member

    Im talking about 12.161s. and what program should i use to make ops.txt and white-list.txt? Forgive me, but i have very limited knowledge of this kind of stuff.
     
  15. Greedseed

    Greedseed New Member

    the 12.161 sec is the time the server needed to fully launch.
     
  16. Ashzification

    Ashzification New Member

    When you run a server, these files should be generated. This is not the place to ask about this however, please post a support thread.
     
  17. krizmac

    krizmac New Member

    Well if you changed your server IP to 12.161, that is your problem.
     
  18. GangsterHippie

    GangsterHippie New Member

    I got it working. Nevermind, guys.
     
  19. GangsterHippie

    GangsterHippie New Member

    ok, going to wait till FTB feels more nice, i dont like the controls, and i dont like how theres so much stuff you feel overwhelmed. How do i stop running my FTB server so i can run a vanilla MC server?
     
  20. krizmac

    krizmac New Member

    Can I ask a question here, what about the controls do you not like?

    We all started out feeling overwhelmed, just learn it a little bit at a time ;)

    If you really don't want it around anymore, just kill all the java*.* processes in your task manager and it will go away.
     

Share This Page