Open Cant connect.

Discussion in 'FTB Revelation' started by Lunarrr, Jul 18, 2019.

  1. Lunarrr

    Lunarrr Guest

    Upon attempting to join the server i get a message with tons of mods where it says i have newer versions of it and that the server requires older versions of the mods
     

Share This Page