1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

BiomesOPlenty Biome Generation

Discussion in 'General FTB chat' started by SatanicSanta, Jul 22, 2013.

  1. SatanicSanta

    SatanicSanta Wiki Steam Witch Wiki Staff FTB Mod Dev ModMyMC Editor

    I have been playing the 1.5.2 W/NGT, and FTB Unleashed quite a bit lately. On all of my worlds I tend to explore a bit too much. Yet, for some worlds I would go 2-8000m and not see a single BoP biome. Does anyone else experience this? I know for a fact that BoP was enabled before world generation, and even if it weren't, the chunks generated after BoP was enabled would have BoP biomes.

    Also, what on earth is this about?
    I dug one of these water things and the water just disappeared. I have these things all over the swamp I live near, the extreme hills I live near, and the plain I live in currently.
    [​IMG]
    [​IMG]
     
  2. Redweevil

    Redweevil Well-Known Member

    I think the config is set to only use normal world generation. It took a bit of fiddling to sort out but I believe if you set normal world generation to false it should work. Hope that helps!
     
  3. SatanicSanta

    SatanicSanta Wiki Steam Witch Wiki Staff FTB Mod Dev ModMyMC Editor

    In the config file there is a section for what biomes to generate. Every single one is set to true.
     
  4. Greylocke

    Greylocke Active Member

    in the server.properties file, do you have level-type=BIOMESOP ? This setting tells the server to use the Biomes O Plenty world gen.
     
  5. Incendium

    Incendium Member

    By default, BoP will not generate any terrain on an existing world. You will either need to start a new world and specifically choose the BiomesOPlenty world generator in the initial config, or edit the BiomesOPlenty config file to force the world generator on for all worlds.

    There may also be a way to change the world generator in an existing world, but I'm not sure how to do that.

    Edit: The specific config file you want to edit, should you want to go that route, is config/BiomesOPlenty.cfg. You'll want to change B:"Add Biomes To Default World"=false to B:"Add Biomes To Default World"=true. Keep in mind that this will reset every time the FTB pack updates, and you'll need to change it each time to keep getting the new generation.
     
    Redweevil likes this.
  6. Redweevil

    Redweevil Well-Known Member


    Exactly this
     
  7. KurShedir

    KurShedir Active Member


    Puddles, maybe

    B:"Enable Puddles During Rain"=true
     
  8. Dackstrus

    Dackstrus Active Member

    Yeah those are puddles, i was confused as hell at first myself, but it's actually kinda neat.
     
    SatanicSanta likes this.
  9. Golrith

    Golrith Over-Achiever Trusted User

    Seriously, I know that Slow doesn't like Biome mods, but it would have made more sense to have BoP enabled by default.
     
  10. Bigglesworth

    Bigglesworth Popular Member

    BoP Should be enabled by default as it allows for BiomesXL and vanilla biomes to generate in the world with it. Its quite the Good Guy Biomes.

    The FTB Lancher should consider going the extra mile and including a tab and UI to edit their config files. Biomes are one of the most important things starting a new world.
     
    SatanicSanta likes this.
  11. SatanicSanta

    SatanicSanta Wiki Steam Witch Wiki Staff FTB Mod Dev ModMyMC Editor

    Not using a server.
     
  12. Golrith

    Golrith Over-Achiever Trusted User

    When you create a new world, go into the additional settings, and on the world type (where you can choose flat world), click again, and you should get Biomes O Plenty as a world option.
     
  13. SatanicSanta

    SatanicSanta Wiki Steam Witch Wiki Staff FTB Mod Dev ModMyMC Editor

    Thanks, although that is a really stupid feature. I feel like if I've installed BoP, I would want BoP biomes in my world... Yikes.
     
  14. The Mobius Archives

    The Mobius Archives Well-Known Member

    I'm finding all sorts of good information today. I'm guessing to get BiomesXL as well I'll need to download and add it myself. Hopefully that mod will play nice with my currently generated world.
     
  15. INCSlayer

    INCSlayer Well-Known Member

    i think the terrain generation is handled differently if you do set it like that when making the world instead of just setting BoP to default in the config
     
  16. CenturionArcher

    CenturionArcher Active Member

    In the config file under the biomes section you need to set the "Add Biomes to Default World" to true in order to spawn BOP biomes in a default world.
     
  17. robbversion1

    robbversion1 Active Member

    Still having BOP issues on my SMP server. So I went ahead and in the server config change level type to BIOMESOP and also in the BOP config changed the add biomes to default world to true, but still only vanilla biomes. Was there something i overlooked?
     
  18. INCSlayer

    INCSlayer Well-Known Member

    did you make a new world after you changed the config?
     
  19. robbversion1

    robbversion1 Active Member


    yup. made a few new ones. only seeing the normal jungle, plains, forest, taiga
     
  20. Golrith

    Golrith Over-Achiever Trusted User

    Here's my server.properties file, if that helps:

    generator-settings=
    allow-nether=true
    level-name=Stu's World
    enable-query=false
    allow-flight=false
    server-port=xxxxxxxxxxxxxxxxxxxxxxxxx
    level-type=BIOMESOP
    enable-rcon=false
    force-gamemode=false
    level-seed=
    server-ip=
    max-build-height=256
    spawn-npcs=true
    white-list=false
    spawn-animals=true
    texture-pack=
    snooper-enabled=true
    hardcore=false
    online-mode=true
    pvp=false
    difficulty=2
    gamemode=0
    max-players=10
    spawn-monsters=true
    view-distance=10
    generate-structures=true
    spawn-protection=16
    motd=Stu's Minecraft Server
     

Share This Page