1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Biomes O Plenty too much water not enough land?

Discussion in 'General FTB chat' started by Bigpak, Jan 12, 2014.

  1. Bigpak

    Bigpak New Member

    When I generate a world with all the biomes disabled except for the vanilla ones its filled with water and the biomes are set to vanilla ones in F3 in the water, there is land occasionally but it is tiny, there is so much water. Is there something I'm doing wrong here? Right now I want just vanilla biomes to generate in the overworld yet it is almost all water

    Has anyone else experienced this? Is there a way to fix it?
     
  2. EnzymeA113

    EnzymeA113 New Member

    In my experience, Biomes O Plenty is awful at generating when lots of biomes are disabled (try enabling only one biome, for example, and it will spam Thaumcraft biomes, water, and you'll get horrendous chunk errors once you re-enable them).

    Probably the best way to go is to edit the biome IDs of an existing BOP world in MCEDIT (not sure how the Biome filter handles mod biomes, but worth a try).
     
    RedBoss likes this.
  3. Bigpak

    Bigpak New Member

    Is there any downside to enabling all of the biomes? I haven't ever used it before I just wanted the stuff in the nether :p
     
  4. Skyqula

    Skyqula New Member

    Biomes o Plenty has a config setting for this, its in the terraingen.cfg. Looks for this:
    Code:
      # In Vanilla it is set to 10. Takes values from 0 to 100.
      I:"Landmass Percentage"=50
    I bumped it up to 50, default is much lower.
     
  5. Bigpak

    Bigpak New Member

    I've been messing with that, I've even set it to 100 and it still spams water so much. The "biomes" are islands basically. It's really irritating me.

    EDIT: Oh well, I give up with disabling the biomes and editing the configs. I gave up as soon as I found multiple villages that are floating in the water. Apparently Biomes o Plenty cannot generate with only vanilla biomes as it fails to do so repeatedly over a attempt of atleast 60 worlds
     
    Last edited: Jan 12, 2014
  6. Skyqula

    Skyqula New Member

    Are you using the default world generator? Enable ==> B:"Add Biomes To Default World"=true with just the nether biomes. My gues is that will work.
     
  7. Bigpak

    Bigpak New Member

    you... you may be on to something let me try this out. I'll reply if it works

    P.S. If it works I will love you forever. I've been struggling with this for hours

    You are the most amazing person. I love you for this! It worked! Will this work for other biomes in the overworld too using the default generator? I hate the BOP generator as it spams water and only creates islands. I am so happy!!!

    How can I repay you? I am in your debt.
     
    Last edited: Jan 12, 2014
    Skyqula likes this.
  8. RedBoss

    RedBoss New Member

    If only there was a config to disable those damned spiders. They ruin the good biomes too. I've been messing with the configs myself because I'm tired of all the dead/wasteland biomes. I generated several worlds in testing with many biomes disabled. The majority of them were islands.
     
    SatanicSanta likes this.
  9. Bigpak

    Bigpak New Member

    Do what that one guy said, it fixed the issue for me, NEVER EVER set the world generation type to BIOMESOP in server.properties as it uses the BOP generator instead of the vanilla generator which is why it spams the islands, I enabled all the biomes but changed in the config to have it add to the vanilla biomes with the vanilla generator instead of the BOP generator in server.properties and everything works fine and is now normal and not islands etc.

    Everything is working fine now! if anyone else has anyone questions I am glad to have them post them here :D
     
  10. hiroshi42

    hiroshi42 New Member

    Just as an aside, I don't think it is generating islands as much as it treats all terrain below y64 as 'ocean' or otherwise underwater so you get deserts (my pet problem) as mostly submerged/entirely submerged.

    also : WOO! I was going to start a new world last night but due to a wonderful MPS crash issue abandoned my efforts. Just to be clear I can use the configs to add BoP biomes to the normal world generation yes?
     
  11. Bigpak

    Bigpak New Member

    From my understanding yes, it seemed to work fairly well when I did it :)
     
  12. JST

    JST New Member

    I noticed that disabling the Ars Magica mod seems to allow Biomes O Plenty to be more epic. I found multiple areas with BOP biomes that are super rare really close to spawn![DOUBLEPOST=1397336463][/DOUBLEPOST]
    Disable Ars Magica and/or Ars Magica 2! The stupid witchwood forrest seems to mess up the biome generation of BOP.
     
  13. trajing

    trajing New Member

    Because, you know, it's necessary to tell this to someone who has had their issue fixed multiple months ago.
     
    PierceSG, JST, RedBoss and 1 other person like this.
  14. JST

    JST New Member

    lol yeah i know, i just thought i would put the idea out there in case anyone else was getting annoyed about not finding certain BOP biomes.
     
  15. dyerseve

    dyerseve New Member

    I have this problem as well, I want to use the higher village spawn so changing to default world type causes villages to be too distant, but using biomesop world type causes all vanilla biomes to be below y=64 so even though I have more villages probably half of them are submerged...

    Anyone find a way to adjust the sea level instead?
     
  16. trajing

    trajing New Member

    Wow.
    Double-necro'd.
     
  17. Azzanine

    Azzanine New Member

    Ehh, remember undead thralls have their uses.
     
  18. Succubism

    Succubism New Member

    Thrillerrrrrrr
     
    Not_Steve and Padfoote like this.
  19. Siigari

    Siigari Well-Known Member

    I'm actually interested in this, and it's still relevant information so the necro is appreciated.

    Does enabling add to default world allow the very crazy BoP mountains like in Crag and Alps?
     

Share This Page