Batch File Error

Discussion in 'Tech Support' started by JoeShmugg, Nov 28, 2017.

  1. JoeShmugg

    JoeShmugg Guest

    Title Batch File Error

    Launcher Type Server

    Modpack SkyFactory 3

    Modpack version 3.0.15

    Have you modified the pack? Yes

    Link to log file http://paste.feed-the-beast.com/view/c67700bc

    Details of the issue When I click on the ServerStart.bat file it comes with this error...

    Starting server
    Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option PermSize; support was removed in 8.0
    Java HotSpot(TM) 64-Bit Server VM warning: Option UseParNewGC was deprecated in version 9.0 and will likely be removed in a future release.
    Unrecognized VM option 'CMSIncrementalPacing'
    Error: Could not create the Java Virtual Machine.
    Error: A fatal exception has occurred. Program will exit.
    Exiting...
    Press any key to continue . . .

    Please Help Me!
     
    Last edited by a moderator: Nov 28, 2017
  2. grandrolf

    grandrolf Popular Member Trusted User

    Did you edit that file?

    If yes - then remove it and replace it with the one in the zip-file.

    There's a file called settings.bat - right click on that and select "EDIT"

    Change this line:
    set MAX_RAM=3072M

    To:
    set MAX_RAM=4096M

    If you want to allocate more - amounts gb x 1024 (1024,2048,3072,4096,5120,6144 and so on)

    Things to think about:

    Is this a shared machine that's running both client and server - then you need to balance allocated ram between the 2 and how much total is on that machine.

    Don't allocate everything you have, leave some for the OS and other applications as well (this is valid regardless of shared or dedicated).

    If you need suggestions on how much to allocate, please tell more about your machine / machines.
     
    JoeShmugg likes this.
  3. JoeShmugg

    JoeShmugg Guest

    It still says the same error message
    and i checked and imon the latest java
    but my java-test.log file says this...

    java version "9.0.1"
    Java(TM) SE Runtime Environment (build 9.0.1+11)
    Java HotSpot(TM) 64-Bit Server VM (build 9.0.1+11, mixed mode)

    any thoughts?
     
  4. grandrolf

    grandrolf Popular Member Trusted User

    Yes, remove java 9 and install latest version 8
     
    JoeShmugg likes this.
  5. JoeShmugg

    JoeShmugg Guest

    Thank you that helped but now im getting this message...

    No java binary in path. Can't run server, exiting...
    Press any key to continue . . .

    Any clue what this means?
     
  6. grandrolf

    grandrolf Popular Member Trusted User

    Did you install latest 64-bit java 8 version?

    Always share full logs (even if they're small), using paste.feed-the-beast.com - and don't share just a chunk of a log, take the full one.
     
  7. JoeShmugg

    JoeShmugg Guest



    http://paste.feed-the-beast.com/view/f25376ae

    This is the entire log
     
  8. grandrolf

    grandrolf Popular Member Trusted User

    And what about java?
     
    JoeShmugg likes this.
  9. JoeShmugg

    JoeShmugg Guest

    The java-test.log changed to this...

    Error: could not find java.dll
    Error: Could not find Java SE Runtime Environment.

    I have the latest version of java and jre
     
  10. JoeShmugg

    JoeShmugg Guest

    I have also tried recrating a different server but the samething keeps happening
     
  11. JoeShmugg

    JoeShmugg Guest

    What should I put in the java-test.log file
     
  12. grandrolf

    grandrolf Popular Member Trusted User

    What?

    Please answer what java version you installed.

    Also share (if it's there) /logs/fml-server-latest.log - using paste.feed-the-beast.com
     
  13. JoeShmugg

    JoeShmugg Guest

  14. Padfoote

    Padfoote Brick Thrower Team Member Forum Moderator

    Java isn’t detected in your Windows PATH variable.

    Restart the command window you’re trying to run the bat file from then try again. If it still doesn’t work check to see if you have java set in your PATH: https://stackoverflow.com/questions/1672281/environment-variables-for-java-installation

    You can ignore everything that is not about the PATH variable. When setting it, make sure you use the JRE, not JDK. The link I’m giving is for development which is why you’re ignoring so much of it, but it’ll still work. Also make sure you do not delete or change anything in your PATH unless it’s the old Java 9.
     
    grandrolf and JoeShmugg like this.
  15. x_Kirito

    x_Kirito Guest

    Are you still having this problem? If yes I know an easy way to fix this:
    Go to control panel, after that, click on Uninstall a program.
    Then search for Java. If you find Java 10 inside there, well uninstall that, and install Java 8.
    This actually fixed the problem for me.
    Sorry for the late reply, but this is for the guys,who were looking for a solution for this problem.
     

Share This Page