Another "help needed with FPS" post

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

AlCapella

New Member
Jul 29, 2019
709
0
0
Operating System: Windows 8.1 Pro 64-bit
CPU: AMD FX-8320 Vishera
RAM: Corsair Vengeance 16.0GB Dual-Channel DDR3
Motherboard ASUSTeK M5A99FX PRO R2.0
Monitor: DELL S2240L ([email protected])
Graphics Card: 2048MB ATI AMD Radeon R9 200 Series (XFX Pine Group)
Disks:
119GB ADATA SP900 (SSD)
1863GB Western Digital (SATA)
Optical Drives: HL-DT-ST DVDRAM GH24NSB0
Audio: Realtek High Definition Audio
Java
Java Runtime Environment
Path C:\Program Files (x86)\Java\jre7\bin\java.exe
Path C:\Program Files\Java\jre7\bin\java.exe
Version 7.0
Update 65
Build 19

I retained my FTB setup from my older machine: So, I still have FpsPlus+ added to the 1.6.4 jar.
No optifine
I always play with the faithful32 pack - even with my previous low-end rig.
Lately I tried to use Soartex and Sphax for variety, but I get so confused at all the textures that I revert to faithful 10 minutes later. :oops:

tl;dr: - FpsPlus+, no optifine, faithful32 resource pack

The only JVM arguments I use are these:
Code:
-Xmx3G -Xms2048m -XX:PermSize=256M -Dfml.ignoreInvalidMinecraftCertificates=true
  -Dfml.ignorePatchDiscrepancies=true

Last two are mandatory, and needed by FpsPlus+. So, they stay.

And despite these specs, I never go beyond 30 fps on any mod pack that I play with. I am fluctuating between 13 and 24 fps 90% of the time. So, I mostly read all those fps fix and fps boost threads with unconcealed amusement. And I am scratching my head wondering what the hell is wrong at my end! Gameplay is fluid for me, so mostly I notice the fps only after reading one of those threads. For fun, I copied down some of the JVM args that were floating around last week and before that and used them all. Those list of args:
Old FTB args from eyamaz
Code:
-Xmx3G -Xms2048m -XX:PermSize=256M -XX:MaxPermSize=512m -Xincgc -XX:ParallelGCThreads=2  -Dfml.ignoreInvalidMinecraftCertificates=true -Dfml.ignorePatchDiscrepancies=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CICompilerCountPerCPU -XX:+TieredCompilation -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+BindGCTaskThreadsToCPUs -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=80 -XX:+CMSClassUnloadingEnabled

Some spigot server argument that seemingly helped someone

-Dfml.ignoreInvalidMinecraftCertificates=true -Dfml.ignorePatchDiscrepancies=true  -XX:ReservedCodeCacheSize=256M -DJINTEGRA_NATIVE_MODE -DJINTEGRA_COINIT_VALUE=0 -Dsun.io.useCanonCaches=false -XX:ThreadPriorityPolicy=42 -XX:CompileThreshold=1500 -XX:+TieredCompilation -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=15 -XX:+UseBiasedLocking -Xverify:none -XX:UseSSE=3 -XX:+OptimizeStringConcat -XX:+UseFastAccessorMethods -Xrs -XX:+UseCompressedOops -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts

For all Java

-XX:-DisableExplicitGC -XX:-RelaxAccessControlCheck -XX:MaxPermSize=128M -XX:MinHeapFreeRatio=30 -XX:+UseFastAccessorMethods -Xmn=2000M -Xmx=2000M

For big packs
-Dfml.ignoreInvalidMinecraftCertificates=true -Dfml.ignorePatchDiscrepancies=true  -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:MaxGCPauseMillis=10 -XX:GCPauseIntervalMillis=50 -XX:MaxGCMinorPauseMillis=7 -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc

For test packs:
-Dfml.ignoreInvalidMinecraftCertificates=true -Dfml.ignorePatchDiscrepancies=true   -Xms512M -Xmx2048M -XX:PermSize=256m -XX:+UseLargePages -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -XX:+OptimizeStringConcat -XX:+UseBiasedLocking -Xincgc -XX:MaxGCPauseMillis=10 -XX:SoftRefLRUPolicyMSPerMB=10000 -XX:+CMSParallelRemarkEnabled -XX:ParallelGCThreads=10 -Djava.net.preferIPv4Stack=true

(Predictably) Zilch happens to my performance in terms of my FPS. On MultiMC, minecraft actually crashes while using one of those arguments *wry smile*

I logged into an FTB Monster world, pranced around a bit, and logged off. Here's the console log:

But on a more serious note, I am curious and surprised at most of the threads that boost off to 120fps or so after copying some random JVM args... Meanwhile in Alca land, ^^ well you can see for yourself.

So, anyone else using this class of AMD or Radeon? Does anyone have any idea how to make Minecraft optimally use my rig? Other suggestions for me to get to the mythical 60-160fps range? :)

Thanks in advance.
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
I was using a worse rig than yours up until recently and getting a minimum of 45FPS so something is wrong.

Try these JVM arguments:
Code:
-Xms1G -Xmx3G  -XX:PermSize=256M
-XX:-DisableExplicitGC
Get rid of FPS++, you shouldn't need it. and its probably not helping. Setting the Xms lower helps the JVM know how much memory it can use.

Make sure 32 bit Java is not even installed.

Make sure your computer is not in power saving or balanced mode. Even on desktops this mode can be switched and is a common reason for performance issues.

Use a program like Speccy to check temperatures of your processor and video card to make sure they aren't getting too hot and throttling back.
 
  • Like
Reactions: AlCapella

AlCapella

New Member
Jul 29, 2019
709
0
0
I was using a worse rig than yours up until recently and getting a minimum of 45FPS so something is wrong.

Try these JVM arguments:
Code:
-Xms1G -Xmx3G  -XX:PermSize=256M
-XX:-DisableExplicitGC
Get rid of FPS++, you shouldn't need it. and its probably not helping. Setting the Xms lower helps the JVM know how much memory it can use.

Make sure 32 bit Java is not even installed.

Make sure your computer is not in power saving or balanced mode. Even on desktops this mode can be switched and is a common reason for performance issues.

Use a program like Speccy to check temperatures of your processor and video card to make sure they aren't getting too hot and throttling back.
Thanks for replying!

1. Got rid of FPS++ as you suggested.

2. Don't I need 32 bit Java for the browser? :(
Besides FTB picks up the 64 bit one anyway:
Code:
The FTB Launcher has found the following Java versions installed:
Java Version: 1.7.0_65 sorted as: 1.7.0_65 32 Bit Java at : C:\Program Files (x86)\Java\jre7\bin\java.exe
Java Version: 1.7.0_65 sorted as: 1.7.0_65 64 Bit Java at : C:\Program Files\Java\jre7\bin\java.exe
Java Version: 1.7.0_65 sorted as: 1.7.0_65 64 Bit Java at : C:\Windows\system32\java.exe
Java Version: 1.7.0_65 sorted as: 1.7.0_65 32 Bit Java at : C:\Windows\SysWOW64\java.exe
Java Version: 1.7.0_65 sorted as: 1.7.0_65 64 Bit Java at : C:\Program Files\Java\jre7\bin\java.exe
Preferred: Java Version: 1.7.0_65 sorted as: 1.7.0_65 64 Bit Java at : C:\Program Files\Java\jre7\bin\java.exe
2b. Just remembered that I still had "for all java" JVM arguments still copied in my Java panel. Removed. Restarted. Clean slate!

3. Er, slightly embarrassed! It was set on balanced mode actually. Changed to High Performance mode :oops:

4. I did use Speccy for my specs: Here a screenie of my temperature:
The graphics card hovers close to 50 degs C, but all others stay where they are.

So with these tweaks, I am happy to report that:
1. With the DW20 pack, I am now close to 50 fps, so something is working...
2. But for monster, now it hovers close to 30 fps, which is also better than before when it fluctuated b/w 13-25 fps all the time.

All in all this is a good start. Not in the 60+ and 120+, but it is a good start!

thanks, @DZCreeper :)
 
Last edited:

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
Alright, next check both the CPU and Graphics tab. Under CPU, make sure the core speed as at full speed. For some reason your summary screenshot doesn't show that. Under Graphics, find the Current Performance Level. It should also list the speed for each performance level. On a R9 2xx card, the maximum performance mode should be called Level 0.

Try enabling full screen mode as well, it increases my FPS a tiny bit because it disables rendering of anything underneath like your desktop.

Make sure v-sync is disabled both ingame and by default in AMD Catalyst Control Center. If you have less FPS than your monitor refresh rate, it actually drops FPS more trying to match it to a fraction of your monitors rate.
 
  • Like
Reactions: AlCapella

steve g

New Member
Jul 29, 2019
445
0
0
sometimes this works...try giving java higher cpu priority. open task manager, locate the java process (the one eating all your cpu and ram) right click, set priority, high. do *not* do realtime unless you want to burn your house, hamsters, billy goats and that epic elvis presley LP collection down into subatomic particles.

i know you dont want optifine, but with monster...not really much of a choice. just do it ;)

other than that, ive said this before, but here goes:

do you *really* need all 1437328978543 mods running? if not, try disabling a few.
do you *really* need to see those trees 5 chunks away? if not, try shortening the render distance some. or a lot. go tiny.
turn sounds off. and music. play your own soundtrack in your head ;)
lots of entities = lots of lag. both network and render. stay away from mob spawners. massive redstone contraptions...no. just no.

theres more, but this has been posted many many times in the past. read a few pages back ;)
 

AlCapella

New Member
Jul 29, 2019
709
0
0
Alright, next check both the CPU and Graphics tab. Under CPU, make sure the core speed as at full speed. For some reason your summary screenshot doesn't show that. Under Graphics, find the Current Performance Level. It should also list the speed for each performance level. On a R9 2xx card, the maximum performance mode should be called Level 0.

Try enabling full screen mode as well, it increases my FPS a tiny bit because it disables rendering of anything underneath like your desktop.

Make sure v-sync is disabled both ingame and by default in AMD Catalyst Control Center. If you have less FPS than your monitor refresh rate, it actually drops FPS more trying to match it to a fraction of your monitors rate.
Here's the details page of my CPU from Speccy:

And the graphics card page:
I see the current performance level indicating "Level 0", so all seems well on that front!

The VSync bit was tricky for it took some hunting in the application to find.... It was turned ON and so was triple buffering. :oops:
So I disabled those and also took the liberty of fiddling with a few other settings as you can see. Those options with "numbers" next to them in image have had their defaults changed.... and then changed back to defaults again, because the textures started developing glass pane like look around them, and started looking freaky.

Vsync has been disabled in game from the beginning. I also set the fullscreen option.
Code:
music:0.3309859
sound:0.6126761
invertYMouse:false
mouseSensitivity:0.5
fov:0.0
gamma:0.85211265
viewDistance:0
guiScale:2
particles:0
bobView:true
anaglyph3d:false
advancedOpengl:false
fpsLimit:0
difficulty:0
fancyGraphics:true
ao:2
clouds:true
skin:FTB-Vattic-32x[latest].zip
lastServer:
lang:en_GB
chatVisibility:0
chatColors:true
chatLinks:true
chatLinksPrompt:true
chatOpacity:1.0
serverTextures:true
snooperEnabled:true
fullscreen:true
enableVsync:false
hideServerAddress:false
advancedItemTooltips:false
pauseOnLostFocus:true
showCape:true
touchscreen:false
overrideWidth:0
overrideHeight:0
heldItemTooltips:true

With all this, I am finally happy to report that for the first time, my game (any modpack) was finally showing fluctuating readings between 45-140 fps! *small hurray!* I had never seen anything at this range so far, so I am mighty pleased to begin with!! :)

Now even if things stayed like this, I could have simply lived with the wild fluctuating fps and would have simply edited the title to [SOLVED]. But now I have noticed another new, persistent glitch as well

Basically, if I keep the advanced OpenGL mode to ON, then I see glitches on the screen for a few modpacks. In Monster, if I turned OpenGL OFF, the glitch went away. But in the TPPI pack, for example, this switch did not make any difference whatsoever. Even tried changing my texture pack to eliminate that possibility, but it didn't matter what RP/TP I used. Screenies follow! There's a box drawn at the place where the glitch is evident. Look for the box.




Thanks for helping out so far.
 

AlCapella

New Member
Jul 29, 2019
709
0
0
I definitely appreciate your suggestions. In the past, for my older machine I had resorted to most of your suggestions on my own, to squeeze out as much performance as I can. But, I cannot disable mods anymore as all the packs I play, I actually play on servers now. Also, with the new rig, I shouldn't need to resort to this kind of optimisation strategy anymore. ;)

Seems like some of the suggestions posted above you worked! A next iteration awaits us. :p
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
Yeah, OpenGL doesn't provide much of a performance boost without a very fast Intel processor and on AMD graphics cards it causes glitches, hence why it was removed from vanilla recently.

Edit: Advanced OpenGL, not OpenGL. My derp.
 
Last edited:

AlCapella

New Member
Jul 29, 2019
709
0
0
Yeah, OpenGL doesn't provide much of a performance boost without a very fast Intel processor and on AMD graphics cards it causes glitches, hence why it was removed from vanilla recently.
It's bizarre. OpenGL is supposed to be the standard, and now we're at this state of affairs?^^ What? OpenGL support was removed from Vanilla MC? :eek:

Having said that, my ongoing concern now is that on some packs, turning it OFF doesn't seem to work either! I still glitch big time... Very annoying and distracting. Do you know if it is possible to do something about this screen glitching at all?

Also, there's far too much fps fluctuation as I see it now. Any suggestions/tricks for stabilising it? Even if it is 70 fps, then it would be really nice if it stayed at 70 +/- 5 all the time, instead of the 45-140 wild and constant fluctuation! Any further thoughts?

P.S: What's your setup now? Intel i5 +NVIDIA something?
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
It's bizarre. OpenGL is supposed to be the standard, and now we're at this state of affairs?^^ What? OpenGL support was removed from Vanilla MC? :eek:

Having said that, my ongoing concern now is that on some packs, turning it OFF doesn't seem to work either! I still glitch big time... Very annoying and distracting. Do you know if it is possible to do something about this screen glitching at all?

Also, there's far too much fps fluctuation as I see it now. Any suggestions/tricks for stabilising it? Even if it is 70 fps, then it would be really nice if it stayed at 70 +/- 5 all the time, instead of the 45-140 wild and constant fluctuation! Any further thoughts?

P.S: What's your setup now? Intel i5 +NVIDIA something?
Oops, I mean Advanced OpenGL. Not OpenGL itself. If it didn't use OpenGL it wouldn't run on Linux :p

As for the visual glitches, try a clean instance. There may be remnants of FPS++. You could try enabling v-sync in the video options but if you can't hold 60FPS constantly it hurts performance because it then drops to 30FPS, 15, and so on.

The FPS fluctuation is normal and sadly there is not much of a way to fix it asides from selecting a good base location like plains or void age to minimize rendering. You could try overclocking your processor if you have an aftermarket cooler. I use a cheap Hyper 212 Evo and can push my Pentium G3258 from 3.2Ghz to 4.4Ghz. Bumped my FPS about 20%.

I already mentioned my processor but my video card is a R9 270X at stock speeds. 12 gigs of memory, and a 180GB SSD for storing my games.
 
  • Like
Reactions: AlCapella

AlCapella

New Member
Jul 29, 2019
709
0
0
Oops, I mean Advanced OpenGL. Not OpenGL itself. If it didn't use OpenGL it wouldn't run on Linux :p

As for the visual glitches, try a clean instance. There may be remnants of FPS++. You could try enabling v-sync in the video options but if you can't hold 60FPS constantly it hurts performance because it then drops to 30FPS, 15, and so on.
Tried it already. Didn't help out. :(

The FPS fluctuation is normal and sadly there is not much of a way to fix it asides from selecting a good base location like plains or void age to minimize rendering. You could try overclocking your processor if you have an aftermarket cooler. I use a cheap Hyper 212 Evo and can push my Pentium G3258 from 3.2Ghz to 4.4Ghz. Bumped my FPS about 20%.
So, I'll live with it I suppose. No more investment on the rig for another year at least :)

I already mentioned my processor but my video card is a R9 270X at stock speeds. 12 gigs of memory, and a 180GB SSD for storing my games.
Oh! Uncanny! So, do you also get those kind of glitches then?

P.S: Thanks again!
 

AlCapella

New Member
Jul 29, 2019
709
0
0
So, I did not want to close this thread until I got some kind of consistent performance, and also I hoped if I would lose those screen glitches.
But, due to RL, I was only able to do some testing recently.
Unfortunately, I am still getting glitches, and while I have also posted to the AMD forums, there's been zero helpful responses from there.


^^ I am standing at the same location and taking both screenshots. This is how the screen glitches every 2 seconds... I have to restart my game before things calm down. Vanilla MC behaves oh-so-nicely.

Anyone has any suggestions for preventing this?

EDIT: *bump* @DZCreeper :)
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
No, I don't get any visual problems. I would suggest you test both your memory and video card. You can use Memtest86 for the memory and Furmark for the video card. Fair warning, Furmark will make your graphics card reach the highest temperature possible. If your computer has heating issues at all, fix them first. Also, what power supply do you have? Inferior power supplies can fail to deliver enough power to the video card, causing visual glitches or lowered performance. Generally you want something with a single 12V rail at high amperage.

Edit: Added links.

http://www.memtest.org/

http://www.ozone3d.net/benchmarks/fur/
 

AlCapella

New Member
Jul 29, 2019
709
0
0
Here's the results of memtest86+ and ozone3d. I left memtest86+ running for over 16 hours or so over the weekend, and the screen did not update beyond that.




So, there seems to be something wrong with the RAM? that much seems obvious. What about the Radeon test? I was unable to parse that one.
I've sent the screenshots to my dealer also. I'll hear something from him tomorrow. Meanwhile, what else?
Thanks again.
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
Your video card is fine but you have some bad memory, remove all but one stick of it and try the test again. If it passes, repeat with the next stick until you find all the bad ones.
 
  • Like
Reactions: AlCapella

AlCapella

New Member
Jul 29, 2019
709
0
0
Your video card is fine but you have some bad memory, remove all but one stick of it and try the test again. If it passes, repeat with the next stick until you find all the bad ones.
^^ Okay. Will do. You've been very helpful so far, @DZCreeper.

Also, the guys in the AMD support forum where I had posted the "glitch screenshots" (enclosed above) kept telling me modded Mc is not supported, so I am out of luck. Is that right? Mojang soesn't support modded MC, fine. But, AMD can say that? Anyway another "veteran" member told me to switch Vsync back on... I would link the thread for your reference, but somehow their forums has been down for a few days straight now. All that enabling VSync has done for me is made the game more sluggish, but hasn't improved anything else!

Thank you again.
 

AlCapella

New Member
Jul 29, 2019
709
0
0
Indeed, the AMD support forums site is still down. Someone told me that it's probably the resource packs causing the glitch... Nope... Here's the game, minus the resource packs.

^^ As you can see where the white coloured box is, nothing changes in the default textures as well. :(
 

Senseidragon

Well-Known Member
May 26, 2013
699
317
88
Not sure if this helps or not, but random Googling of video issues had this pop up a few times:

Try adding this flag to your JVM arguments. If it doesn't help, take it back out.

-Dforge.forceNoStencil=true

If it works, let us know. :)

Edit: Further reading seems to suggest that some older AMD cards or drivers may have issues with stencil buffers.
 
Last edited: