Open 2.5.0: Some Tinkers' items don't display correctly.

Discussion in 'FTB Presents SkyFactory 2.5 1.7.10' started by Echosa, May 22, 2016.

  1. Echosa

    Echosa Guest

    Version:
    2.5.0

    What is the bug:
    Some of the TInkers' Construct items and books don't display correctly for me. Notably so far are my pickaxe:

    http://i.imgur.com/UkSi6cQ.png

    and all of the TInkers' books:

    http://i.imgur.com/Dg8DHSV.png

    This is running Sky Factory 2.5 on a Retina MacBook pro running OS X El Capitan, with the modpack running through the FTB launcher version 1.4.11-378.

    Note that I've had similar issues running some versions of TConstruct in ATLauncher and MultiMC. There seems to be particular version of Forge that causes this to happen. Consequently, most of my home-grown modpacks run older version of Forge (10.13.3.1388) precisely because of this problem. Any version after that seems to cause this problem. I'm assuming FTB SkyFactory 2.5 is using a newer version of Forge than that.

    Mod & Version:
    SkyFactory 2.5.0

    Paste.feed-the-beast.com log:
    http://paste.feed-the-beast.com/view/c6e27c7a

    Can it be repeated:
    This is consistent for me.

    Known Fix:
     
  2. Darkosto

    Darkosto New Member

    The version of Forge that every 1.7.10 modpack that has been created and developed in the last 5 months are using Forge version 1614. This sounds like something that happening because of your system and not specific to this modpack. There's not much I can do, seeing as how Forge has moved on past 1.7.10 and will not be updating that Minecraft version anymore. I would suggest trying a texture/resource pack that has those particular textures to help with your problem. Soartex Fanver Universal is a good place to start: https://soartex.net/downloads/modpacks/
     
  3. Echosa

    Echosa Guest

    That's unfortunate. Why would an updated Forge version affect textures being loaded? I'd really rather not use a different texture pack, as I rather like the default one. I also can't help but wonder how many texture packs have new textures specifically for certain mods, like Tinkers' Construct.

    Additionally, I just found another item that has this issue: creeper hearts from Witchery. I've only ever seen the issue with Tinkers' items before, so this is new info.
     
  4. Echosa

    Echosa Guest

    Update: Thanks for the advice. I grabbed that resource pack you recommended. Not a huge fan, but it is properly displaying textures for some of the items that weren't displayed correctly before. Worst case scenario: I make my own custom resource pack that only fills in the textures that don't show properly.

    Any idea what would cause this issue and why updating Forge would be the culprit? Obviously, the game is able to properly load and display the textures for items, so I don't understand why some of the default textures aren't loading and displaying correctly.

    Thanks, again!
     
  5. UniZero

    UniZero Popular Member

    Have you checked for an update to your video card. The version of forge you are using on your own modpacks is very old. The newer versions changed a lot of things and unfortunately caused the 2.4 update of sky factory, also other modpacks, to have issues running on some systems. I had an issue as well but an update to my video card fixed this.
     
  6. Echosa

    Echosa Guest

    I run OS X on a Retina MacBook Pro, and have installed all the latest updates from Apple. The fact that simply using a new texture from a different resource pack, as recommended by Darkosto, results in correctly displayed textures makes me think that this wouldn't be a hardware issue. If Minecraft and Forge can properly load and display one texture file, why can't it properly display and load another?

    As I said before, for now I'm uisng the resource pack that Darkosto recommended. Still not a huge fan, but I'm coming around to it. Parts of it are quite beautiful, so I may go through and make my own mix-and-match resource pack. It's fairly annoying that I have to do this, but if it makes things work then I'll do it.

    I wonder if anyone else has had this issue. Perhaps fellow Mac users. It's possible it's an issue between OS X and Forge. I don't know their development or testing situation, so perhaps they don't test on OS X.
     
  7. BarryCarlyon

    BarryCarlyon Guest

    I have this also on Max OSX Retina.

    I fix it by just opening Escape Menu, Options, Resources Packs and just hitting Done.

    Basically regardless of installed mod packs, or resource packs, just hit done and let the client recompile the RP, seems it fails to compile properly on first launch
     
    Echosa likes this.
  8. Echosa

    Echosa Guest

    Barry... Thank you. Not only for verifying that this isn't just a "me" or "my computer" problem, but for giving me a much easier solution. Don't get me wrong, I'm very glad to now know that Soarex exists. However, knowing that all I have to do is reload the resources is wonderful. I can't believe I never thought to try this. To be fair, I never would have thought that just opening up the resource packs menu then closing it again would reload the resources without actually adding or removing something first. I guess I assumed they would check for changes before reloading when you click "Done".

    That also helps narrow down what's going wrong. I still don't think it will get fixed, but one can always hope. I wonder what goes wrong during the first that manually reloading the resources fixes.

    Also, FWIW, you can just press F3+t to reload the resources. No need to go through the menu. (I just tested this, and it works just as well as going through the menu.) I still can't believe I didn't think to try this.

    I wonder if this will be an issue in 1.8 and/or 1.9. It does seem to be an issue with Forge on OS X.
     
  9. Darkosto

    Darkosto New Member

    Awesome! I'm glad Barry was able to give some insight on this issue and get your fixed up! Thanks, Barry :)
     

Share This Page