Open 2.3.3: Forestry Miner's Backpack not working in 2.4.0, and 2.4.1

R

Rixxaw

Guest
Version:
2.3.3

What is the bug:
Forestry Miner's Backpack doesn't recognize ore, ingot, nugget or dust from any other mod besides Railcraft. It also does not recognize vanilla Iron Ore, in version 2.4.1.

It works in version 2.3.5.

Checked the config file differences between 2.3.5 and 2.4.1 and found what appears to be a typo, but any time I change the config the FTB launcher somehow over-writes the file, with the known bad config file included in 2.4.1.

Seems like a simple fix guys. Just a period out of place or something here.

Mod & Version:
Forestry 4.2.54? 2.4.1

Paste.feed-the-beast.com log:
http://paste.feed-the-beast.com/NotApplicable-and-ur-paste-site-is-down

Can it be repeated:


Known Fix:

Use this config file : http://pastebin.com/nFJ1Atsa
 
Last edited:
R

Rixxaw

Guest
I just posted the notepad++ compare between the 2.4.1 on the left and the 2.3.5 config files. I have tried marking the config file as read only so the update to 2.4.1 will not overwrite it, but nothing I can do works. I have to decide between losing all by Bees but having working backpacks or throwing the backpacks out the window because of this typo in the config file.

Please fix this asap, or tell me how to work around the launcher overwriting a config file that we are supposed to be able to edit.
 
S

Sympai

Guest
I have been messing around. Seems like this config as well as project red's config have some added stuff they shouldn't. On the left image notice the lines item.stacks and itemStacks. It appears that itemStacks is no longer valid and has been replaced by item.stacks in the current versions. I don't know if this is a bug with the mod or not, but getting rid of itemStack and everything under it will fix any issues. I found that by deleting the config and rerunning the game should clear up any issue, so if I were you, I would delete the backpacks config, run the game and test. Post back with results.
 
R

Rixxaw

Guest
I've tried deleting it and I've tried changing it manually. the FTB launcher over-writes everything I do. That file is generated by the FTB launcher / client on start.

And the odd thing is the railcraft ore's work, so you are right the item.stacks is working. The second section may or may not work but since the two apparently conflict with each other as if they renamed a variable in the first section by creating the first section in the first place. Either way someone knows they goofed up and can fix this.
 
R

Rixxaw

Guest
Okay apparently if you create a proper config file the FTB doesn't overwrite it on load.

here is a config file from Un-Worries thread where someone fixed the config file and posted. confirmed to work

http://pastebin.com/nFJ1Atsa
 
Last edited:
  • Like
Reactions: un worry

guiguilyon

New Member
Jul 29, 2019
76
0
0
I deleted backpacks.cfg from Forestry config folder and restarted the game. It works.
 
Last edited:
R

Rixxaw

Guest
I deleted backpacks.cfg from Forestry config folder and restarted the game. It works.
Yes if you do that you will have a BASE config or empty config that doesn't include the other mods versions of the Ore's? You should only be able to put Railcraft metal and vanilla ores in there if I remember correctly.

If you take the Paste-bin config you can actually add Chisel Items to the Builders backpack as well allowing you to keep stacks and stacks of Factory blocks, and Laboratory Blocks, as well as my current favorite Voidstone blocks.
 

aTeLe

New Member
Jul 29, 2019
68
0
0
I freshly downloaded 2.6.0 and the backpacks aren't working. Since it's an issue for so long, Is this intended?