1.7.10 Modpacks ... problem with allocated memory and strange performance behavior

Discussion in 'Tech Support' started by WildWolve, Oct 23, 2015.

  1. WildWolve

    WildWolve New Member

    Title:
    1.7.10 Modpacks ... problem with allocated memory and strange performance behavior
    Launcher Version:
    1.4.8
    Modpack:
    various modpacks
    Modpack Version:

    Log Link:

    Details of the issue:
    Hello comunity ^^
    first of all, i wanna say sorry for my not perfekt english, i'm from austria and english is not my mother tongue, for the case that you will find some strange typed words ^^

    ok i have some strange performance problems and i can not sort it out, what's the reason why, since the time i startet to play modpacks for Minecraft 1.7.10. Befor that i played tekkit lite (minecraft 1.4.7) and it works fine.
    i played a few different modpacks, all in singleplayer, like "the dark trilogy", "infinity" (at least and most of time), and "direwolf20" from FTB launcher, also from the AT launcher i played DNS techpack a little bit and some Skyfactory 2. ecept for skyfactory i have the same problem with every 1.7.10 modpack:
    right from the start of the world i have 100% allocated memory. ( in skyfactory i'm at 83% alocated memory right from the world start). the taskmanager shows me, java is using waaay more than 4 gig, sometimes even more than 5 gig ram and i have sometimes spikes with 90% up to 96% using my CPU. And that with a system, that should handle even big modpacks without any problems like DNS with way more than 200 mods. (see system down below)

    i played always in maximised windows mode
    sometimes, as we all here knows, you have to tab out of the game because you may have to check somethingother during playing modded minecraft, making a note for example or do some research in the internet with firefox. most of the times, if i tabbed out of the game and go back into minecraft, my frames drops to 4 or 5 fps and stuck with it. Sometimes i can fixe it with F11, go in fullscreen mode and back in windows mode, do that a few times. But very often i have to close minecraft and restart it.
    i also noticed, that i get a framedrop for 2 or 3 seconds, in the moment, i go into my inventory, or a chest, or a turtle.
    another thing, what i don't understand is: when i start to play FTB modpacks i couldn't use a mining turtle. i build a mining turtle and as it start to work my frames brocke to 2 fps. now since one of the younger updates of infinity (i don't know which one changed that) i can use it now. Now i don't get those framedrops anymore when a mining turtle starts with her programm. i have no clue, what was the change here.

    It doesn't make a difference, what performance settings or video settings i have set in minecraft, neither the settings of range of sight. I tryed to change every single one, to get better FPS, but nothing
    it doesn't make a difference, if i install java 7 or java 8 ( current version at system below) i tryed too delete java and install an older javabuild, then i reinstall the latest one. a few times with different java versions ... Nothing!
    it doesn't any difference how much chunkloader i have, like i said, the problem exists from the start of a brand new world with nothing build already.
    it also seems not to make any difference, how many mobs are spawned on the map.
    oh yeah before i forgot, it also doesn't matter, if i use only one monitor, or two like current

    System:
    Asus Desktop PC G30AB
    intel I7-4770K @3,50 GHz
    8 gig ram
    64 bit system
    Windows 8.1
    NVIDIA GeForce GTX 770 with 2 gig
    Javaversion 8.0.65


    now i run out of ideas to get fix this really annoying problem and i hope somebody of you is able to help me with that. because of minecraft did not crashed, i had of course no crashlog to show you. sorry for that
    WildWolve
     
  2. lenscas

    lenscas Over-Achiever

    What does f3 tell you about how much memory it has allocated?
    Make sure minecraft uses your Nvidia GPU. Look under snooper settings at openGL vendor to see what cart it uses (asuming your CPU has an integrated GPU)
     
  3. WildWolve

    WildWolve New Member

    Hello lenscas, thank you for trying to help me out. very appreciate that^^

    ok
    F3 screen shows me ... 100% allocated memory /3956mb

    and the snooper settings told me that here
    http://imgur.com/DK61VUU

    i guessy that is working fine

    WildWolve
     
  4. WildWolve

    WildWolve New Member

    any moar ideas to get rid of my problem?
     
  5. mc.crab

    mc.crab Well-Known Member

    Have you tried without the resource pack? When I used a resource pack my memory usage was closer to 95% with 8 gigs of RAM.
     
  6. WildWolve

    WildWolve New Member

    yep .. id did, nothing! no difference
     
  7. lenscas

    lenscas Over-Achiever

    I believe you can make the game crash by holding f3+c maybe that will reveal something useful.
    But to be honest, I have no idea why your game uses all the RAM at all time.

    How does Minecraft behave without any mods? Maybe it's one of the mods having problems on your system for some reason?
     
  8. WildWolve

    WildWolve New Member

    thanks lenscas ... yeah after a little bit research i learned to hold F3 and C for 10 seconds to crash minecraft xD it worked
    i did a security copy of my infinity worlds and crashed it ^^
    here is my crashreport ---> http://pastebin.com/YcutxZEF


    uhm what do you mean? do you mean vanilla minecraft? or modpack like infinity with all moda deactivated?
     
  9. lenscas

    lenscas Over-Achiever

    Maybe try without any jvm flags?
    thus remove these:
    -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx4G -Xms4G -Xmn256M -XX:NewSize=512M -XX:SurvivorRatio=2 -XX:+DisableExplicitGC -XX:parallelGCThreads=4 -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CICompilerCountPerCPU -XX:+TieredCompilation
    In ftb they are at options->advanced option->additional java parameters
    if that doesn't solve the problem try both vanilla and a modpack where you removed all the mods. (assuming that vanilla minecraft worked correctly both need to have 4 GB of RAM allocated to make the tests as equal as possible)
     
  10. WildWolve

    WildWolve New Member

    Ok ...


    here are the news:

    nope, the deleting of the jvm flags did nothing, but that does not surprised me. time ago i talk too some people because of my FPS problem and they suggest to bring the jvm flags in, they may do some difference ... unfortunatly they did not.


    then i downloaded ftb "the dark trilogy" as a normal modpack, without any changes at the mods, without any ressourcepack or anything else ... F3 shows me 100% allocated memory 3965 mb
    after that i closed it and deleted all mods from the trilogy modpack and start it again. well not all mods, i stillhad 3 mods like from the forge thing. but now comes the interesting thing: F3 shows me 7% allocated memory ( something around ) 320 mb up to 400 mb


    for some testing i made a second mainfolder for the FTB launcher and i downloaded infinity and the dark trilogy in the the new one. First i thought, my bee the ressource pack is the issue or the 20 extra mods, which i get for playing ftb infinity. But i tested it in the ftb test folder with the dark trilogy, infinity and the darktrilogy are same big, both had at the normal modpack 172 mods:
    the 20 extra mods mad only a difference from 44% allocated memory up to 49% and the ressource pack mad a difference from 49% (ressource pack no / 20 extra mods yes) from 49% allocated memory up to 88% allocated memory


    after realizing that i fly a bit around in the world and tabbet a few times out of the dark trilogy and return to it, i thought i had it:
    then comes the hammer


    the F3 screen still shows me 88% alocated memory but after a few times tabbing out of the game and return to it .. BAM! Minecraft droped down to 3 FPS und get stuck with it -.- i hate it
     
  11. lenscas

    lenscas Over-Achiever

    so, without mods it uses 7% of RAM?
    With infinity it uses 44%?
    with 20 extra mods it uses 49%
    with the resource pack and the extra mods it uses 88%?
    and after a alt tabbing a few times it gets stuck at 100% again?

    If you have the console open from the ftb launcher does it say something about leaked worlds or something else that looks wrong? (during startup it will have a lot of red lines, no worries most if not all of them are normal)
     
  12. WildWolve

    WildWolve New Member

    it get stuck with 88% too ... it doesn't have to get up too 100% allocated memory to get stuck with 4 fps
    right now i have the DNS techpack from the AT launcher open, with this modpack i have the same problem
    there i have even 96% allocated memory with out the ressorce pack

    and the AT console shows me this line right now at the last:
    [27/10/2015 13:39:17 PM] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 2085ms behind, skipping 41 tick(s)

    but yeah, i guess the ftb console would also show me something like that ... i saw some line like this one in the past
     
  13. lenscas

    lenscas Over-Achiever

    I was more thinking about some error, this just tells you that it can't run fast enough.
    I just don't get why every modpack goes so high in memory for you, can you post a screenshot of the debug screen? Maybe I said something wrong causing you to look at the wrong things?
    I really have no ideas anymore.
     
  14. WildWolve

    WildWolve New Member

    i never saw ian error message at this frame drop event ...

    here is a screenshot of testworld in the dns pack ---> http://imgur.com/FtMwxxz

    btw taskmanager shows me 4.551,6 mb ram in use only for Java / minecraft
     
  15. lenscas

    lenscas Over-Achiever

    And in this screenshot it uses 55% of its RAM which s about 2236 MB, this sounds a lot more like normal.
    I think you were looking at the wrong thing though as right under it is indeed something telling you its 96% but that is not the thing you should look at.(for as far as I know)
    You also appear to have 49 fps which is playable.
    Then now the question, did you try to get your RAM usage as high as possible by doing the alt tabbing thing or did you just took it as soon as possible?
     
  16. WildWolve

    WildWolve New Member

    i started my main world in ftb Infinity, whe i had made some much stuff and already build so many ...

    i run around through my castle and try to get this strange framedrop ... here is the screenshot from the debug screen, 2 seconds after minecraft droped down to 5 fps ---> http://imgur.com/qtHrOJX
    as you can see i have 63 % used memory at the frames droped down
    sometimes i can tab out of the game 20 times and nothing happens, and sometimes the game lost the frames after the first time alt tab


    of course with 49 fps ican play minecraft pretty perfect but as you can see at my last screenshot ... :(
     
  17. lenscas

    lenscas Over-Achiever

    Maybe its optifine then? I know it can cause issues, never heard of it doing things like this but at this point I have no idea why your performance goes down.
     
  18. WildWolve

    WildWolve New Member

    Hello again

    nope optifine did no difference ...

    but i think its the texturepack, i did some quick tests for ram using and without texturepack minecraft was pretty stable, with texturepack minecraft droped to 4 fps again and again an again, but it does it without alt tab out of the game ....

    i will test it, but that will take some time, because - as i said - the framedrops by alt tab out of the game and return into minecraft, were totally random...
    i will see how stable the game will be without the texturepack in the next few weeks

    the only thing, that still bring headpain to me is the thing what the taskmanager tell me about RAM using by minecraft modpacks. often java is using waaaay moar than 4 gig something it goes up to 6.000 MB RAM .. its confusing, i realize that today too, during play DNS techpack with default textures ... taskmanager shows me: minecraft ___ almost 4.800 MB Ram
     
  19. idjmleader

    idjmleader New Member

    Do not put more than 4gb of ram to client side :) I did not read all this post but ya hope that helps.
     
  20. lenscas

    lenscas Over-Achiever

    He only allocated 4 GB to minecraft(maybe less I forgot the exact amount), his f3 screen confirms this. Task manager however says its using more.
    Maybe its the ftb launcher+minecraft? I have no idea never gave it a close enough look.
     

Share This Page