[1.7.10] Binnie Patcher

Discussion in 'Mod Discussion' started by Chocohead, Feb 6, 2016.

  1. TomeWyrm

    TomeWyrm Popular Member

    I play on his Dev server, I was trying to replicate the Bees with Gendustry... I still want to hug @Chocohead
     
  2. xeronut

    xeronut Active Member

    Thank you for this! I have a folder full of newer versions of mods that I can't use because Binnie's Mods wasn't playing nice. I love the Panel/Wood/Tile/Glassworker too much to update, so this was a welcome surprise to wake up to. :)
     
  3. kordum

    kordum New Member

    Another visual bug:

    Untitled-1 copy.jpg
     
  4. Mistercloud

    Mistercloud New Member

    You should add it on curse so people could find it !
     
    kordum likes this.
  5. FranzieJK

    FranzieJK New Member

    @Chocohead it doesn't work in my pack :(
    here the first 2 lines of my crashreport ç_ç


    ---- Minecraft Crash Report ----// Don't be sad, have a hug! <3Time: 2/14/16 10:25 PMDescription: Initializing game java.lang.NoSuchFieldError: blocks

    at chocohead.patcher.PatcherPlugin$Patcher.postInit(PatcherPlugin.java:174)
    ....
    any ideas about this error?
     
  6. Chocohead

    Chocohead Well-Known Member Wiki Staff

    What version of Forestry do you have? Do you have Forestry's Arboriculture plugin disabled?
     
  7. Kupferdrache

    Kupferdrache New Member

    Chocohead I have a Crash report for you may you can tell me what went wrong before I start to rip out mods to locate the error futher.

    The report is attached as created.
     

    Attached Files:

  8. D.V

    D.V Active Member

    First all, thanks Chocohead for this fix : very appreciable :)... Thanks a lot :D

    I have a question about Forestry V4 & Binnie core with this fix : someone get a crash with the Extra Tree's fences:2 when you update Forestry ?

    Now, my world crash when a chunk is loading with this kind of fences... Any idea or solution about this issue ? (Must remove all Extra Tree's fences to resolve that ?! xD)

    Thanks in advance.

    Pastebin :
    http://pastebin.com/BAy6eru5

    EDIT : I see a new version of your patch... test with it but issue still here :(
    EDIT 2 : Test with new version of Forestry too => Still crash.
     
    Last edited: Feb 16, 2016
  9. Chocohead

    Chocohead Well-Known Member Wiki Staff

    You don't have Binnie Patcher installed, at least not in the crash report you attached
    Yeah, that still needs fixing.
     
    D.V and Robijnvogel like this.
  10. Robijnvogel

    Robijnvogel Well-Known Member

    Chocohead, thy head be delicious, may you fill us with the yumyums.

    Thou art not being thanked enough, so accept my humble offering.
     
  11. D.V

    D.V Active Member

    Okay, thanks Chocohead ^^ How long it will take you to do this fix please ? If it's too long for you, don't worry, i will replace all my fences in my server but if it's just few days, i will waiting :)
     
  12. Kupferdrache

    Kupferdrache New Member

    hm, strange Do I have to put it into a sub directory? But that would explain the crash.

    Edit: Could it be the the patcher is called exsample mod internaly?
     
  13. D.V

    D.V Active Member

    You must put this patch on the folder call Mods/ (Basically, with other .jar) or maybe you use the wrong folder/modpack ?
     
  14. Chocohead

    Chocohead Well-Known Member Wiki Staff

    Released a new version, fixes your fench crash and a long standing bug in Binnie's mods that the planks tab in the Arborist's Database was empty.
     
    D.V and Robijnvogel like this.
  15. LunariusH

    LunariusH Member

    http://pastebin.com/gJwGRKFZ

    Had a crash here when I installed Binnie's patchers. Yes I have Arboriculture and Lepidopterology turned off. Along with automatic farms..

    About the only thing that *is* enabled from Forestry is the bees. >.> Using Magic Bees with your patcher.
     
  16. D.V

    D.V Active Member

    Add the new version of my server => Launched => Stable since 1 hour..... THANKS A LOT CHOCOHEAD ! You earn a
    dog kibble :p

    Appreciate your efficiency. Good game everyone and good luck for further bugs Chocohead :oops:

    (If i found any bugs with this patch, i will report on this topic)
     
  17. Kupferdrache

    Kupferdrache New Member

    Thanks for finxing the internal Modname as well, it works now.

    Forestry extras has the same problem, not sure if it is worth keeping it. But If you find time you may took a look into it if you could integrate support for it as well.

    You did a AMAZINIG job.

    Edit: for reference I added the forestry extras crashlog to this post.
     

    Attached Files:

  18. Chocohead

    Chocohead Well-Known Member Wiki Staff

    That'd do it, I never accounted for the lists never populating as the parts were disabled. Should be a simple enough fix.
    It's open source so I just forked it and patched it. I've not tested it at all but I can't be expected to do all the work ;) https://github.com/Chocohead/ForestryExtras2-4Forestry4/
     
  19. LunariusH

    LunariusH Member

    Oh thank God, I wanted to include the Magic Bees in the Modpack, but without being able to turn off Arboriculture, Lepidopterology, and Farms I just couldn't.
     
  20. jikuja

    jikuja Launcher Dev Launcher Developer

    Nice work but...

    I tried to find license for original source code and failed. Can you provide link? Better to handle this now before fixed mod is being added into packs.
     

Share This Page