1.1.0: Somthing in my world seriously crashes the game!

Discussion in 'FTB Presents CrackPack' started by Galbi3000, Jul 23, 2016.

  1. Galbi3000

    Galbi3000 New Member

    Version:
    1.1.0

    What is the bug:
    I have a world that worked fine for a long time, I have mapped a large portion of it. Most of what is mapped was generated in version 1.0.0 of the mod pack. Last night I tried flying in bat form to look for stuff I need. I was flying over an area already mapped. All of a sudden the game closed taking me back to the FTB launcher.

    I tried launching the game again but it crashed before even displaying the main menu!

    I rolled back to the previous backup of the world and tried again. Same crash out before the main menu!

    Reverted to version 1.0.0 and same again!

    This bug occurs with both versions of the pack.

    The pasted log is from version 1.0.0 of the pack.
    I have another log from before reverting back to 1.0.0: http://paste.feed-the-beast.com/view/0473db79

    Mod & Version:


    Paste.feed-the-beast.com log:
    http://paste.feed-the-beast.com/view/68dc76ab

    Can it be repeated:
    I can fix the crashing before the main menu by restoring a backup copy of the config folder. So the bug is affecting a config file somehow making it crash the game on load.

    If I reload the world at the backed up stage I can still play the game. But moving to the area where it crashed crashes it again! I then have to restore the config as well as the world backup to get it working again.

    I have crept near to the area with the chuck render setting at it's lowest to get as near to the affected chunk as possible so I know roughly where it is.

    Known Fix:
    No known fix yet!
     
  2. Galbi3000

    Galbi3000 New Member

    Ok, I have fixed the issue.

    I loaded my world into MCEdit and found that a chunk was seriously corrupted! I used MCEdit to delete that chunk from the disk and reloaded FTB. The world loaded fine, no crash and the missing chunk was re-generated.

    The question now is why did this also corrupt a config file enough to make the game crash before even showing the main menu?
     

Share This Page