Closed 1.0.4: 1.04 island creation problem

Wackoamd1

New Member
Jul 29, 2019
11
0
0
Version:
1.0.4

What is the bug:
i'm nt sure if it is related to the known bug with capital letters , if so im sorry but..

im trying to create islands for my players with the playersname , so when they join the server all that have to remember is /island join playername

now the weird part is that sometimes it creates the island and sometimes it doesnt , and ofc ppl fall to theyre death ;-) when they join the island which should be there .

Mod & Version:


Paste.feed-the-beast.com log:


Can it be repeated:


Known Fix:
 

Lone Lycan

New Member
Jul 29, 2019
25
1
0
two things i've found.... the /island create command cannot be run from console.. and cannot be run from a non-opped player

make sure the player typing the command is typing it in-game not in the server console.. and make sure the player is opped
 

Wackoamd1

New Member
Jul 29, 2019
11
0
0
i know this and thats not the problem ,
sometimes it just doesnt create the island.
atm it looks random , but it might be related to the known bug with the capital letters.
 

DeathOfTime

New Member
Jul 29, 2019
824
0
1
i know this and thats not the problem ,
sometimes it just doesnt create the island.
atm it looks random , but it might be related to the known bug with the capital letters.
The Island never get created? It is possible to be a lag issue? The server to busy with everything else that it doesn't create the island in time. Could you send someone through the list of failed islands and see if it is still a issue? (preferably a mod or someone with some sort of flight.) Get them to fully gen the chunk.

Not disbelieving your issue. Just adding troubleshooting possibilities. To allow for further data collection and eliminate any possibilities.. You may have even already tried them, Or even something similar.
 

Wackoamd1

New Member
Jul 29, 2019
11
0
0
its on a completely fresh world , without any island created.
i even waited for a few minutes before creating a island.
but im almost sure it is related to the capital letter bug , because i just deleted the world again. tried it with only lowercase letters and the islands are created.
it's just a bit of a hassle for now to tell ppl to only use lowercase letters when they join the island instead of the exact playername
 

Lone Lycan

New Member
Jul 29, 2019
25
1
0
just add another sign to the 3 already at spawn

i'm lazy, but even i would go to that much trouble for a minor bug while you're waiting for the bugfix to be implemented
 

DeathOfTime

New Member
Jul 29, 2019
824
0
1
its on a completely fresh world , without any island created.
i even waited for a few minutes before creating a island.
but im almost sure it is related to the capital letter bug , because i just deleted the world again. tried it with only lowercase letters and the islands are created.
it's just a bit of a hassle for now to tell ppl to only use lowercase letters when they join the island instead of the exact playername
I found out just now the coordinates for the islands aren't saved in the world folder. It might be the issue. With that save setup something like your issue might happen if islands were created on a previous world. The mod might be checking it for a island entry before creating a new island. Since the entry is already there it fails to create a new island and teleports the player to the location of the island that is currently in the list when they try to go to the new one. Two possible workaround present themselves if this is so. Delete the island list when creating a new world. Use unique identifiers for every island, check them against of master list of island names, might even be worth going to the islands and writing down the coordinates of them. As if this file is ever lost the teleports to the islands it provides will be too.

The coordinates for the islands might be stored at /local/islands.ser