1.0.2: 1.1.0: Difficult Life - disabling custom health regen disables all health regen permanently

Discussion in 'Horizons: Daybreaker' started by Ligands, Aug 3, 2015.

  1. Ligands

    Ligands New Member


    What is the bug:
    For this configuration parameter:
    # If this is set to %true%, then the default MC health regen mechanic will get replaced by the custom one, added by the mod [default: true]

    Setting enableCustomHealth=false does not enable the default MC health regen, but rather disables health regen completely.

    Also, probably related, this bug definitely still exists in 1.1.0:
    I had difficult life disabled originally, and when the 1.1.0 update came out, I figured hey, why not try it out? Then I noticed how overpowered the heart canisters were by default, and figured I'd just disable the mod again- it was simply delaying combat tenfold, not making it harder. This had the side-effect of completely disabling natural health regen! I re-enabled the mod and changed the aforementioned config setting to false, and noticed that I still had no HP regen. It's gone forever ;_;

    For science, I tried completely emptying my hunger bar and filling it again, with either the mod disabled or the enableCustomHealth set to false, and I still had no natural regen.

    (On a side note, why do the default settings have heart canisters dropping from any mobs, with no limit to maximum HP? The moment you have a mob farm, you're invincible. And you know everyone's gonna set up a blaze farm for that juicy exchange energy)

    Mod & Version:
    Difficult Life 1.2.1710.3

    Paste.feed-the-beast.com log:

    Can it be repeated:
    Either by setting B:enableCustomHealth=false, or disabling Difficult Life in the FTB Launcher

    Known Fix:
    Only fix is to set the setting to true. There's not much different about the 'custom regen' anyway so it's no biggie; the main issue is that the HP regen remains broken even after disabling the mod.
    Yatekko likes this.
  2. Ligands

    Ligands New Member

    Also, you really need to add a '1.1.0' option to the version drop-down box in the bug report form.
  3. Zarvoxbe

    Zarvoxbe New Member

    I've also disabled difficult life on my server cause with blood magic is a pain in the backside to have regeneration (I know there is potion).

    For restoring vanilla health regen enter in a console "gamerule naturalRegeneration true".
  4. Ligands

    Ligands New Member

    Does this work with cheats disabled? (Sorry if it's a stupid question, just can't try it out myself at the moment)

    For the meantime I'd just changed the configuration to make it more vanilla-like.

    It's a shame, FTB modpacks could sure do with difficulty balancing of some sort, but this is more of an inconvenience than a difficulty increase. Not hating on Difficult Life, just the way it implements difficulty is not for me.
    For example, mobs now just take a few extra sword pokes to kill, but I'm still invincible in my Battlesuit, even moreso after collecting a few stacks of heart canisters from a mob spawner- so effectively, I'm just taking more time to achieve the same result (which feels like quite a backward mechanic in the world of modded minecraft).
  5. Yatekko

    Yatekko New Member

    THANK YOU... I've been trying to figure out for an entire day why I haven't been regenerating and it's been driving me insane.
  6. Gunner76th

    Gunner76th New Member

    If you are playing with cheats disabled, you will need to use NBTExplorer and edit the Level.Dat file for your game save. Your client must be closed when doing this. Click on "Data" then click on "GameRules". Once you have GameRules open, look for "naturalRegeneration:false" and double click it. In the box that opens, delete what is there and type "true" in all lowercase. Click on ok, then click on the disk to save your updated entry, then close NBTExplorer. When you start your client back up, you will regenerate health using the normal MC mechanics.
  7. Ki29PDX

    Ki29PDX New Member

    I'm having the same problem with my world. I got tired of 65 hp chickens and disabled DL, now I cant regen health at all. I tried the above suggestion (gamerule naturalRegeneration true) with no result. Cheats are allowed.

    NM. Idiot me left out the / when I tried it. All better now. Thank you for the fix!
    Last edited: Dec 7, 2015
  8. Delcar

    Delcar New Member

    Gunner76th: Thank you for the solution.

    I'm in agreement - I like the idea of a timed progressively increasing difficulty (to cut down on the "Ooo Shiny" distractions too) but when I have to chase a cow for ten minutes because his hitpoints are exponentially higher...
  9. RealKC

    RealKC Popular Member

    An easiee solution would be(works if you're on single player): go to options, Open to LAN and there should be an option to turn cheats on, enable it, type in chat "/gamerule naturalRegeneration true".(without ")
  10. Shadus

    Shadus New Member

    This mod is neigh unusable on a server. Breaking basic vanilla mechanics even after removal, peaceful mobs taking minutes to kill, making a server basically unplayable rapidly, hyperfast unkillable mobs spawning at your home area spawn camping you before for hundreds of kills, etc... this mod should probably be disabled by default or removed. This would ruin most people new to the pack's experience.
    Penticrack likes this.
  11. Penticrack

    Penticrack New Member

    I totally agree. Mod creator don´t say a word how to remove this mod on this course page and how to restore regeneration (/gamerule naturalRegeneration true) . It respects NO other mods and i´m sure it breaks the gameplay any modpacks ! Optional activation with warnings would be better!

Share This Page