Open 1.0.0: Soujourner's Sash Does Work For LAN Player

Discussion in 'Departed 1.7.10' started by AName, Jul 13, 2015.

  1. AName

    AName New Member

    Version:
    1.0.0

    What is the bug:
    http://ftb.gamepedia.com/Soujourner's_Sash

    Version:
    Actually the post 1.0 release available from the FTB launcher.

    Issue:
    Soujourner's Sash only works reliably for local player but not LAN player.

    Details:
    Wife and I are playing. I created two soujourner's Sashes, one for each. Next I create two band of manas, again, one for each. Both a rings are charged. We've tried swapping rings and sashes, and each combination, and the results are the same. Also tried using just a mana tablet. Same results.

    When the sash doesn't work, it manifests itself in very odd ways. Sometimes, rarely, it works. For the first ten minutes or so, the first time I gave the sash to my wife, the sash worked. It suddenly stopped working. I don't recall if a stop and restart was involved or not. Regardless sometimes the double jump is permitted. Sometimes the step assist is provided. Sometimes the speed boost is provided; with this the most rare. Since the initial success at no time have all three attributes been available.

    Googled the topic and found a FTB post from 7 months ago on a sash bug. Sorry, several days ago and don't have link. Any ways, the link said that a local game should be started with the sash. Exit. Connect to LAN game. Tried this. It does seem to increase the likelihood of activating at least one of the sash's attributes but it does not seem to fix. Sash works perfectly for her when she is running in a local, non-LAN game.

    I have not tried to have my wife create the sash to see if that makes a difference.

    I'm running on Linux and hosting with the latest Java 8. Game is started as a single player game and made available to the LAN. Wife then connections via multiplayer. I've not looked to see which version of Java is running on my wife's box but IIRC it's Java 8; running on Win 8.x,

    Suggestions most welcome. Possible synchronization error with the sash? I have a technical background and am happy to provide any additional details. This bug is fairly frustrating as it effectively limits us from running around together and leaves her vulnerable to mobs.

    Mod & Version:


    Paste.feed-the-beast.com log:


    Can it be repeated:
    Yes. Same results observed into two different worlds - both hosted from my machine.

    Known Fix:
     
  2. AName

    AName New Member

    Subject should have, "NOT", added to it. Sorry about that.
     
  3. Kurama

    Kurama New Member

    Do you guys have a mana tablet with some mana in it?
     
  4. AName

    AName New Member

    Yes. Tried with mana tablet and band of mana. Both powered. Same works for me, not for LAN player.
     
  5. Watchful11

    Watchful11 Forum Addict Team Member Third Party Pack Admin

    This sounds like a tricky one. I'll do some testing and get back to you.

    I don't suppose you could record a short video clip of the phenomenon? Probably worth waiting for the 1.2.0 update that should be coming out tomorrow, it has an updated botania version.
     
  6. AName

    AName New Member

    Will update and report back. If it still doesn't work, I'll try to make a video of it.
     
  7. AName

    AName New Member

    Did some research and found that this is a widely known bug since at least January. It's believe to be a Botania/baubles bug or a conflict with one or more mods in the pack. I don't expect the update will fix anything. Will still test and report back.
     
  8. AName

    AName New Member

    Did try 1.2.1 on LAN and it's still broken. I don't believe this to be a Departed bug proper. Does work with server. Current 1.2.1 server is broken so still running 1.1.1.
     
  9. Jugg3rV

    Jugg3rV New Member

    Confirmed. We have the same problem here in a LAN world. The sash works fine for me, but not for the joining player.
     
  10. Moasseman

    Moasseman New Member

    Great bump mate.

    It's a known issue and not exactly too fixable. Certain things are just not made for LAN playing (Botania items like Sashes and Fl├╝gel tiara as well as RotaryCraft ethanol jetpack).

    To get around the issue, host a dedicated server and play on it.
     

Share This Page