Yet another plead for help... YogCraft Server Lag Issues, Optimization Requested

Theidore

New Member
Jul 29, 2019
2
0
0
In advance, I apologize to everyone who has seen this kind of thread before constantly. Unfortunately, I am not capable of solving this myself. I am running a Hamachi YogCraft server (which may be the issue), and my friend and I are having terrible lag with only us two on the server. Our ping connection with Hamachi is around 80, which he tells me is decent, since I don't understand these things, but I don't have all that much faith in Hamachi. Is there a way I can optimize my server to be faster? I'm gonna dump some PC info here that I don't know anything about, so if someone knows what to do with the mess I've made, I would extremely appreciate it if you could help out. This is all directly from my system info, so I'm not sure if this will help.

CPU: Intel Core i5-2430M CPU @ 2.40 GHz, 2401 Mhz, 2 Core(s), 4 Logical Processor(s)
RAM: 8 GB DDR3 Memory
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
That is indeed some helpful information, saves us a lot of time. First off the M at the end of 2430 on your processor means mobile, and the 2 cores means exactly that, you have 2 cores.

First off, this is fairly generalized, but your hardware is underpowered compared to a desktop. You won't be able to play and a host a server with good quality on this laptop, I am 100% certain. So if you play on another machine and host using this one, things will be much smoother. Next bit of info I need to spread to you and anyone viewing this thread, Hamachi has a small but often noticeable impact on connection quality. I suggest port forwarding the port your server is using in your router settings. This will allow people to directly connect without Hamachi, and contrary to what some people believe this is not a security risk, as long as you only forward the port you need.
 
  • Like
Reactions: Theidore

dajonar

New Member
Jul 29, 2019
9
0
0
i have the same problem, i run a server on a 2gb ram mac where i also play the game on (simultaneausly).
however even when i play alone the server lags alot and it takes around 2 seconds to open a chest.
Ps: i dont use hamachi but portforwarding


Modelnaam:iMac
Modelaanduiding:iMac5,1
Processornaam:Intel Core 2 Duo
Processorsnelheid:2,16 GHz
Aantal processors:1
Totaal aantal cores:2
L2-cache:4 MB
Geheugen:2 GB
Bussnelheid:667 MHz
Opstart-ROM-versie:IM51.0090.B09
SMC-versie (systeem):1.9f4
Serienummer (systeem):W8636340VUV
Hardware-UUID:00000000-0000-1000-8000-0016CB9466F0
 

glasspelican

New Member
Jul 29, 2019
187
0
0
First things first remove your hardware UUID from this post

Second, you will NEED atleast 2G of ram for JUST the server, with ANOTHER 2 gig for the client program, + 1 Gig for your OS and other programs

you can probably run a vinilla server + client with no problem, but mods <redated> your hardware
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
UUID is your computers Unique Identifier Code, keep that shit off the internet, its asking for trouble when the code is a permanent part of your device that can be faked by other devices with bad intents.

Your IMac doesn't have the performance and memory needed to do a client and server. A client it could do, a server maybe, but not both at once.