What is wrong with my AE autocrafting setup?

Brian Cherrick

Well-Known Member
Jul 5, 2013
1,050
98
64
I got generators setup to autocraft because I am working towards making HV solars. I run the generator recipe in batches of 64. The problem I am running into partway through a run is that it just stops crafting, or takes an extremely long time (many minutes) before it goes on crafting. The recipe I realize it is having issues on is the iron plate.

Now every item that goes into making a generator I have set to autocraft, including the maceration and smelting of iron ore.

Any ideas what it can be so that I can double check my setup?
 

KingTriaxx

Forum Addict
Jul 27, 2013
4,269
1,335
184
Michigan
Are you crafting enough plates so that it has them for the 64 generators? If not, adjust the recipe, or use a system to ensure you have the number you need at all times.
 

Brian Cherrick

Well-Known Member
Jul 5, 2013
1,050
98
64
Are you crafting enough plates so that it has them for the 64 generators? If not, adjust the recipe, or use a system to ensure you have the number you need at all times.
I'm thinking I may have to go the latter route. I was under the assumption that if the recipes all existed in the system that it would autocraft them as needed? Is this not the case anymore ?
 

KingTriaxx

Forum Addict
Jul 27, 2013
4,269
1,335
184
Michigan
It still is, but the speed of the machines might be causing a problem. Or if you're using the Forge Hammer, it might be using all it's cycles on something else and then having to wait for them to be free to use the hammer.
 

Brian Cherrick

Well-Known Member
Jul 5, 2013
1,050
98
64
It could be ... I got overclockers in each, but not enough EU/tick to power them all simultaneously ... so might be creating a backlog?
 

Brian Cherrick

Well-Known Member
Jul 5, 2013
1,050
98
64
I added more power, and even energy upgrades to increase the internal storage, and it still happens. Sometimes cancelling the job and restarting it will get it to work again, but that isn't always definite. Any clues ?
 

Blue

New Member
Jul 29, 2019
223
0
0
im having issues with my AE crafting? it stops randomly some time and i just have to craft enough of that sub item and then restart the originally thing i wanted to craft
 

KhrFreak

New Member
Jul 29, 2019
689
0
0
also are you changing your AE network at all while they are crafting? either by manually placing cables/ buses or by using a dark cable? cause that will also cause your autocrafting to stop
 

Blue

New Member
Jul 29, 2019
223
0
0
also are you changing your AE network at all while they are crafting? either by manually placing cables/ buses or by using a dark cable? cause that will also cause your autocrafting to stop
nope. not triggering an update in mine. if that happen it would wipe the crafting window clean. it just stops mid crafting saying it is crafting said item but doesnt show that its missing any items....which the system doe have all the items needed
 

Adonis0

New Member
Jul 29, 2019
1,800
0
0
nope. not triggering an update in mine. if that happen it would wipe the crafting window clean. it just stops mid crafting saying it is crafting said item but doesnt show that its missing any items....which the system doe have all the items needed
Sounds like a known bug, are you using rv14?

EDIT: The bug is here
http://ae-mod.info/Announcement/
"If you are interested in playing with the new features and are ok with smacking the network to reboot it every so often, the build..."
 

Adonis0

New Member
Jul 29, 2019
1,800
0
0
What does he mean by smack it to reboot it ?
Reset it by removing and/or adding a piece to the network
Something connected by a piece of dark cable works well because whenever you switch one of those they reset the system

You'll have to re-order anything you had crafting already, but at least it would craft that time around
 

Saamoz

New Member
Jul 29, 2019
25
0
0
I remember that in AE autocrafting, it crafts each component individually. If you're crafting a piston and you have logs and iron, first it will do the logs, in a sawmill perhaps, then after it is done, it will smelt the iron. Only then will it make the piston; it won't do things simultaneously even though it should. I'm not sure of any workaround, but a similar mod that handles things together is Logistics Pipes, which is pretty cool too.
 

Adonis0

New Member
Jul 29, 2019
1,800
0
0
I remember that in AE autocrafting, it crafts each component individually. If you're crafting a piston and you have logs and iron, first it will do the logs, in a sawmill perhaps, then after it is done, it will smelt the iron. Only then will it make the piston; it won't do things simultaneously even though it should. I'm not sure of any workaround, but a similar mod that handles things together is Logistics Pipes, which is pretty cool too.
I thought adding crafting CPU's increases the number of actions it can do parallel?
Correct me if I'm wrong though
 

Saamoz

New Member
Jul 29, 2019
25
0
0
I thought adding crafting CPU's increases the number of actions it can do parallel?
Correct me if I'm wrong though
Well, i think that crafting CPU's increase the speed of vanilla crafting functions, like wood planks to crafting table. If you are outsourcing functions with an ME Interface, like using a furnace or other machine, then it will wait that job to be completed before continuing, and as far as I know, you can't make AE do things simultaeniously.