[Tutorial] How to install shaders

Discussion in 'Texture packs' started by Zica, Feb 10, 2013.

  1. Zica

    Zica New Member

    So, now with the 1.6 modpacks out, it is very easy to install shaders.

    Download these two files:
    https://www.dropbox.com/s/0lmd2d1jmo34wlk/ShadersModCore-v2.0.1-beta18-mc1.6.2-f859-ofuc4.jar
    For this next one, you want to scroll down to where it says Sonic Ether's Unbelievable shaders.
    http://www.minecraftforum.net/topic...rs-unbelievable-shaders-and-glsl-shaders-mod/
    Choose whichever shaderpack you want. I will be posting comparison photos of each of the packs soon.

    Once done downloading, take the ShadersModCore.jar and put it into your FTBModpack\minecraft\mods folder. Run minecraft, then exit once you get to the main menu. Open up the FTBModpack\minecraft\shaderpacks\ folder. Place the SEUS v10.zip shaderpack inside that folder.

    TIP: If the shaders aren't automatically loaded when you start minecraft, press escape, click on video settings, then shaders. Double click on the option that doesn't say default, or none.

    Proof that it works with FTB. Remember, these are all in-game screenshots. I've added no effects to them.

    [​IMG]

    [​IMG]
     
    Last edited: Dec 14, 2013
    misabiko, MrZwij and Velotican like this.
  2. Velotican

    Velotican New Member

    I remember this being so much more awkward to pull off than it is these days.

    Thanks for this guide. Now if only Minecraft actually had multithreading.
     
  3. SublightNova

    SublightNova New Member

    Thanks for writing up the guide..

    >> Excuse my noobness.. Before I wrote it didn't work.. but it does...

    Nice guide... ! :)

    Colors look weirdish though... a bit brownish etc... washed out...

    But have to say the water, moving leaves/grass are absolutely brilliant. :)

    >> another edit.. Using the supplied texture packs actually works better... just tried the sphax 128x pack and it looks absolutely gorgeous. I'm playing with shaders from now on. :)
     
  4. Seananners07

    Seananners07 New Member

    I've managed to get shaders to work in vanilla minecraft but every time I've tried to install it on FtB I have failed. I'm going to give this one a try (or three) and see if I can manage to work it out.

    I'll be editing to let you guys know how it goes :D

    Edit#1: Having trouble getting it to work :/ I started with a fresh copy of Direwolf20. I'll give it a few more tries to see what I come up with
     
  5. Zica

    Zica New Member


    Make sure your using MultiMc. I haven't found a way to get it to work with the FTB launcher yet. I have no idea why though
     
  6. tedyhere

    tedyhere New Member

    There a good shader pack that doesn't have the waving grass and leaves? It's making me kind of sick when playing lol
     
  7. espri

    espri New Member


    Also can't seem to get it to work :(
    Followed the directions to a T and it just doesn't seem to want to work! The game launches perfectly fine (through Multi MC), but it looks no different. I'm not very good with this kind of stuff so hopefully you are able to find a fix and post it.. maybe we're both doing something wrong ;P
     
  8. Seananners07

    Seananners07 New Member


    That is what kept happening to me. I would run it through multimc and it would show that Optifine had been installed just fine and what not. When it come to the graphics/shaders though, nothing was different. I'll try and post some screens later today
     
  9. tedyhere

    tedyhere New Member

    Did you go into options and video setting and click the shaders button? That's where you choose the shaders
     
  10. Velotican

    Velotican New Member

    No shaders is the default setting in the mod. You will need to actually select a shader pack (like a texture pack) to activate it.
     
  11. Zica

    Zica New Member

    I updated the main post with a method of using shaders without having to use MultiMc.
     
  12. Seananners07

    Seananners07 New Member

    I'm sorry that I'm being overly difficult :/
    When I use the texture pack that is in the Zeus folder, everything turns out blue. I'm assuming I dun goofed up

    Edit: I tried installing it directly to the FtB launcher and it worked! I was most likely messing up with the other tool Thank you so much for dealing with me :D
     
  13. sig_kill

    sig_kill New Member

    Hi,

    What did you end up doing for this? I followed the instructions in the original post (as well as made up my own after things didn't work).

    I did the following:

    1. Unpacked both Optifine D3 and GLSL Shaders mod
    2. Copy (and replaced) the class files inside the extracted Optifine folder with the ones from the shader mod
    3. Repacked the Optifine folder, keeping the original structure intact (but the new class files for the shaders mod in place)
    4. Copied that repackaged optifine zip to the instMods folder
    5. Copied the shader zip to minecraft/shaderpacks/SUES_v10rc6_Karyonix_1.30 D3.zip
    6. Copied the colour-altered default texture pack to minecraft/texturepacks
    I ran the game, optifine was loaded, and I could select a shader pack. I selected the SEUS shaders and here is what I got:

    http://imgur.com/a/FFL5c#0

    The ground with the shaders and the updated texture pack make everything look black. The second I turn the shaders off, I get a colourized texture pack, and when I set the texturepack back to the original, everything is normal.

    I made sure I turned off all of the settings:

    A. FOV at Default.​
    B. Fog: OFF.​
    C. Quality > Custom Colors: ON​
    D. Quality > Anisotropic Filtering: OFF​
    E. Quality > Antialiasing: OFF​
    F. Quality > Connected Textures: OFF​

    And then I turned off any custom config I had set up for javaw.exe in the nVidia control panel.
    My graphics card is an EVGA GTX465 (superclocked version --- factory overclock).
     
  14. Zica

    Zica New Member

    Don't unpack and repack optifine. If you use winrar, just drag the contents of the GLSL shaders mod into optifine.
     
  15. sig_kill

    sig_kill New Member

    Just tried this with the same results... not sure what I'm doing wrong.

    Running Forgemod .518
    Optifine HD Ultra D3
    ShadersMod-mc1.4.6-ofud3-1.33
    SEUS_v10rc6_Karyonix_1.30 D3 shaders
     
  16. VikeStep

    VikeStep New Member

    Just a question, will I have to update forge for this to work since Optifine isn't compatible with the current version.

    also will updating forge mean other mods won't work
     
  17. DevinDragonFlame

    DevinDragonFlame New Member

    I'm also having the same issue as Sig-kill. It's not like the directions are terribly complicated, but I end up only seeing a ton of black and the sunlight if it's daytime.

    Each time I try to enable the shader in-game, the console says it can't open the shader files.
    screencap.jpg
     
  18. sig_kill

    sig_kill New Member

    I'm not sure if this is relevant, but if you have Optifine HD Ultra D3 (ofud3) installed, from the looks of the name of your shader pack, you have a set for Optifine Ultra A2 (ofua2). I found a set of shaders for ofud3 here: http://www.mediafire.com/?6hzx4r7a3v7rqcf


    I updated forge to .518 (which is what the Optifine documentation said it was compatible with) with no problems. Back up the old forgemod, grab .518 (from http://www.minecraftforge.net/forum/index.php?action=files), and drop it in your instMod folder if you're running FTB.
     
  19. DevinDragonFlame

    DevinDragonFlame New Member

    Well, that's strange. Not sure how I got the wrong file, I used the links in the OP... oh well. I tried the file you found for me (thanks, btw!) and changed my forge to 518 and this time, when I enable the shader, I don't get any more blackness... however, I also don't get shaders either. It just looks like normal minecraft.

    I'm testing this from my work computer, which might be different, but it's got a decent video card and I would think it would work just fine. It's an nVidia GT 620. I'll try again when I get home, maybe it'll work on my main computer. Will report back if it worked or not then.

    Edit: I found one that works! http://www.mediafire.com/?9jm2v2gfddxwdgp This file, combined with the forge 518 makes beautiful shaders that crush my puny work computer's framerate to dust. I'll have to try this at home where my main machine can handle the awesomeness.
     
  20. sig_kill

    sig_kill New Member

    Yeah, I noticed that late last night too... Seems the files in OPs post are a bit mixed up.

    Your edited shaders, do you by chance run a GTX 460 at home? I tried those ones because I have a 460 (series) card, but I still get the blackness. What were your steps to get the FTB launcher running with the updated shader set? Hopefully I can give it another whack tonight and get it working.
     

Share This Page