1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Problem Ticking world?!

Discussion in 'General FTB chat' started by oso, Jul 28, 2019.

  1. oso

    oso Guest

    Hello guys so can you guys help me out with my world crashing?

    Description: Exception ticking world

    java.lang.NullPointerException: Exception ticking world
    at drzhark.mocreatures.entity.MoCEntityAmbient.func_70601_bi(MoCEntityAmbient.java:521)
    at net.minecraft.world.SpawnerAnimals.func_77192_a(SpawnerAnimals.java:252)
    at net.minecraft.world.WorldServer.func_72835_b(WorldServer.java:161)
    at WorldServerOF.func_72835_b(WorldServerOF.java:234)
    at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:625)
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:547)
    at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:186)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427)
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- Head --
    Stacktrace:
    at drzhark.mocreatures.entity.MoCEntityAmbient.func_70601_bi(MoCEntityAmbient.java:521)
    at net.minecraft.world.SpawnerAnimals.func_77192_a(SpawnerAnimals.java:252)
    at net.minecraft.world.WorldServer.func_72835_b(WorldServer.java:161)
    at WorldServerOF.func_72835_b(WorldServerOF.java:234)

    -- Affected level --
    Details:
    Level name: efwefwe
    All players: 1 total; [EntityPlayerMP['Ziekeman55'/517, l='efwefwe', x=-21.13, y=123.25, z=268.81]]
    Chunk stats: ServerChunkCache: 289 Drop: 0
    Level seed: -6474272073312901166
    Level generator: ID 00 - default, ver 1. Features enabled: false
    Level generator options:
    Level spawn location: World: (0,0,0), Chunk: (at 0,0,0 in 0,0; contains blocks 0,0,0 to 15,255,15), Region: (0,0; contains chunks 0,0 to 31,31, blocks 0,0,0 to 511,255,511)
    Level time: 0 game time, 0 day time
    Level dimension: 0
    Level storage version: 0x00000 - Unknown?
    Level weather: Rain time: 0 (now: false), thunder time: 0 (now: false)
    Level game mode: ~~ERROR~~ NullPointerException: null
    Stacktrace:
    at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:625)
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:547)
    at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:186)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427)
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)

    -- System Details --
    Details:
    Minecraft Version: 1.7.10
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_221, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 14793236128 bytes (14107 MB) / 16106127360 bytes (15360 MB) up to 16106127360 bytes (15360 MB)
    JVM Flags: 5 total; -Xms15360m -Xmx15360m -XX:+UseG1GC -XX:MaxGCPauseMillis=4 -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 15, tcache: 0, allocated: 13, tallocated: 95
    FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1614 Optifine OptiFine_1.7.10_HD_U_D6 78 mods loaded, 78 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJAAAA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJAAAA FML{7.10.99.99} [Forge Mod Loader] (modpack.jar)
    UCHIJAAAA Forge{10.13.4.1614} [Minecraft Forge] (modpack.jar)
    UCHIJAAAA CodeChickenCore{1.0.7.47} [CodeChicken Core] (minecraft.jar)
    UCHIJAAAA ivtoolkit{1.2.1} [IvToolkit] (minecraft.jar)
    UCHIJAAAA LambdaLib|Core{1.2.3} [LambdaLib|Core] (minecraft.jar)
    UCHIJAAAA Micdoodlecore{} [Micdoodle8 Core] (minecraft.jar)
    UCHIJAAAA NotEnoughItems{1.0.5.120} [Not Enough Items] (NotEnoughItems-1.7.10-1.0.5.120-universal.jar)
    UCHIJAAAA OpenModsCore{0.10} [OpenModsCore] (minecraft.jar)
    UCHIJAAAA <CoFH ASM>{000} [CoFH ASM] (minecraft.jar)
    UCHIJAAAA mod_ThreadedLighting{1.7.10-1.0} [Threaded Lighting] (minecraft.jar)
    UCHIJAAAA gilded-games-util{1.7.10-1.2} [Gilded Games Utility] (gilded-games-util-1.7.10-1.9.jar)
    UCHIJAAAA battlegear2{1.7.10} [Mine & Blade Battlegear 2 - Bullseye] (1.7.10-MB_Battlegear2-Bullseye-1.0.8.3.jar)
    UCHIJAAAA divinerpg{1.4.1.4} [DivineRPG] ([1.7.10][SMP]DivineRPG-1.4.1.4.jar)
    UCHIJAAAA bspkrsCore{6.15} [bspkrsCore] ([1.7.10]bspkrsCore-universal-6.15.jar)
    UCHIJAAAA Treecapitator{1.7.10} [Treecapitator] ([1.7.10]Treecapitator-universal-2.0.4.jar)
    UCHIJAAAA abyssalcraft{1.9.1.3} [AbyssalCraft] (AbyssalCraft-1.7.10-1.9.1.3-FINAL.jar)
    UCHIJAAAA Baubles{1.0.1.10} [Baubles] (Baubles-1.7.10-1.0.1.10.jar)
    UCHIJAAAA adventurebackpack{1.7.10-0.8b} [Adventure Backpack] (adventurebackpack-1.7.10-0.8c.jar)
    UCHIJAAAA aether_legacy{v1.0.1} [Aether Legacy] (aether_legacy-1.7.10-v1.0.1.jar)
    UCHIJAAAA nevermine{Tslat-1.1.3} [Advent of Ascension] (AoA.jar)
    UCHIJAAAA gibby_dungeons{1.7} [Arcana RPG] (Arcana RPG 1.6.2-1.7.10.jar)
    UCHIJAAAA ArchimedesShips{1.7.10 v1.7.1} [Archimedes' Ships] (Archimedes-Ships-Mod-1.7.10.jar)
    UCHIJAAAA atum{0.6} [Atum] (Atum-1.7.10-0.6.77.jar)
    UCHIJAAAA Thaumcraft{4.2.3.5} [Thaumcraft] (Thaumcraft-1.7.10-4.2.3.5.jar)
    UCHIJAAAA Botania{r1.8-249} [Botania] (Botania+r1.8-249.jar)
    UCHIJAAAA Avaritia{1.13} [Avaritia] (Avaritia-1.13.jar)
    UCHIJAAAA CoFHCore{1.7.10R3.1.4} [CoFH Core] (CoFHCore-[1.7.10]3.1.4-329.jar)
    UCHIJAAAA BrandonsCore{1.0.0.12} [Brandon's Core] (Brandons-Core-1.7.10.jar)
    UCHIJAAAA ChestTransporter{2.0.6} [Chest Transporter] (ChestTransporter-1.7.10-2.0.6.jar)
    UCHIJAAAA chocolateQuest{1.0} [Chocolate Quest] (chocolateQuest-1.7.10-1.0.jar)
    UCHIJAAAA customnpcs{1.7.10d} [CustomNpcs] (CustomNPCs_1.7.10d(29oct17).jar)
    UCHIJAAAA DamageIndicatorsMod{3.3.2} [Damage Indicators] (Damage-Indicators-Mod-1.7.10.jar)
    UCHIJAAAA DraconicEvolution{1.0.2h} [Draconic Evolution] (Draconic-Evolution-1.7.10-1.0.2h.jar)
    UCHIJAAAA MoCreatures{6.3.1} [DrZhark's Mo'Creatures Mod] (DrZharks MoCreatures Mod v6.3.1.zip)
    UCHIJAAAA wizardry{1.1.5} [Electroblob's Wizardry] (Electroblob's+Wizardry+-+1.1.5+-+MC+1.7.10.jar)
    UCHIJAAAA ForgeMultipart{1.2.0.345} [Forge Multipart] (ForgeMultipart-1.7.10-1.2.0.345-universal.jar)
    UCHIJAAAA ExtraUtilities{1.2.12} [Extra Utilities] (extrautilities-1.2.12.jar)
    UCHIJAAAA farlanders{1.2b} [The Farlanders] (Farlanders-Mod-1.7.10.jar)
    UCHIJAAAA Mantle{1.7.10-0.3.2.jenkins191} [Mantle] (Mantle-1.7.10-0.3.2b.jar)
    UCHIJAAAA GalacticraftCore{3.0.12} [Galacticraft Core] (GalacticraftCore-1.7-3.0.12.504.jar)
    UCHIJAAAA GalacticraftMars{3.0.12} [Galacticraft Planets] (Galacticraft-Planets-1.7-3.0.12.504.jar)
    UCHIJAAAA ganysend{1.11.3} [Gany's End] (Ganys+End-1.11.3.jar)
    UCHIJAAAA ganysnether{1.8.3} [Gany's Nether] (Ganys+Nether-1.8.3.jar)
    UCHIJAAAA gemsplus{1.7.10} [Gems+] (gemsplus-1.7-mc1.7.10.jar)
    UCHIJAAAA iChunUtil{4.2.3} [iChunUtil] (iChunUtil-4.2.3.jar)
    UCHIJAAAA Hats{4.0.1} [Hats] (Hats-4.0.1.jar)
    UCHIJAAAA InventoryPets{1.5.2} [Inventory Pets] (inventorypets-1.7.10-1.5.2-universal.jar)
    UCHIJAAAA inventorytweaks{1.59-dev-152-cf6e263} [Inventory Tweaks] (InventoryTweaks-1.59-dev-152.jar)
    UCHIJAAAA IronChest{6.0.62.742} [Iron Chest] (ironchest-1.7.10-6.0.62.742-universal.jar)
    UCHIJAAAA journeymap{5.1.4p1} [JourneyMap] (JourneyMap-Mod-1.7.10-Unlimited.jar)
    UCHIJAAAA LambdaLib{1.2.3} [LambdaLib] (LambdaLib-1.7.10.jar)
    UCHIJAAAA llibrary{1.5.1} [LLibrary] (llibrary-1.5.1-1.7.10.jar)
    UCHIJAAAA lucky{5.1.0} [Lucky Block] (Lucky-Block-Mod-1.7.10.jar)
    UCHIJAAAA malisiscore{1.7.10-0.14.3} [MalisisCore] (malisiscore-1.7.10-0.14.3.jar)
    UCHIJAAAA malisisdoors{1.7.10-1.13.2} [Malisis' Doors] (malisisdoors-1.7.10-1.13.2.jar)
    UCHIJAAAA MetallurgyCore{4.0.4} [Metallurgy Core] (MetallurgyCore-1.7.10-4.0.4.18 (1).jar)
    UCHIJAAAA Metallurgy{4.0.6} [Metallurgy 4] (Metallurgy-1.7.10-4.0.6.80.jar)
    UCHIJAAAA MoreBows2{1.2} [More Bows 2] (More-Bows-2-Mod-1.7.10.jar)
    UCHIJAAAA MoreFurnaces{1.3.9} [More Furnaces] (MoreFurnaces-1.3.9-MC1.7.10.jar)
    UCHIJAAAA mowziesmobs{1.2.9} [Mowzie's Mobs] (MowziesMobs-1.2.99.jar)
    UCHIJAAAA notenoughIDs{1.4.3.4} [NotEnoughIDs] (NotEnoughIDs-1.4.3.4.jar)
    UCHIJAAAA OpenMods{0.10} [OpenMods] (OpenModsLib-1.7.10.jar)
    UCHIJAAAA OpenBlocks{1.6} [OpenBlocks] (OpenBlocks-Mod-1.7.10.jar)
    UCHIJAAAA harvestcraft{1.7.10j} [Pam's HarvestCraft] (Pam's+HarvestCraft+1.7.10Lb.jar)
    UCHIJAAAA reccomplex{0.9.7.1.1} [Recurrent Complex] (RecurrentComplex-0.9.7.1.1.jar)
    UCHIJAAAA RedstoneArsenal{1.7.10R1.1.2} [Redstone Arsenal] (RedstoneArsenal-[1.7.10]1.1.2-92.jar)
    UCHIJAAAA SpecialMobs{3.2.2} [Special Mobs] (SpecialMobs-1.7.10-3.2.2.jar)
    UCHIJAAAA thebetweenlands{1.0.6-alpha} [The Betweenlands] (TheBetweenlands-1.0.6-alpha-universal (1).jar)
    UCHIJAAAA erebus{0.4.7} [Erebus] (TheErebus-0.4.7 (3).jar)
    UCHIJAAAA TwilightForest{2.3.7} [The Twilight Forest] (twilightforest-1.7.10-2.3.7.jar)
    UCHIJAAAA Artifacts{1.0.4} [Artifacts] (Unique-Artifacts-Mod-1.7.10 (1).jar)
    UCHIJAAAA Waila{1.5.10} [Waila] (Waila-1.5.10_1.7.10.jar)
    UCHIJAAAA WailaHarvestability{1.1.6} [Waila Harvestability] (WailaHarvestability-mc1.7.10-1.1.6.jar)
    UCHIJAAAA wildcaves3{1.7.10} [Wild Caves 3] (Wild-Caves-Mod-1.7.10.jar)
    UCHIJAAAA witchery{0.24.1} [Witchery] (witchery-1.7.10-0.24.1.jar)
    UCHIJAAAA McMultipart{1.2.0.345} [Minecraft Multipart Plugin] (ForgeMultipart-1.7.10-1.2.0.345-universal.jar)
    UCHIJAAAA ForgeMicroblock{1.2.0.345} [Forge Microblocks] (ForgeMultipart-1.7.10-1.2.0.345-universal.jar)
    GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
    OpenModsLib class transformers: [stencil_patches:FINISHED],[movement_callback:FINISHED],[player_damage_hook:FINISHED],[map_gen_fix:FINISHED],[gl_capabilities_hook:FINISHED],[player_render_hook:FINISHED]
    Class transformer null safety: all safe
    CoFHCore: -[1.7.10]3.1.4-329
    Mantle Environment: DO NOT REPORT THIS CRASH! Unsupported mods in environment: optifine
    RedstoneArsenal: -[1.7.10]1.1.2-92
    Stencil buffer state: Function set: GL30, pool: forge, bits: 8
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Player Count: 1 / 8; [EntityPlayerMP['Ziekeman55'/517, l='efwefwe', x=-21.13, y=123.25, z=268.81]]
    Type: Integrated Server (map_client.txt)
    Is Modded: Definitely; Client brand changed to 'fml,forge'
    OptiFine Version: OptiFine_1.7.10_HD_U_D6
    Render Distance Chunks: 8
    Mipmaps: 4
    Anisotropic Filtering: 1
    Antialiasing: 0
    Multitexture: false
    OpenGlVersion: 4.6.0 NVIDIA 430.86
    OpenGlRenderer: GeForce GTX 1660 Ti/PCIe/SSE2
    OpenGlVendor: NVIDIA Corporation
    CpuCount: 12

    I know that mocreatures causes the crash but i dont want to remove the mod because i have alot of pets ):
     
  2. Senseidragon

    Senseidragon Well-Known Member

    @oso, you might have better luck reporting this on the Mo' Creatures Issue Tracker, which can be found here: https://github.com/DrZhark/mocreatures/issues

    Be aware that the 1.7.10 version of the mod hasn't really been significantly updated since 2015.

    Best of luck to you!

    Edit: Also, you might want to see if you still get the crash after disabling Optifine. If you still get the crash, go to that link above and report it.
     
    Last edited: Jul 29, 2019
  3. Drbretto

    Drbretto Popular Member

    this happens all the time, especially with mo creatures. It's a bugged entity and basically the only fix is to delete it.

    You'll have to do a little bit of legwork yourself, but there's a configuration file built into forge with a line you can edit to go through and delete ticking entities. You'd go in, edit that line, open the world, exit, edit the line back and load again and you should be good. Alternatively, if it's definitely coming from mo creatures, you can remove that mod, load the world, then exit and add the mod back in. It will delete all entities from mo creatures, though, so if you have yourself a zoo, you'll lose it all.
     
    Senseidragon likes this.

Share This Page