Open Thermal Expansion machines lose upgrades and reset configuration

Discussion in 'FTB Beyond' started by Electrofried, Mar 18, 2017.

  1. Electrofried

    Electrofried Guest

    Summary of the problem Thermal Expansion machines lose upgrades and reset configuration

    Pack Version 1.1.0

    What is the bug? When leaving the dimension or area that the Thermal expansion machines are located, they will sometimes reset to basic tier. They lose all upgrades installed and reset the output configuration to default.

    Mod & Version Thermal Expansion 5.0.3.86

    Link to log file No log available

    Is it repeatable? Yes, place the machine, upgrade it and leave area/dimension a few times.

    Known Fix Don't upgrade thermal expansion machines .
     
  2. asim0v

    asim0v New Member

    Having this same issue on a Beyond v1.2.1 server.
     
  3. VanDerProtofsky

    VanDerProtofsky New Member

    From the same server asim0v refers to, we've had reports of the following issues which I believe are connected to OP's report:
    What these reports have in common is that:
    • The data appears to be lost randomly upon chunk unload
    • These are happening in FTBU claimed chunks (chunkloading seems to have no effect)
    A theory that two of us have, is that something with the chunk claiming system is causing tile entities to lose their data, upon chunk unload (or load?). This is a pretty bad issue as most of FTB play is with tile entities, and this is frustrating enough to cause players to quit playing Beyond.
     
  4. VanDerProtofsky

    VanDerProtofsky New Member

    After further testing, this doesn't appear to be caused by the chunk claiming system. Testing reproduction:

    1. At least 1000 blocks away from spawn, set up a mana pool and drop a creative mana tablet inside to fill it with mana
    2. In the same area, set up Thermal Expansion machines (any) and a magmatic dynamo like pictured
      • Does not have to be exact, but both machines should be at least powered and have non-default side configurations
    3. Do /sethome test
    4. Do /spawn to teleport back to spawn
    5. Do /save-all to instantly unload chunks
    6. Do /home test to teleport back to testing area
    7. Repeat steps 4 to 6 until the mana pools become empty and/or the thermal expansion machines get reset
     
  5. modmuss50

    modmuss50 Guest

    Is this in single or multiplayer? Do you have sponge or any customized mods installed?
     
  6. VanDerProtofsky

    VanDerProtofsky New Member

    Multiplayer; using the standard Forge server but with some config changes (don't have list of specific changes available at the moment). We've also added Dynmap-Forge and PurpleIRC-Forge, but was able to reproduce the issue without both present.

    I can try to test this on a fresh installation of Beyond 1.2.1 multiplayer.
     
  7. Electrofried

    Electrofried Guest

    In our case it is a server, no sponge and only extra mod is discordchat.
     
  8. EZKatnipz

    EZKatnipz Guest

    I'm having the same issue on my server. However, the machines seem to reset no mater if there are upgrades. The tank will lose the lava i have in it whenever i get back on my server. Using quite a few mods though, custom built modpack. Using latest version of Sponge on my server. Minecraft version 1.10.2 i can link to my modpack and give some more information if needed to help solve the issue.
     
  9. VanDerProtofsky

    VanDerProtofsky New Member

    We don't know how or why, but we were able to "fix" this issue by rebuilding the server. Our asim0v did this by:
    1. Redownloading the Beyond 1.2.1 server package and extracting it to a new folder
    2. Copying everything over except for the "enderio" and "woot" folders
    This is the diff between the old server folder and the new server folder. Setting Forge's dormantChunkCacheSize to the default of 0 did not seem to be the issue when we tried it before rebuild. So either it was having old enderio or woot data around that apparently caused the issue, or something else we're missing.

    Also, this bug is not reproducible in a fresh (untouched) server install of Beyond 1.2.1.
     
  10. Hazmatik

    Hazmatik New Member

    I had this happen to me on the server I play on, but the difference was my redstone furnace reset when i picked it up and placed it again. It was resonant with 2 of the secondary reception coil augments in it, after picking it up using the crescent hammer and placing it again it was back to basic tier. This only happened with the Redstone Furnace, at the same time I moved a pulverizer, magma crucible, and fluid transposer all resonant but the redstone furnace was the only one that got reset.
     
  11. EZKatnipz

    EZKatnipz Guest

    I believe the problem has been solved since I updated my pack with the most resent versions of CoFH, Thermal Expansion and Thermal Foundation. Since the update, I have not experienced the issue.
    Edit: Never mind, the issue returned.
     
    Last edited: Apr 8, 2017
  12. EZKatnipz

    EZKatnipz Guest

  13. john01dav

    john01dav Active Member

    I just want to contribute a bit of information:
    • This issue happens with AE as well, which I haven't seen mentioned here.
    • FTBUtilities is not responsible. I run a custom chunk loading plugin and a different claiming plugin on my server instead, and FTBU isn't installed.
    • The issue started yesterday, right as I enabled Forge's dormant chunk cache. I just disabled it and I'll try to report back here with the results.
     
  14. mbbkraft

    mbbkraft New Member

    Hey i have the same problem here with the All the Mods 3 modpack, both AE2 and TE are reseting by chunk sometimes i dont know why. Did you found what was the problem ?
     

Share This Page